summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFathi Boudra <fabo@debian.org>2009-10-02 19:22:22 +0200
committerFathi Boudra <fabo@debian.org>2009-10-02 19:22:22 +0200
commit7f8a6e20e1d3ba0f1e7d0ee73bd536185cc691e7 (patch)
treec4ccb7a9ecc4cdf403df5d76c340bda2a61e3418
parenta27a7c70a0e1a715ad57d4daf37619a90d5058e1 (diff)
downloadqt4-x11-7f8a6e20e1d3ba0f1e7d0ee73bd536185cc691e7.tar.gz
Merge changes done on Qt 4.6.0 git:
- Build translations - Generate include directory - Clean *.a files - Create translations directory
-rw-r--r--debian/changelog2
-rwxr-xr-xdebian/rules15
2 files changed, 12 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 9c6424c..5c06a7d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -16,7 +16,7 @@ qt4-x11 (4:4.5.3-1) UNRELEASED; urgency=low
* Bump Standards-Version to 3.8.3: no changes needed.
+++ Changes by Fathi Boudra:
-
+
* Add qt-coy patches:
- 0288-more-x-keycodes.diff
Fill gap of X.org/XFree multimedia/special/launcher keys. Qt up to 4.5.x
diff --git a/debian/rules b/debian/rules
index 2b4e232..94b858d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,7 @@
#!/usr/bin/make -f
+#export DH_VERBOSE=1
+
export QTDIR := $(shell pwd)
export PATH := $(QTDIR)/bin:$(PATH)
# workaround to use lrelease.
@@ -67,14 +69,15 @@ common-build-arch:: debian/stamp-makefile-build-tools
debian/stamp-makefile-build-tools: debian/stamp-makefile-build
$(MAKE) sub-tools
- # Test current version is a snapshot
-ifeq (snapshot, $(findstring snapshot, $(CURRENTVERSION)))
# Build documentations
$(MAKE) docs
+ # Build translations
+ $(MAKE) ts
+ $(MAKE) qm
# Workaround: It's a known qmake limitation.
# It can't generate install rules for files that don't exist yet like docs.
./config.status
-endif
+
touch $@
common-configure-arch:: config.status
@@ -100,6 +103,9 @@ endif
rm -rf mkspecs/glibc-g++
cp -a mkspecs/linux-g++ mkspecs/glibc-g++
+ # Generate include
+ rm -rf include && QTDIR=. perl bin/syncqt
+
./configure -confirm-license \
-prefix "/usr" \
-bindir "/usr/bin" \
@@ -184,7 +190,7 @@ clean::
# Leftover files and all symlinks
find \( -false \
- -o -name \*.a \
+ -o -type f -name \*.a \
-o -name Makefile.Debug \
-o -name Makefile.Release \
-o -name \*.o \
@@ -220,6 +226,7 @@ common-install-arch::
-exec sed -i -e "/^QMAKE_PRL_BUILD_DIR/d;s/\(QMAKE_PRL_LIBS =\).*/\1/" {} \;
install/libqtcore4::
+ mkdir -p $(DEB_DESTDIR)/usr/share/qt4/translations
$(CURDIR)/bin/lrelease-qt4 debian/translations/qt_ca.ts \
-qm $(DEB_DESTDIR)/usr/share/qt4/translations/qt_ca.qm