summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFathi Boudra <fabo@debian.org>2009-10-09 11:45:32 +0200
committerFathi Boudra <fabo@debian.org>2009-10-09 11:45:32 +0200
commitb7a18b288d840c09e67639509e0e369963f714ef (patch)
tree8fab612edd177e16b22d8d81699d4e9975c5b5f7
parenta8c6f0f7ba2f0336f877198990678219afa6b4bd (diff)
downloadqt4-x11-b7a18b288d840c09e67639509e0e369963f714ef.tar.gz
* Add Debian patch: 12_add_nostrip_for_debug_packages
Set nostrip to generate debug packages as expected. * Cleanup debian/rules: remove deprecated .debug handling.
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/12_add_nostrip_for_debug_packages.diff16
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules9
4 files changed, 20 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index efc4a9a..610f6b5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,9 @@ qt4-x11 (4:4.6.0~~tp1+git1336+gc5c58c2-0fabo1) experimental-snapshots; urgency=l
upstream.
* Remove Debian patches:
- 14_add_libraries_to_gui_build_where_actually_needed - fixed upstream.
+ * Add Debian patches:
+ - 12_add_nostrip_for_debug_packages
+ Set nostrip to generate debug packages.
* Update debian/control:
- Remove Brian Nelson from uploaders field.
Thanks for his great work on Qt.
diff --git a/debian/patches/12_add_nostrip_for_debug_packages.diff b/debian/patches/12_add_nostrip_for_debug_packages.diff
new file mode 100644
index 0000000..438cc4a
--- /dev/null
+++ b/debian/patches/12_add_nostrip_for_debug_packages.diff
@@ -0,0 +1,16 @@
+author: Fathi Boudra <fabo@debian.org>
+
+Qt is built in release mode and strip files by default.
+Set CONFIG+=nostrip to avoid the stripping and
+let dh_strip do it to generate debug packages.
+
+--- a/configure
++++ b/configure
+@@ -644,6 +644,7 @@ rm -f "$outpath/config.tests/.qmake.cach
+ cp "$QMAKE_VARS_FILE" "$outpath/config.tests/.qmake.cache"
+
+ QMakeVar add QMAKE_LFLAGS -Wl,--as-needed
++QMakeVar add CONFIG nostrip
+
+ QMakeVar add styles "cde mac motif plastique cleanlooks windows"
+ QMakeVar add decorations "default windows styled"
diff --git a/debian/patches/series b/debian/patches/series
index 04bb02a..6857718 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -17,6 +17,7 @@
09_qmake_lflags_as-needed.diff
10_config_tests_fixes.diff
11_build_translations.diff
+12_add_nostrip_for_debug_packages.diff
15_fix_qmake_makefile_generation.diff
16_hide_std_symbols_on_qtwebkit.diff
17_add_postgresql_8.3_support.diff
diff --git a/debian/rules b/debian/rules
index 6c3ff68..b012250 100755
--- a/debian/rules
+++ b/debian/rules
@@ -230,10 +230,6 @@ override_dh_auto_install:
debian/desktop/qtconfig.png.uu
override_dh_install:
-# # Run dh_install without the exclude argument to install the *.debug files
-# $(foreach pkg,$(pkgs_dbg),dh_install -p$(pkg) --sourcedir=debian/tmp;)
-# # Ensure the *.debug files aren't included in any package other than *-dbg
-# dh_install --remaining-packages --sourcedir=debian/tmp --exclude=.debug
dh_install --list-missing --sourcedir=debian/tmp
override_dh_installdocs:
@@ -243,8 +239,6 @@ override_dh_installchangelogs:
dh_installchangelogs $(upstream_changes)
override_dh_strip:
-# $(foreach pkg,$(pkgs_dbg),dh_strip -p$(pkg) --exclude=.debug;)
-# dh_strip --remaining-packages
$(foreach pkg,$(pkgs_dbg),dh_strip -p$(pkg) --dbg-package=$(pkg)-dbg;)
dh_strip -plibphonon4 --dbg-package=phonon-dbg
dh_strip --remaining-packages --dbg-package=libqt4-dbg
@@ -261,7 +255,4 @@ override_dh_makeshlibs:
fi \
done
-#override_dh_shlibdeps:
-# dh_shlibdeps --exclude=.debug
-
.PHONY: override_dh_auto_test