summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFathi Boudra <fabo@debian.org>2010-03-26 09:07:06 +0100
committerFathi Boudra <fabo@debian.org>2010-03-26 09:07:06 +0100
commitbc5773bc3421dfe4807492bb3b325df794aebccc (patch)
tree67d111175df20d4e9b2b60ba67cc3c82999ede81
parent9faac02c10cd80b254e9766ea1445d579c987c7c (diff)
downloadqt4-x11-bc5773bc3421dfe4807492bb3b325df794aebccc.tar.gz
Add 0002_qmake_qfileinfo_absolutepath.diff
Fixed QFileInfo::absolutePath() warning when running "qmake -project" (Closes: #574043)
-rw-r--r--debian/changelog9
-rw-r--r--debian/patches/0002_qmake_qfileinfo_absolutepath.diff22
2 files changed, 28 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index c0479c2..adf2902 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,11 @@
-qt4-x11 (4:4.6.2-2) UNRELEASED; urgency=low
+qt4-x11 (4:4.6.2-2) experimental; urgency=low
- * Add upstream patch:
+ * Add upstream patches:
- 0001_qpixmap_load_no_modify_referenced_copies.diff
Fixed QPixmap::load() to not modify referenced copies.
+ - 0002_qmake_qfileinfo_absolutepath.diff
+ Fixed QFileInfo::absolutePath() warning when running "qmake -project"
+ (Closes: #574043)
* Fix FTBFS on sparc caused by a wrong platform_arg value:
check for exact string match (instead of findstring usage).
* Fix FTBFS on ia64: -m64 option isn't recognized by gcc.
@@ -971,7 +974,7 @@ qt4-x11 (4.3.4-2) unstable; urgency=low
* Exclude debug files from dh_shlibdeps using DEB_DH_SHLIBDEPS_ARGS_ALL.
* Update configure options to use libtiff from system.
* Remove debug configure option to build with -02.
- * Update common-install-arch target to fix wrong path in pkconfig and prl files.
+ * Update common-install-arch target to fix wrong path in pkgconfig and prl files.
* Add libtiff4-dev build dependency.
* Update libqt4-dev dependencies.
diff --git a/debian/patches/0002_qmake_qfileinfo_absolutepath.diff b/debian/patches/0002_qmake_qfileinfo_absolutepath.diff
new file mode 100644
index 0000000..6819b17
--- /dev/null
+++ b/debian/patches/0002_qmake_qfileinfo_absolutepath.diff
@@ -0,0 +1,22 @@
+From 05a1573eddc6dc404631c9d16474c81aa4cea569 Mon Sep 17 00:00:00 2001
+From: Andreas Kling <andreas.kling@nokia.com>
+Date: Wed, 3 Feb 2010 14:56:15 +0100
+Subject: [PATCH] Fixed QFileInfo::absolutePath() warning when running "qmake -project"
+
+Task-number: QTBUG-7176
+Reviewed-by: Benjamin Poulain <benjamin.poulain@nokia.com>
+---
+ qmake/project.cpp | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+--- a/qmake/project.cpp
++++ b/qmake/project.cpp
+@@ -3067,7 +3067,7 @@ QStringList &QMakeProject::values(const
+ place[var] = QStringList(pfile);
+ } else if(var == QLatin1String("_PRO_FILE_PWD_")) {
+ var = ".BUILTIN." + var;
+- place[var] = QStringList(QFileInfo(pfile).absolutePath());
++ place[var] = QStringList(pfile.isEmpty() ? qmake_getpwd() : QFileInfo(pfile).absolutePath());
+ } else if(var == QLatin1String("_QMAKE_CACHE_")) {
+ var = ".BUILTIN." + var;
+ if(Option::mkfile::do_cache)