summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFathi Boudra <fabo@debian.org>2010-03-19 16:54:59 +0100
committerFathi Boudra <fabo@debian.org>2010-03-19 16:54:59 +0100
commit9aff1bb67eea99688b54d7e69888bef0041b5a22 (patch)
treee39bb0dde9463d7ba71857abbe7e95b620d437b8
parent13867fd0a485233211167eab1c1350e2fd0f0f1e (diff)
downloadqt4-x11-9aff1bb67eea99688b54d7e69888bef0041b5a22.tar.gz
Add cherry-picked patch from upstream:
0001_qpixmap_load_no_modify_referenced_copies.diff
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/0001_qpixmap_load_no_modify_referenced_copies.diff44
-rw-r--r--debian/patches/series3
3 files changed, 55 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 714cb4f..a3e534e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+qt4-x11 (4:4.6.2-2) UNRELEASED; urgency=low
+
+ * Add upstream patch:
+ - 0001_qpixmap_load_no_modify_referenced_copies.diff
+ Fixed QPixmap::load() to not modify referenced copies.
+
+ -- Fathi Boudra <fabo@debian.org> Fri, 19 Mar 2010 16:28:34 +0100
+
qt4-x11 (4:4.6.2-1) experimental; urgency=low
* New upstream release (Closes: #571990).
diff --git a/debian/patches/0001_qpixmap_load_no_modify_referenced_copies.diff b/debian/patches/0001_qpixmap_load_no_modify_referenced_copies.diff
new file mode 100644
index 0000000..6d651eb
--- /dev/null
+++ b/debian/patches/0001_qpixmap_load_no_modify_referenced_copies.diff
@@ -0,0 +1,44 @@
+From 1ab5feb6260589f254ed209816cb67dbe9d3e4a5 Mon Sep 17 00:00:00 2001
+From: =?utf-8?q?Trond=20Kjern=C3=A5sen?= <trond@trolltech.com>
+Date: Mon, 1 Mar 2010 13:44:22 +0100
+Subject: [PATCH] Fixed QPixmap::load() to not modify referenced copies (again!)
+
+Change 8721d060a67a01ac891cab9d3d17aacf7373bcf0 broke the previous
+fix.
+
+Task-number: QTBUG-8606
+Reviewed-by: Gunnar
+---
+ src/gui/image/qpixmap.cpp | 19 ++++++-------------
+ 1 files changed, 6 insertions(+), 13 deletions(-)
+
+--- a/src/gui/image/qpixmap.cpp
++++ b/src/gui/image/qpixmap.cpp
+@@ -831,21 +831,14 @@ bool QPixmap::load(const QString &fileNa
+ if (QPixmapCache::find(key, *this))
+ return true;
+
+- bool ok;
+-
+- if (data) {
+- ok = data->fromFile(fileName, format, flags);
+- } else {
+- QScopedPointer<QPixmapData> tmp(QPixmapData::create(0, 0, QPixmapData::PixmapType));
+- ok = tmp->fromFile(fileName, format, flags);
+- if (ok)
+- data = tmp.take();
+- }
+-
+- if (ok)
++ QScopedPointer<QPixmapData> tmp(QPixmapData::create(0, 0, data ? data->type : QPixmapData::PixmapType));
++ if (tmp->fromFile(fileName, format, flags)) {
++ data = tmp.take();
+ QPixmapCache::insert(key, *this);
++ return true;
++ }
+
+- return ok;
++ return false;
+ }
+
+ /*!
diff --git a/debian/patches/series b/debian/patches/series
index 69be1b0..75ff80b 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,6 @@
+# upstream patches
+0001_qpixmap_load_no_modify_referenced_copies.diff
+
# qt-copy patches
0180-window-role.diff
0195-compositing-properties.diff