summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2010-04-11 22:12:59 +0300
committerModestas Vainius <modestas@vainius.eu>2010-04-11 22:12:59 +0300
commitcd34f080cb3da578f3e712a520603a8ac7a5df4c (patch)
tree000472aea55dcac291b084b620eead518121aadb
parentcee259bfc81ad858781ddb0ba4a4cfad6db01146 (diff)
downloadqt4-x11-cd34f080cb3da578f3e712a520603a8ac7a5df4c.tar.gz
Actually solve s390 FTBFS (in another way).
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/91_s390_use_gstabs.diff (renamed from debian/patches/91_s390_webkit_ftbfs_fixes.diff)7
-rw-r--r--debian/patches/96_powerpc_no_gc_sections.diff16
-rw-r--r--debian/patches/96_webkit_no_gc_sections.diff21
-rw-r--r--debian/patches/series4
5 files changed, 28 insertions, 27 deletions
diff --git a/debian/changelog b/debian/changelog
index de8d5da..891bacb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,10 @@
qt4-x11 (4:4.6.2-4~pre1) UNRELEASED; urgency=low
* Revert previous s390 specific change as it did not solve FTBFS.
- * Do not build with -ffunction-sections on s390. This should actually
- workaround FTBFS on s390 caused by internal linker error which is due to
- miscompilation of UString.o and others.
+ * Do not link webkit with -Wl,--gc-sections on s390. This should workaround
+ FTBFS on s390 caused by internal linker error which is due to bugs when
+ processing UString.o and some others (built with -ffunction-sections).
+ Implemented in the 96_webkit_no_gc_sections.diff patch.
-- Modestas Vainius <modax@debian.org> Sun, 11 Apr 2010 19:06:59 +0300
diff --git a/debian/patches/91_s390_webkit_ftbfs_fixes.diff b/debian/patches/91_s390_use_gstabs.diff
index db2405a..beaf524 100644
--- a/debian/patches/91_s390_webkit_ftbfs_fixes.diff
+++ b/debian/patches/91_s390_use_gstabs.diff
@@ -3,9 +3,6 @@ Author: Modestas Vainius <modax@debian.org>
Description: workaround webkit FTBFSes on s390
* Build s390 debugging symbols with -gstabs instead of with -g to reduce
linker memory usage. Thanks to Oswald Buddenhagen for the hint.
- * Do not build webkit with -ffunction-sections on s390 as it triggers internal
- linker error with "gcc (Debian 4.4.3-7) 4.4.3" / "ld 2.20.1-system.20100303"
- (there are problems with at least UString.o and some more).
Bug-Debian: http://bugs.debian.org/528485
Origin: vendor
Forwarded: no
@@ -13,7 +10,7 @@ Last-Update: 2010-04-11 (-ffunction-sections removal)
--- a/src/3rdparty/webkit/WebKit.pri
+++ b/src/3rdparty/webkit/WebKit.pri
-@@ -43,6 +43,16 @@ CONFIG(release, debug|release) {
+@@ -43,6 +43,14 @@ CONFIG(release, debug|release) {
DEFINES += NDEBUG
}
@@ -22,8 +19,6 @@ Last-Update: 2010-04-11 (-ffunction-sections removal)
+ message("S/390 workaround: do not build with -g, but with -gstabs")
+ QMAKE_CXXFLAGS -= -g
+ QMAKE_CXXFLAGS += -gstabs
-+ message("S/390 workaround: do not build with -ffunction-sections")
-+ QMAKE_CXXFLAGS -= -ffunction-sections
+}
+
+
diff --git a/debian/patches/96_powerpc_no_gc_sections.diff b/debian/patches/96_powerpc_no_gc_sections.diff
deleted file mode 100644
index 613af8a..0000000
--- a/debian/patches/96_powerpc_no_gc_sections.diff
+++ /dev/null
@@ -1,16 +0,0 @@
-Description: Don't pass -Wl,--gc-sections on powerpc when building
- libQtWebKit.so;
- works around a binutils bug that results in a segfault.
-Author: Steve Langasek <steve.langasek@ubuntu.com>
-
---- a/src/3rdparty/webkit/WebCore/WebCore.pro
-+++ b/src/3rdparty/webkit/WebCore/WebCore.pro
-@@ -63,7 +63,7 @@ unix {
- }
-
- unix:!mac:*-g++*:QMAKE_CXXFLAGS += -ffunction-sections -fdata-sections
--unix:!mac:*-g++*:QMAKE_LFLAGS += -Wl,--gc-sections
-+unix:!mac:*-g++*:!equals(QT_ARCH, powerpc):QMAKE_LFLAGS += -Wl,--gc-sections
-
- CONFIG(release):!CONFIG(QTDIR_build) {
- contains(QT_CONFIG, reduce_exports):CONFIG += hide_symbols
diff --git a/debian/patches/96_webkit_no_gc_sections.diff b/debian/patches/96_webkit_no_gc_sections.diff
new file mode 100644
index 0000000..2f7f236
--- /dev/null
+++ b/debian/patches/96_webkit_no_gc_sections.diff
@@ -0,0 +1,21 @@
+Description: Don't link QtWebkit with --gc-sections on powerpc and s390
+ This works around a binutils bug that results in a segfault on powerpc
+ and an internal link error on s390.
+ NOTE: s390 part depends on the 91_s390_webkit_ftbfs_fixes.diff patch.
+Author: Steve Langasek <steve.langasek@ubuntu.com>
+Author: Modestas Vainius <modax@debian.org>
+Origin: vendor
+Forwarded: no
+Last-Update: 2010-04-11 (s390 added)
+
+--- a/src/3rdparty/webkit/WebCore/WebCore.pro
++++ b/src/3rdparty/webkit/WebCore/WebCore.pro
+@@ -63,7 +63,7 @@ unix {
+ }
+
+ unix:!mac:*-g++*:QMAKE_CXXFLAGS += -ffunction-sections -fdata-sections
+-unix:!mac:*-g++*:QMAKE_LFLAGS += -Wl,--gc-sections
++unix:!mac:*-g++*:!equals(QT_ARCH, powerpc):!equals(arch, s390):QMAKE_LFLAGS += -Wl,--gc-sections
+
+ CONFIG(release):!CONFIG(QTDIR_build) {
+ contains(QT_CONFIG, reduce_exports):CONFIG += hide_symbols
diff --git a/debian/patches/series b/debian/patches/series
index 5dcaf2d..3c69cc8 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -38,8 +38,8 @@
81_hurd_architecture.diff
82_hurd_SA_SIGINFO.diff
89_powerpc_opts.diff
-91_s390_webkit_ftbfs_fixes.diff
+91_s390_use_gstabs.diff
92_armel_gcc43_valist_compat.diff
95_sparc_platform_definition.diff
-96_powerpc_no_gc_sections.diff
+96_webkit_no_gc_sections.diff
97_alpha_ftbfs_qatomic_alpha_h_types.diff