summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2010-06-06 03:20:10 +0300
committerModestas Vainius <modestas@vainius.eu>2010-06-06 03:20:25 +0300
commit45e7ee93ef997a592027ce14c2b534a6044e7242 (patch)
tree1b2e5b24647bed9c521d7abe1b2f439d5acb569b
parentce3e04b22f65b78f33d5dac4a2050b9e5ab417ef (diff)
downloadqt4-x11-45e7ee93ef997a592027ce14c2b534a6044e7242.tar.gz
Expand 96_webkit_no_gc_sections.diff to cover mips(el) as well.
Hopefully, this will make linker less memory demanding and solve out-of-memory condition on buildds.
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/96_webkit_no_gc_sections.diff8
2 files changed, 7 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 6491f46..8e22d37 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,8 @@
qt4-x11 (4:4.6.2-6) UNRELEASED; urgency=low
+ * Expand 96_webkit_no_gc_sections.diff to cover mips(el) as well. Hopefully,
+ this will make linker less memory demanding and solve out-of-memory
+ condition on buildds.
-- Modestas Vainius <modax@debian.org> Sun, 06 Jun 2010 03:16:11 +0300
diff --git a/debian/patches/96_webkit_no_gc_sections.diff b/debian/patches/96_webkit_no_gc_sections.diff
index 998b25d..cb0c57f 100644
--- a/debian/patches/96_webkit_no_gc_sections.diff
+++ b/debian/patches/96_webkit_no_gc_sections.diff
@@ -1,11 +1,11 @@
Description: Don't link QtWebkit with --gc-sections on powerpc and s390
- This works around a binutils bug that results in a segfault on powerpc
- and an internal link error on s390.
+ This works around a binutils bug that results in a segfault on powerpc,
+ an internal link error on s390, and OOM condition on mipsel.
Author: Steve Langasek <steve.langasek@ubuntu.com>
Author: Modestas Vainius <modax@debian.org>
Origin: vendor
Forwarded: no
-Last-Update: 2010-04-11 (s390 added)
+Last-Update: 2010-05-31 (mipsel added)
--- a/src/3rdparty/webkit/WebCore/WebCore.pro
+++ b/src/3rdparty/webkit/WebCore/WebCore.pro
@@ -14,7 +14,7 @@ Last-Update: 2010-04-11 (s390 added)
unix:!mac:*-g++*:QMAKE_CXXFLAGS += -ffunction-sections -fdata-sections
-unix:!mac:*-g++*:QMAKE_LFLAGS += -Wl,--gc-sections
-+unix:!mac:*-g++*:!equals(QT_ARCH, powerpc):!equals(QT_ARCH, s390):QMAKE_LFLAGS += -Wl,--gc-sections
++unix:!mac:*-g++*:!equals(QT_ARCH, powerpc):!equals(QT_ARCH, s390):!equals(QT_ARCH, mips):QMAKE_LFLAGS += -Wl,--gc-sections
CONFIG(release):!CONFIG(QTDIR_build) {
contains(QT_CONFIG, reduce_exports):CONFIG += hide_symbols