summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2010-04-19 00:19:07 +0300
committerModestas Vainius <modestas@vainius.eu>2010-04-19 00:19:38 +0300
commit509b920e16ae4b30e33c048f5459dbfba355ec37 (patch)
treef765c32ba4510d4ec98eac0b4df88d686d39edf2
parent1e1632d5792bc1038499d59f0e892774d8f9eec1 (diff)
downloadqt4-x11-509b920e16ae4b30e33c048f5459dbfba355ec37.tar.gz
Add support for alpha to QtScript copy of wtf/Platform.h.
This change should fix FTBFS on alpha (patch 52_wtf_platform_support_alpha.diff).
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/52_wtf_platform_support_alpha.diff31
-rw-r--r--debian/patches/series1
3 files changed, 34 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 6362c42..05fac7a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,8 @@
qt4-x11 (4:4.6.2-5) UNRELEASED; urgency=low
* Update symbol files for armel, hppa and mips.
+ * Add support for alpha to QtScript copy of wtf/Platform.h. This change
+ should fix FTBFS on alpha (patch 52_wtf_platform_support_alpha.diff).
-- Modestas Vainius <modax@debian.org> Sun, 18 Apr 2010 23:42:13 +0300
diff --git a/debian/patches/52_wtf_platform_support_alpha.diff b/debian/patches/52_wtf_platform_support_alpha.diff
new file mode 100644
index 0000000..b96adc6
--- /dev/null
+++ b/debian/patches/52_wtf_platform_support_alpha.diff
@@ -0,0 +1,31 @@
+Author: Modestas Vainius <modax@debian.org>
+Description: add support for alpha architecture to wtf/Platform.h
+ This should fix FTBFS of QtScript library on alpha. ALPHA is already supported
+ in the webkit copy of this header file.
+Forwarded: no
+Origin: vendor
+Last-Update: 2010-04-19
+
+--- a/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h
++++ b/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h
+@@ -367,6 +367,11 @@
+ #endif
+ #endif
+
++/* PLATFORM(ALPHA) */
++#if defined(__alpha) || defined(__alpha__)
++#define WTF_PLATFORM_ALPHA 1
++#endif
++
+ /* PLATFORM(WINCE) && PLATFORM(QT)
+ We can not determine the endianess at compile time. For
+ Qt for Windows CE the endianess is specified in the
+@@ -720,7 +725,7 @@
+ #if !defined(WTF_USE_JSVALUE64) && !defined(WTF_USE_JSVALUE32) && !defined(WTF_USE_JSVALUE32_64)
+ #if PLATFORM(X86_64) && (PLATFORM(DARWIN) || PLATFORM(LINUX) || PLATFORM(SOLARIS) || PLATFORM(HPUX))
+ #define WTF_USE_JSVALUE64 1
+-#elif (PLATFORM(IA64) && !PLATFORM(IA64_32)) || PLATFORM(SPARC64)
++#elif (PLATFORM(IA64) && !PLATFORM(IA64_32)) || PLATFORM(SPARC64) || PLATFORM(ALPHA)
+ #define WTF_USE_JSVALUE64 1
+ #elif PLATFORM(AIX64)
+ #define WTF_USE_JSVALUE64 1
diff --git a/debian/patches/series b/debian/patches/series
index 19abe42..842114d 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -33,6 +33,7 @@
41_disable_opengl_visibility.diff
50_kfreebsd_build_fix.diff
51_kfreebsd_strnstr_build_fix.diff
+52_wtf_platform_support_alpha.diff
70_hppa_ldcw_fix.diff
71_hppa_unaligned_access_fix_458133.diff
80_hurd_max_path.diff