summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFathi Boudra <fabo@debian.org>2010-07-07 10:51:08 +0300
committerFathi Boudra <fabo@debian.org>2010-07-07 10:51:08 +0300
commita1f6ccf08cbae4aa37d2820fc5e032e2bc6f0f93 (patch)
tree3ff18850d5ca2fbe76b34c423753c300f7d7064c
parentca6b629628ec8fe37121f8dfbcc40f8033ee1cfc (diff)
downloadqt4-x11-a1f6ccf08cbae4aa37d2820fc5e032e2bc6f0f93.tar.gz
Add 0006_device_context_leak.diff from upstream
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/0005_fix_detection_of_headers_files.diff5
-rw-r--r--debian/patches/0006_device_context_leak.diff12
-rw-r--r--debian/patches/series1
4 files changed, 14 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 742989e..4034d71 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,7 @@ qt4-x11 (4:4.6.3-2) UNRELEASED; urgency=low
is found after the last path separator. This implies that dots in
directory names are now ignored, and that files without an extension are
always considered headers (e.g., STL headers and Qt forwarding headers).
+ - 0006_device_context_leak.diff
-- Fathi Boudra <fabo@debian.org> Thu, 17 Jun 2010 09:03:32 +0300
diff --git a/debian/patches/0005_fix_detection_of_headers_files.diff b/debian/patches/0005_fix_detection_of_headers_files.diff
index bff5c62..dc30abc 100644
--- a/debian/patches/0005_fix_detection_of_headers_files.diff
+++ b/debian/patches/0005_fix_detection_of_headers_files.diff
@@ -15,8 +15,6 @@ Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@nokia.com>
src/tools/moc/main.cpp | 7 +++----
1 files changed, 3 insertions(+), 4 deletions(-)
-diff --git a/src/tools/moc/main.cpp b/src/tools/moc/main.cpp
-index ebe1834..4997690 100644
--- a/src/tools/moc/main.cpp
+++ b/src/tools/moc/main.cpp
@@ -359,11 +359,10 @@ int runMoc(int _argc, char **_argv)
@@ -34,6 +32,3 @@ index ebe1834..4997690 100644
}
if (moc.includeFiles.isEmpty()) {
if (moc.includePath.isEmpty()) {
---
-1.6.1
-
diff --git a/debian/patches/0006_device_context_leak.diff b/debian/patches/0006_device_context_leak.diff
new file mode 100644
index 0000000..e477d0c
--- /dev/null
+++ b/debian/patches/0006_device_context_leak.diff
@@ -0,0 +1,12 @@
+--- a/src/gui/kernel/qapplication_win.cpp
++++ b/src/gui/kernel/qapplication_win.cpp
+@@ -933,6 +933,9 @@ const QString qt_reg_winclass(QWidget *w
+ if (qt_widget_private(w)->isGLWidget) {
+ cname = QLatin1String("QGLWidget");
+ style = CS_DBLCLKS;
++#ifndef Q_WS_WINCE
++ style |= CS_OWNDC;
++#endif
+ icon = true;
+ } else if (flags & Qt::MSWindowsOwnDC) {
+ cname = QLatin1String("QWidgetOwnDC");
diff --git a/debian/patches/series b/debian/patches/series
index 953b713..f5cd9e6 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,6 +1,7 @@
# upstream patches
0004_problem_displaying_half_width_character.diff
0005_fix_detection_of_headers_files.diff
+0006_device_context_leak.diff
# qt-copy patches
0180-window-role.diff