summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFathi Boudra <fabo@debian.org>2010-06-28 15:34:39 +0300
committerFathi Boudra <fabo@debian.org>2010-06-28 15:34:39 +0300
commit84f03e9237cc7ef90748e9b93f6b05357408f575 (patch)
tree3cd76d667dbd9a668a36e4f1849b6592c6c5465b
parentff68def1d7f02c96bdd10e35de8b024076a2bfad (diff)
downloadqt4-x11-84f03e9237cc7ef90748e9b93f6b05357408f575.tar.gz
Refresh patches.
Remove Debian patches merged upstream (81 and 97) Disable patch 11 - not applicable to snapshot
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/0180-window-role.diff8
-rw-r--r--debian/patches/0209-prevent-qt-mixing.diff2
-rw-r--r--debian/patches/0216-allow-isystem-for-headers.diff4
-rw-r--r--debian/patches/0225-invalidate-tabbar-geometry-on-refresh.patch2
-rw-r--r--debian/patches/02_launch_assistant-qt4.diff2
-rw-r--r--debian/patches/05_append_qt4_target.diff60
-rw-r--r--debian/patches/08_configure_quilt_compat.diff2
-rw-r--r--debian/patches/10_config_tests_fixes.diff2
-rw-r--r--debian/patches/15_fix_qmake_makefile_generation.diff2
-rw-r--r--debian/patches/16_hide_std_symbols_on_qtwebkit.diff8
-rw-r--r--debian/patches/18_enable_qt3support_qtwebkit_debug_info.diff4
-rw-r--r--debian/patches/20_install_qvfb.diff2
-rw-r--r--debian/patches/30_webkit_unaligned_access.diff4
-rw-r--r--debian/patches/41_disable_opengl_visibility.diff2
-rw-r--r--debian/patches/50_kfreebsd_build_fix.diff4
-rw-r--r--debian/patches/51_kfreebsd_strnstr_build_fix.diff4
-rw-r--r--debian/patches/81_hurd_architecture.diff26
-rw-r--r--debian/patches/91_s390_use_gstabs.diff4
-rw-r--r--debian/patches/92_armel_gcc43_valist_compat.diff2
-rw-r--r--debian/patches/96_webkit_no_gc_sections.diff2
-rw-r--r--debian/patches/97_alpha_ftbfs_qatomic_alpha_h_types.diff63
-rw-r--r--debian/patches/series4
23 files changed, 74 insertions, 142 deletions
diff --git a/debian/changelog b/debian/changelog
index 29bf04c..cdabe55 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,9 @@ qt4-x11 (4:4.7.0~beta1+git3529+59c5857-1) UNRELEASED; urgency=low
* NOT RELEASED YET.
* Remove Qt Multimedia, Qt MediaServices and Qt WebKit packages.
+ * Remove Debian patches:
+ - 81_hurd_architecture.diff - merged upstream.
+ - 97_alpha_ftbfs_qatomic_alpha_h_types.diff - merged upstream.
* Update debian/rules:
- replace -multimedia by -no-multimedia configure option.
- add -no-mediaservices configure option.
diff --git a/debian/patches/0180-window-role.diff b/debian/patches/0180-window-role.diff
index af7f883..8cda02c 100644
--- a/debian/patches/0180-window-role.diff
+++ b/debian/patches/0180-window-role.diff
@@ -21,7 +21,7 @@ Trolltech task ID : 168283 (status: "fixed" for Qt 4.4.0, but effectively refuse
--- a/src/corelib/kernel/qobject.cpp
+++ b/src/corelib/kernel/qobject.cpp
-@@ -1120,8 +1120,16 @@ void QObject::setObjectName(const QStrin
+@@ -1095,8 +1095,16 @@ void QObject::setObjectName(const QStrin
{
Q_D(QObject);
d->objectName = name;
@@ -48,11 +48,11 @@ Trolltech task ID : 168283 (status: "fixed" for Qt 4.4.0, but effectively refuse
+ virtual void checkWindowRole();
+#endif
- static Sender *setCurrentSender(QObject *receiver,
+ static inline Sender *setCurrentSender(QObject *receiver,
Sender *sender);
--- a/src/gui/kernel/qwidget_p.h
+++ b/src/gui/kernel/qwidget_p.h
-@@ -699,6 +699,7 @@ public:
+@@ -756,6 +756,7 @@ public:
static QWidget *keyboardGrabber;
void setWindowRole();
@@ -86,7 +86,7 @@ Trolltech task ID : 168283 (status: "fixed" for Qt 4.4.0, but effectively refuse
}
// set client leader property
-@@ -2938,6 +2942,17 @@ void QWidgetPrivate::setWindowRole()
+@@ -2939,6 +2943,17 @@ void QWidgetPrivate::setWindowRole()
XChangeProperty(X11->display, q->internalWinId(),
ATOM(WM_WINDOW_ROLE), XA_STRING, 8, PropModeReplace,
(unsigned char *)windowRole.constData(), windowRole.length());
diff --git a/debian/patches/0209-prevent-qt-mixing.diff b/debian/patches/0209-prevent-qt-mixing.diff
index 1c9af93..06df477 100644
--- a/debian/patches/0209-prevent-qt-mixing.diff
+++ b/debian/patches/0209-prevent-qt-mixing.diff
@@ -28,5 +28,5 @@ bugs.kde.org number : none
+// in some Q*Private class
+enum { QObjectPrivateVersion = QT_VERSION + 0x1000000 };
- class Q_CORE_EXPORT QDeclarativeData
+ class Q_CORE_EXPORT QAbstractDeclarativeData
{
diff --git a/debian/patches/0216-allow-isystem-for-headers.diff b/debian/patches/0216-allow-isystem-for-headers.diff
index f451768..5d0d41d 100644
--- a/debian/patches/0216-allow-isystem-for-headers.diff
+++ b/debian/patches/0216-allow-isystem-for-headers.diff
@@ -27,7 +27,7 @@ bugs.kde.org number :
--- a/configure
+++ b/configure
-@@ -1046,6 +1046,11 @@ while [ "$#" -gt 0 ]; do
+@@ -1045,6 +1045,11 @@ while [ "$#" -gt 0 ]; do
VAL=`echo $1 | sed 's,-D,,'`
fi
;;
@@ -39,7 +39,7 @@ bugs.kde.org number :
-I?*|-I)
VAR="add_ipath"
if [ "$1" = "-I" ]; then
-@@ -2106,6 +2111,9 @@ while [ "$#" -gt 0 ]; do
+@@ -2119,6 +2124,9 @@ while [ "$#" -gt 0 ]; do
add_ipath)
I_FLAGS="$I_FLAGS -I\"${VAL}\""
;;
diff --git a/debian/patches/0225-invalidate-tabbar-geometry-on-refresh.patch b/debian/patches/0225-invalidate-tabbar-geometry-on-refresh.patch
index b35ceac..31e298f 100644
--- a/debian/patches/0225-invalidate-tabbar-geometry-on-refresh.patch
+++ b/debian/patches/0225-invalidate-tabbar-geometry-on-refresh.patch
@@ -30,7 +30,7 @@ bugs.kde.org number : 159014
--- a/src/gui/widgets/qtabbar.cpp
+++ b/src/gui/widgets/qtabbar.cpp
-@@ -678,8 +678,8 @@ void QTabBarPrivate::refresh()
+@@ -723,8 +723,8 @@ void QTabBarPrivate::refresh()
layoutTabs();
makeVisible(currentIndex);
q->update();
diff --git a/debian/patches/02_launch_assistant-qt4.diff b/debian/patches/02_launch_assistant-qt4.diff
index eb4cd95..2d040cf 100644
--- a/debian/patches/02_launch_assistant-qt4.diff
+++ b/debian/patches/02_launch_assistant-qt4.diff
@@ -3,7 +3,7 @@ Author: Fathi Boudra <fabo@debian.org>
--- a/demos/qtdemo/menumanager.cpp
+++ b/demos/qtdemo/menumanager.cpp
-@@ -286,7 +286,7 @@ void MenuManager::showDocInAssistant(con
+@@ -297,7 +297,7 @@ void MenuManager::showDocInAssistant(con
if (this->assistantProcess.state() != QProcess::Running){
QString app = QLibraryInfo::location(QLibraryInfo::BinariesPath) + QDir::separator();
#if !defined(Q_OS_MAC)
diff --git a/debian/patches/05_append_qt4_target.diff b/debian/patches/05_append_qt4_target.diff
index ca9aa6d..e60a724 100644
--- a/debian/patches/05_append_qt4_target.diff
+++ b/debian/patches/05_append_qt4_target.diff
@@ -2,12 +2,12 @@ author: Fathi Boudra <fabo@debian.org>
--- a/config.tests/unix/compile.test
+++ b/config.tests/unix/compile.test
-@@ -66,7 +66,7 @@ cd "$OUTDIR/$TEST"
+@@ -68,7 +68,7 @@ test -r Makefile && $MAKE distclean >/de
+ # Make sure output from possible previous tests is gone
+ rm -f "$EXE" "${EXE}.exe"
- test -r Makefile && $MAKE distclean >/dev/null 2>&1
-
--"$OUTDIR/bin/qmake" -nocache -spec "$QMKSPEC" "CONFIG+=$QMAKE_CONFIG" "LIBS*=$LFLAGS" "LIBS+=$MAC_ARCH_LFLAGS" "INCLUDEPATH*=$INCLUDEPATH" "QMAKE_CXXFLAGS*=$CXXFLAGS" "QMAKE_CXXFLAGS+=$MAC_ARCH_CXXFLAGS" "$SRCDIR/$TEST/$EXE.pro" -o "$OUTDIR/$TEST/Makefile"
-+"$OUTDIR/bin/qmake-qt4" -nocache -spec "$QMKSPEC" "CONFIG+=$QMAKE_CONFIG" "LIBS*=$LFLAGS" "LIBS+=$MAC_ARCH_LFLAGS" "INCLUDEPATH*=$INCLUDEPATH" "QMAKE_CXXFLAGS*=$CXXFLAGS" "QMAKE_CXXFLAGS+=$MAC_ARCH_CXXFLAGS" "$SRCDIR/$TEST/$EXE.pro" -o "$OUTDIR/$TEST/Makefile"
+-"$OUTDIR/bin/qmake" -nocache -spec "$QMKSPEC" "CONFIG+=$QMAKE_CONFIG" "CONFIG-=debug_and_release" "LIBS*=$LFLAGS" "LIBS+=$MAC_ARCH_LFLAGS" "INCLUDEPATH*=$INCLUDEPATH" "QMAKE_CXXFLAGS*=$CXXFLAGS" "QMAKE_CXXFLAGS+=$MAC_ARCH_CXXFLAGS" "$SRCDIR/$TEST/$EXE.pro" -o "$OUTDIR/$TEST/Makefile"
++"$OUTDIR/bin/qmake-qt4" -nocache -spec "$QMKSPEC" "CONFIG+=$QMAKE_CONFIG" "CONFIG-=debug_and_release" "LIBS*=$LFLAGS" "LIBS+=$MAC_ARCH_LFLAGS" "INCLUDEPATH*=$INCLUDEPATH" "QMAKE_CXXFLAGS*=$CXXFLAGS" "QMAKE_CXXFLAGS+=$MAC_ARCH_CXXFLAGS" "$SRCDIR/$TEST/$EXE.pro" -o "$OUTDIR/$TEST/Makefile"
if [ "$VERBOSE" = "yes" ]; then
$MAKE
@@ -57,7 +57,7 @@ author: Fathi Boudra <fabo@debian.org>
if [ "$VERBOSE" = "yes" ]; then
--- a/configure
+++ b/configure
-@@ -4438,7 +4438,7 @@ END {
+@@ -4468,7 +4468,7 @@ END {
}
# build qmake
@@ -66,7 +66,7 @@ author: Fathi Boudra <fabo@debian.org>
echo "Creating qmake. Please wait..."
OLD_QCONFIG_H=
-@@ -7597,8 +7597,8 @@ QMAKE_ABSOLUTE_SOURCE_ROOT = \$\$QT_SOUR
+@@ -7737,8 +7737,8 @@ QMAKE_ABSOLUTE_SOURCE_ROOT = \$\$QT_SOUR
QMAKE_MOC_SRC = \$\$QT_BUILD_TREE/src/moc
#local paths that cannot be queried from the QT_INSTALL_* properties while building QTDIR
@@ -77,7 +77,7 @@ author: Fathi Boudra <fabo@debian.org>
QMAKE_UIC3 = \$\$QT_BUILD_TREE/bin/uic3
QMAKE_RCC = \$\$QT_BUILD_TREE/bin/rcc
QMAKE_QDBUSXML2CPP = \$\$QT_BUILD_TREE/bin/qdbusxml2cpp
-@@ -7987,11 +7987,11 @@ EXEC=""
+@@ -8128,11 +8128,11 @@ EXEC=""
#-------------------------------------------------------------------------------
echo "Finding project files. Please wait..."
@@ -91,7 +91,7 @@ author: Fathi Boudra <fabo@debian.org>
fi
# .projects -> projects to process
-@@ -8166,7 +8166,7 @@ for file in .projects .projects.3; do
+@@ -8309,7 +8309,7 @@ for file in .projects .projects.3; do
QMAKE_SPEC_ARGS="-spec $SPEC"
echo $ECHO_N " for $a$ECHO_C"
@@ -221,22 +221,22 @@ author: Fathi Boudra <fabo@debian.org>
return ($$result)
}
--LUPDATE = $$QT_BUILD_TREE/bin/lupdate
-+LUPDATE = $$QT_BUILD_TREE/bin/lupdate-qt4
- win32 {
- LUPDATE ~= s,/,$$QMAKE_DIR_SEP,
- LUPDATE = $${LUPDATE}.exe
+-qtPrepareTool(LUPDATE, lupdate)
++qtPrepareTool(LUPDATE, lupdate-qt4)
+ LUPDATE += -locations relative -no-ui-lines
+
+ ###### Qt Libraries
--- a/translations/translations.pro
+++ b/translations/translations.pro
@@ -1,6 +1,6 @@
TRANSLATIONS = $$files(*.ts)
--LRELEASE = $$QT_BUILD_TREE/bin/lrelease
-+LRELEASE = $$QT_BUILD_TREE/bin/lrelease-qt4
- win32 {
- LRELEASE ~= s,/,$$QMAKE_DIR_SEP,
- LRELEASE = $${LRELEASE}.exe
-@@ -19,7 +19,7 @@ updateqm.input = TRANSLATIONS
+-qtPrepareTool(LRELEASE, lrelease)
++qtPrepareTool(LRELEASE, lrelease-qt4)
+
+ contains(TEMPLATE_PREFIX, vc):vcproj = 1
+
+@@ -15,7 +15,7 @@ updateqm.input = TRANSLATIONS
updateqm.output = ${QMAKE_FILE_BASE}.qm
isEmpty(vcproj):updateqm.variable_out = PRE_TARGETDEPS
updateqm.commands = $$LRELEASE ${QMAKE_FILE_IN} -qm ${QMAKE_FILE_OUT}
@@ -245,3 +245,23 @@ author: Fathi Boudra <fabo@debian.org>
updateqm.name = LRELEASE ${QMAKE_FILE_IN}
updateqm.CONFIG += no_link
QMAKE_EXTRA_COMPILERS += updateqm
+--- a/mkspecs/features/moc.prf
++++ b/mkspecs/features/moc.prf
+@@ -1,6 +1,6 @@
+
+ #global defaults
+-qtPrepareTool(QMAKE_MOC, moc)
++qtPrepareTool(QMAKE_MOC, moc-qt4)
+ isEmpty(MOC_DIR):MOC_DIR = .
+ isEmpty(QMAKE_H_MOD_MOC):QMAKE_H_MOD_MOC = moc_
+ isEmpty(QMAKE_EXT_CPP_MOC):QMAKE_EXT_CPP_MOC = .moc
+--- a/mkspecs/features/uic.prf
++++ b/mkspecs/features/uic.prf
+@@ -1,6 +1,6 @@
+ defined(qtPrepareTool)|load(qt_functions) ### Qt 5: see default_pre.prf
+ qtPrepareTool(QMAKE_UIC3, uic3)
+-qtPrepareTool(QMAKE_UIC, uic)
++qtPrepareTool(QMAKE_UIC, uic-qt4)
+
+ isEmpty(UI_DIR):UI_DIR = .
+ isEmpty(UI_SOURCES_DIR):UI_SOURCES_DIR = $$UI_DIR
diff --git a/debian/patches/08_configure_quilt_compat.diff b/debian/patches/08_configure_quilt_compat.diff
index 991d10b..fbde18f 100644
--- a/debian/patches/08_configure_quilt_compat.diff
+++ b/debian/patches/08_configure_quilt_compat.diff
@@ -3,7 +3,7 @@ It breaks qmake projects search.
--- a/configure
+++ b/configure
-@@ -8043,7 +8043,7 @@ fi
+@@ -8184,7 +8184,7 @@ fi
# .projects.3 -> the rest
rm -f .projects .projects.1 .projects.2 .projects.3
diff --git a/debian/patches/10_config_tests_fixes.diff b/debian/patches/10_config_tests_fixes.diff
index e088861..96a4768 100644
--- a/debian/patches/10_config_tests_fixes.diff
+++ b/debian/patches/10_config_tests_fixes.diff
@@ -14,7 +14,7 @@ Last-Update: 2010-05-24
+LIBS += -lfbclient
--- a/src/sql/drivers/drivers.pri
+++ b/src/sql/drivers/drivers.pri
-@@ -91,7 +91,7 @@ contains(sql-drivers, ibase) {
+@@ -89,7 +89,7 @@ contains(sql-drivers, ibase) {
HEADERS += drivers/ibase/qsql_ibase.h
SOURCES += drivers/ibase/qsql_ibase.cpp
diff --git a/debian/patches/15_fix_qmake_makefile_generation.diff b/debian/patches/15_fix_qmake_makefile_generation.diff
index e6f1fd1..8e3a220 100644
--- a/debian/patches/15_fix_qmake_makefile_generation.diff
+++ b/debian/patches/15_fix_qmake_makefile_generation.diff
@@ -3,7 +3,7 @@ Author: Sune Vuorela <debian@pusling.com>
--- a/qmake/generators/makefile.cpp
+++ b/qmake/generators/makefile.cpp
-@@ -2390,7 +2390,7 @@ MakefileGenerator::writeSubTargets(QText
+@@ -2403,7 +2403,7 @@ MakefileGenerator::writeSubTargets(QText
QString mkfile = subtarget->makefile;
if(!in_directory.isEmpty())
diff --git a/debian/patches/16_hide_std_symbols_on_qtwebkit.diff b/debian/patches/16_hide_std_symbols_on_qtwebkit.diff
index 97291e6..b1e5e23 100644
--- a/debian/patches/16_hide_std_symbols_on_qtwebkit.diff
+++ b/debian/patches/16_hide_std_symbols_on_qtwebkit.diff
@@ -4,10 +4,10 @@ Author: Sune Vuorela <debian@pusling.com>
--- a/src/3rdparty/webkit/WebKit.pri
+++ b/src/3rdparty/webkit/WebKit.pri
-@@ -49,6 +49,7 @@ CONFIG(release, debug|release) {
-
- BASE_DIR = $$PWD
- INCLUDEPATH += $$OUTPUT_DIR/include/QtWebKit
+@@ -54,6 +54,7 @@ symbian {
+ } else {
+ INCLUDEPATH += $$OUTPUT_DIR/include/QtWebKit
+ }
+QMAKE_LFLAGS += -Wl,--version-script,$$BASE_DIR/symbols.filter
CONFIG -= warn_on
diff --git a/debian/patches/18_enable_qt3support_qtwebkit_debug_info.diff b/debian/patches/18_enable_qt3support_qtwebkit_debug_info.diff
index 8912863..790efea 100644
--- a/debian/patches/18_enable_qt3support_qtwebkit_debug_info.diff
+++ b/debian/patches/18_enable_qt3support_qtwebkit_debug_info.diff
@@ -5,7 +5,7 @@ This patch enable them.
--- a/src/3rdparty/webkit/WebCore/WebCore.pro
+++ b/src/3rdparty/webkit/WebCore/WebCore.pro
-@@ -2900,8 +2900,6 @@ HEADERS += $$WEBKIT_API_HEADERS
+@@ -2935,8 +2935,6 @@ HEADERS += $$WEBKIT_API_HEADERS
CONFIG(QTDIR_build) {
# Remove the following 2 lines if you want debug information in WebCore
@@ -13,7 +13,7 @@ This patch enable them.
- CONFIG += no_debug_info
}
- !win32-g++:win32:contains(QMAKE_HOST.arch, x86_64):{
+ win32:!win32-g++*:contains(QMAKE_HOST.arch, x86_64):{
--- a/src/qt3support/qt3support.pro
+++ b/src/qt3support/qt3support.pro
@@ -34,6 +34,3 @@ MOCDIR = .moc
diff --git a/debian/patches/20_install_qvfb.diff b/debian/patches/20_install_qvfb.diff
index 25daad4..9808fd8 100644
--- a/debian/patches/20_install_qvfb.diff
+++ b/debian/patches/20_install_qvfb.diff
@@ -3,7 +3,7 @@ Author: Fathi Boudra <fabo@debian.org>
--- a/tools/tools.pro
+++ b/tools/tools.pro
-@@ -40,5 +40,7 @@ embedded: SUBDIRS += makeqpf
+@@ -41,5 +41,7 @@ embedded: SUBDIRS += makeqpf
!wince*:!cross_compile:SUBDIRS += qdoc3
diff --git a/debian/patches/30_webkit_unaligned_access.diff b/debian/patches/30_webkit_unaligned_access.diff
index 47ab3de..c099838 100644
--- a/debian/patches/30_webkit_unaligned_access.diff
+++ b/debian/patches/30_webkit_unaligned_access.diff
@@ -53,7 +53,7 @@ a real problem yet.
@@ -182,10 +182,7 @@ namespace WTF {
Node* m_freeList;
bool m_isDoneWithInitialFreeList;
- static const size_t m_poolSize = 256;
+ static const size_t m_poolSize = inlineCapacity;
- union {
- char pool[sizeof(Node) * m_poolSize];
- double forAlignment;
@@ -61,7 +61,7 @@ a real problem yet.
+ uint32_t m_pool[(sizeof(Node) * m_poolSize + sizeof(uint32_t) - 1) / sizeof(uint32_t)];
};
- template<typename ValueArg> struct ListHashSetNode {
+ template<typename ValueArg, size_t inlineCapacity> struct ListHashSetNode {
--- a/src/3rdparty/webkit/WebCore/platform/text/AtomicString.cpp
+++ b/src/3rdparty/webkit/WebCore/platform/text/AtomicString.cpp
@@ -103,9 +103,9 @@ static inline bool equal(StringImpl* str
diff --git a/debian/patches/41_disable_opengl_visibility.diff b/debian/patches/41_disable_opengl_visibility.diff
index ed2ea47..fd3b629 100644
--- a/debian/patches/41_disable_opengl_visibility.diff
+++ b/debian/patches/41_disable_opengl_visibility.diff
@@ -2,7 +2,7 @@ temporary fix because of alpha, has to be dropped as soon as gcc's bug is fixed.
--- a/src/opengl/opengl.pro
+++ b/src/opengl/opengl.pro
-@@ -36,6 +36,7 @@ SOURCES += qgl.cpp \
+@@ -37,6 +37,7 @@ SOURCES += qgl.cpp \
qglpaintdevice.cpp \
qglbuffer.cpp \
diff --git a/debian/patches/50_kfreebsd_build_fix.diff b/debian/patches/50_kfreebsd_build_fix.diff
index ab07438..3532907 100644
--- a/debian/patches/50_kfreebsd_build_fix.diff
+++ b/debian/patches/50_kfreebsd_build_fix.diff
@@ -55,7 +55,7 @@ Fixes FTBFS on GNU/kFreeBSD by creating new Q_OS_GLIBC.
# include <fenv.h>
#endif
-@@ -6598,7 +6598,7 @@ Q_CORE_EXPORT char *qdtoa ( double d, in
+@@ -6636,7 +6636,7 @@ Q_CORE_EXPORT char *qdtoa ( double d, in
_control87(MCW_EM, MCW_EM);
#endif
@@ -64,7 +64,7 @@ Fixes FTBFS on GNU/kFreeBSD by creating new Q_OS_GLIBC.
fenv_t envp;
feholdexcept(&envp);
#endif
-@@ -6614,7 +6614,7 @@ Q_CORE_EXPORT char *qdtoa ( double d, in
+@@ -6652,7 +6652,7 @@ Q_CORE_EXPORT char *qdtoa ( double d, in
#endif //_M_X64
#endif //Q_OS_WIN
diff --git a/debian/patches/51_kfreebsd_strnstr_build_fix.diff b/debian/patches/51_kfreebsd_strnstr_build_fix.diff
index 085cd3e..2e95627 100644
--- a/debian/patches/51_kfreebsd_strnstr_build_fix.diff
+++ b/debian/patches/51_kfreebsd_strnstr_build_fix.diff
@@ -4,7 +4,7 @@ Bug: https://bugs.webkit.org/show_bug.cgi?id=33903
--- a/src/3rdparty/webkit/JavaScriptCore/wtf/Platform.h
+++ b/src/3rdparty/webkit/JavaScriptCore/wtf/Platform.h
-@@ -359,7 +359,7 @@
+@@ -367,7 +367,7 @@
#endif
/* OS(LINUX) - Linux */
@@ -15,7 +15,7 @@ Bug: https://bugs.webkit.org/show_bug.cgi?id=33903
--- a/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h
+++ b/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h
-@@ -383,7 +383,7 @@
+@@ -388,7 +388,7 @@
#endif
/* OS(LINUX) - Linux */
diff --git a/debian/patches/81_hurd_architecture.diff b/debian/patches/81_hurd_architecture.diff
deleted file mode 100644
index 7185af8..0000000
--- a/debian/patches/81_hurd_architecture.diff
+++ /dev/null
@@ -1,26 +0,0 @@
-Description: recognize the correct architecture on GNU/Hurd.
- Doing the same mangling of `uname -m` done in the config.guess of the widely
- used autotools, we can recognize the correct architecture, and thus using
- non-generic atomic primitives.
-Author: Pino Toscano <pino@kde.org>
-Forwarded: http://bugreports.qt.nokia.com/browse/QTBUG-7803
---- a/configure
-+++ b/configure
-@@ -2814,6 +2814,17 @@ fi
-
- if [ -z "${CFG_HOST_ARCH}" ]; then
- case "$UNAME_SYSTEM:$UNAME_RELEASE:$UNAME_MACHINE" in
-+ GNU:*:*)
-+ CFG_HOST_ARCH=`echo ${UNAME_MACHINE} | sed -e 's,[-/].*$,,'`
-+ case "$CFG_HOST_ARCH" in
-+ i?86)
-+ CFG_HOST_ARCH=i386
-+ ;;
-+ esac
-+ if [ "$OPT_VERBOSE" = "yes" ]; then
-+ echo " GNU/Hurd ($CFG_HOST_ARCH)"
-+ fi
-+ ;;
- IRIX*:*:*)
- CFG_HOST_ARCH=`uname -p`
- if [ "$OPT_VERBOSE" = "yes" ]; then
diff --git a/debian/patches/91_s390_use_gstabs.diff b/debian/patches/91_s390_use_gstabs.diff
index dbb9906..e1fd4df 100644
--- a/debian/patches/91_s390_use_gstabs.diff
+++ b/debian/patches/91_s390_use_gstabs.diff
@@ -20,5 +20,5 @@ Forwarded: no
+
+
BASE_DIR = $$PWD
- INCLUDEPATH += $$OUTPUT_DIR/include/QtWebKit
- QMAKE_LFLAGS += -Wl,--version-script,$$BASE_DIR/symbols.filter
+
+ symbian {
diff --git a/debian/patches/92_armel_gcc43_valist_compat.diff b/debian/patches/92_armel_gcc43_valist_compat.diff
index 0ad00bd..a7e7c91 100644
--- a/debian/patches/92_armel_gcc43_valist_compat.diff
+++ b/debian/patches/92_armel_gcc43_valist_compat.diff
@@ -15,7 +15,7 @@ Forward: not-needed
--- a/src/corelib/tools/qstring.cpp
+++ b/src/corelib/tools/qstring.cpp
-@@ -5425,6 +5425,11 @@ QString &QString::vsprintf(const char* c
+@@ -5432,6 +5432,11 @@ QString &QString::vsprintf(const char* c
return *this;
}
diff --git a/debian/patches/96_webkit_no_gc_sections.diff b/debian/patches/96_webkit_no_gc_sections.diff
index 97693a4..84f1343 100644
--- a/debian/patches/96_webkit_no_gc_sections.diff
+++ b/debian/patches/96_webkit_no_gc_sections.diff
@@ -9,7 +9,7 @@ Last-Update: 2010-04-11 (s390 added)
--- a/src/3rdparty/webkit/WebCore/WebCore.pro
+++ b/src/3rdparty/webkit/WebCore/WebCore.pro
-@@ -80,7 +80,7 @@ unix {
+@@ -90,7 +90,7 @@ unix {
}
unix:!mac:*-g++*:QMAKE_CXXFLAGS += -ffunction-sections -fdata-sections
diff --git a/debian/patches/97_alpha_ftbfs_qatomic_alpha_h_types.diff b/debian/patches/97_alpha_ftbfs_qatomic_alpha_h_types.diff
deleted file mode 100644
index 8706dd5..0000000
--- a/debian/patches/97_alpha_ftbfs_qatomic_alpha_h_types.diff
+++ /dev/null
@@ -1,63 +0,0 @@
-Author: Modestas Vainius <modax@debian.org>
-Description: fix FTBFS on alpha due to invalid type conversions
- ../../include/QtCore/../../src/corelib/arch/qatomic_alpha.h: In member function 'T* QBasicAtomicPointer<T>::fetchAndStoreAcquire(T*) [with T = QMutexPool]':
- kernel/qobject.cpp:123: instantiated from here
- ../../include/QtCore/../../src/corelib/arch/qatomic_alpha.h:401: error: invalid conversion from 'void*' to 'QMutexPool*'
-Forwarded: http://bugreports.qt.nokia.com/browse/QTBUG-5955
-
---- a/src/corelib/arch/qatomic_alpha.h
-+++ b/src/corelib/arch/qatomic_alpha.h
-@@ -367,7 +367,7 @@ Q_INLINE_TEMPLATE bool QBasicAtomicPoint
- template <typename T>
- Q_INLINE_TEMPLATE T *QBasicAtomicPointer<T>::fetchAndStoreRelaxed(T *newValue)
- {
-- register void *old, *tmp;
-+ register T *old, *tmp;
- asm volatile("1:\n"
- "ldq_l %0,%2\n" /* old=*ptr; */
- "mov %3,%1\n" /* tmp=newval; */
-@@ -385,7 +385,7 @@ Q_INLINE_TEMPLATE T *QBasicAtomicPointer
- template <typename T>
- Q_INLINE_TEMPLATE T *QBasicAtomicPointer<T>::fetchAndStoreAcquire(T *newValue)
- {
-- register void *old, *tmp;
-+ register T *old, *tmp;
- asm volatile("1:\n"
- "ldq_l %0,%2\n" /* old=*ptr; */
- "mov %3,%1\n" /* tmp=newval; */
-@@ -404,7 +404,7 @@ Q_INLINE_TEMPLATE T *QBasicAtomicPointer
- template <typename T>
- Q_INLINE_TEMPLATE T *QBasicAtomicPointer<T>::fetchAndStoreRelease(T *newValue)
- {
-- register void *old, *tmp;
-+ register T *old, *tmp;
- asm volatile("mb\n"
- "1:\n"
- "ldq_l %0,%2\n" /* old=*ptr; */
-@@ -423,7 +423,7 @@ Q_INLINE_TEMPLATE T *QBasicAtomicPointer
- template <typename T>
- Q_INLINE_TEMPLATE T *QBasicAtomicPointer<T>::fetchAndAddRelaxed(qptrdiff valueToAdd)
- {
-- register void *old, *tmp;
-+ register T *old, *tmp;
- asm volatile("1:\n"
- "ldq_l %0,%2\n" /* old=*ptr; */
- "addq %0,%3,%1\n"/* tmp=old+value; */
-@@ -441,7 +441,7 @@ Q_INLINE_TEMPLATE T *QBasicAtomicPointer
- template <typename T>
- Q_INLINE_TEMPLATE T *QBasicAtomicPointer<T>::fetchAndAddAcquire(qptrdiff valueToAdd)
- {
-- register void *old, *tmp;
-+ register T *old, *tmp;
- asm volatile("1:\n"
- "ldq_l %0,%2\n" /* old=*ptr; */
- "addq %0,%3,%1\n"/* tmp=old+value; */
-@@ -460,7 +460,7 @@ Q_INLINE_TEMPLATE T *QBasicAtomicPointer
- template <typename T>
- Q_INLINE_TEMPLATE T *QBasicAtomicPointer<T>::fetchAndAddRelease(qptrdiff valueToAdd)
- {
-- register void *old, *tmp;
-+ register T *old, *tmp;
- asm volatile("mb\n"
- "1:\n"
- "ldq_l %0,%2\n" /* old=*ptr; */
diff --git a/debian/patches/series b/debian/patches/series
index 0b7db55..a49a651 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -15,7 +15,7 @@
08_configure_quilt_compat.diff
09_qmake_lflags_as-needed.diff
10_config_tests_fixes.diff
-11_build_translations.diff
+# disabled for snapshot 11_build_translations.diff
12_add_nostrip_for_debug_packages.diff
15_fix_qmake_makefile_generation.diff
16_hide_std_symbols_on_qtwebkit.diff
@@ -31,9 +31,7 @@
70_hppa_ldcw_fix.diff
71_hppa_unaligned_access_fix_458133.diff
80_hurd_max_path.diff
-81_hurd_architecture.diff
89_powerpc_opts.diff
91_s390_use_gstabs.diff
92_armel_gcc43_valist_compat.diff
96_webkit_no_gc_sections.diff
-97_alpha_ftbfs_qatomic_alpha_h_types.diff