summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2010-12-04 23:52:50 +0200
committerModestas Vainius <modestas@vainius.eu>2010-12-04 23:55:42 +0200
commit2d261aa1f218c6298982e9e636dc5bb7a42b5bf1 (patch)
treeb8f8e9cba1ce7edc19d9e1e8f1fe6651fb572f60
parent7a71379682c258de94558c5388659c735ee92cf6 (diff)
downloadqt4-x11-2d261aa1f218c6298982e9e636dc5bb7a42b5bf1.tar.gz
More changelog updates for the recent 4.6 merge.
Including the actual removal of the now-obsolete 22_fix_disappearing_cursor.diff patch.
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/22_fix_disappearing_cursor.diff31
2 files changed, 6 insertions, 32 deletions
diff --git a/debian/changelog b/debian/changelog
index 9fdb134..5b3e480 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -30,7 +30,12 @@ qt4-x11 (4:4.7.1-0r1) UNRELEASED; urgency=low
* Merge revisions from 4:4.6.3-1 to 4:4.6.3-4:
- refresh 23_permit_plugins_built_with_future_qt.diff patch;
- bump libqt4-dbus Replaces/Breaks against libqt4-dev to << 4:4.7.1 because
- 4:4.7.0~rc1-1 still has dbus.1 manpage misplaced.
+ 4:4.7.0~rc1-1 still has dbus.1 manpage misplaced;
+ - remove merged patches which were backported from upstream:
+ - 0005_fix_detection_of_headers_files.diff
+ - 0006_webkit_propriotary_flash_init_gtk_first.diff
+ - 0007_qsslsocket_improve_error_handling_CVE-2010-2621.patch
+ - 22_fix_disappearing_cursor.diff
* Bump debian/compat to 7. This source package uses dh v7.
* Confirm symbol files for 4.7.0~rc1 on alpha armel hurd-i386 i386 ia64
kfreebsd-amd64 kfreebsd-i386 mipsel powerpc sparc (based on experimental
diff --git a/debian/patches/22_fix_disappearing_cursor.diff b/debian/patches/22_fix_disappearing_cursor.diff
deleted file mode 100644
index bc446f7..0000000
--- a/debian/patches/22_fix_disappearing_cursor.diff
+++ /dev/null
@@ -1,31 +0,0 @@
-From: Denis Dzyubenko <denis.dzyubenko@nokia.com>
-Date: Wed, 29 Sep 2010 14:02:10 +0200
-Subject: [PATCH] Fixes cursor shape when widget becomes native on X11.
-Origin: backport commit:f9312fec1c44097a2093b3075aa68901327eb9c5
-Applied-Upstream: 4.7.1
-
-When a native window handle is created for a widget that has override
-cursor set, we should reset the cursor on the parent and set the cursor
-on the new window handle.
-
-Task-number: QTBUG-6185
-Reviewed-by: Olivier Goffart
-(cherry picked from commit 9e9a7bc29319d52c3e563bc2c5282cb7e6890eba)
----
- src/gui/kernel/qwidget_x11.cpp | 4 +++-
- 1 files changed, 3 insertions(+), 1 deletions(-)
-
---- a/src/gui/kernel/qwidget_x11.cpp
-+++ b/src/gui/kernel/qwidget_x11.cpp
-@@ -902,8 +902,10 @@ void QWidgetPrivate::create_sys(WId wind
- q->setWindowOpacity(maybeTopData()->opacity/255.);
-
- }
-- } else if (q->testAttribute(Qt::WA_SetCursor) && q->internalWinId()) {
-+ } else if (q->internalWinId()) {
- qt_x11_enforce_cursor(q);
-+ if (QWidget *p = q->parentWidget()) // reset the cursor on the native parent
-+ qt_x11_enforce_cursor(p);
- }
-
- if (extra && !extra->mask.isEmpty() && q->internalWinId())