summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2010-10-16 00:36:59 +0300
committerModestas Vainius <modestas@vainius.eu>2010-10-16 00:37:08 +0300
commit98d70e8c913674646a06a42d75bc64ede494a9d9 (patch)
tree833381f2818e6c6aa31115a42ba9b17b1e5634dc
parent956b96cf1eab0e95f50ad770499b73efc411b2b4 (diff)
downloadqt4-x11-98d70e8c913674646a06a42d75bc64ede494a9d9.tar.gz
Fix a bug with mouse cursor disappearing randomly on various widgets.
Backport 22_fix_disappearing_cursor.diff patch to fix a bug with mouse cursor disappearing randomly on various widgets (QTreeView, QListView etc.).
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/22_fix_disappearing_cursor.diff31
-rw-r--r--debian/patches/series1
3 files changed, 35 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 199457a..9196062 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,6 +11,9 @@ qt4-x11 (4:4.6.3-4) UNRELEASED; urgency=low
* Confirm 4.6.3 symbol files on the rest (!amd64) of arches. All symbols
affected are optional. Also remove old stale MISSING symbols in the
process.
+ * Backport 22_fix_disappearing_cursor.diff patch from 4.7.1 to fix a bug
+ with mouse cursor disappearing randomly on various widgets (QTreeView,
+ QListView etc.).
-- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Tue, 12 Oct 2010 17:04:43 +0200
diff --git a/debian/patches/22_fix_disappearing_cursor.diff b/debian/patches/22_fix_disappearing_cursor.diff
new file mode 100644
index 0000000..bc446f7
--- /dev/null
+++ b/debian/patches/22_fix_disappearing_cursor.diff
@@ -0,0 +1,31 @@
+From: Denis Dzyubenko <denis.dzyubenko@nokia.com>
+Date: Wed, 29 Sep 2010 14:02:10 +0200
+Subject: [PATCH] Fixes cursor shape when widget becomes native on X11.
+Origin: backport commit:f9312fec1c44097a2093b3075aa68901327eb9c5
+Applied-Upstream: 4.7.1
+
+When a native window handle is created for a widget that has override
+cursor set, we should reset the cursor on the parent and set the cursor
+on the new window handle.
+
+Task-number: QTBUG-6185
+Reviewed-by: Olivier Goffart
+(cherry picked from commit 9e9a7bc29319d52c3e563bc2c5282cb7e6890eba)
+---
+ src/gui/kernel/qwidget_x11.cpp | 4 +++-
+ 1 files changed, 3 insertions(+), 1 deletions(-)
+
+--- a/src/gui/kernel/qwidget_x11.cpp
++++ b/src/gui/kernel/qwidget_x11.cpp
+@@ -902,8 +902,10 @@ void QWidgetPrivate::create_sys(WId wind
+ q->setWindowOpacity(maybeTopData()->opacity/255.);
+
+ }
+- } else if (q->testAttribute(Qt::WA_SetCursor) && q->internalWinId()) {
++ } else if (q->internalWinId()) {
+ qt_x11_enforce_cursor(q);
++ if (QWidget *p = q->parentWidget()) // reset the cursor on the native parent
++ qt_x11_enforce_cursor(p);
+ }
+
+ if (extra && !extra->mask.isEmpty() && q->internalWinId())
diff --git a/debian/patches/series b/debian/patches/series
index 4fbe491..3140ad7 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -29,6 +29,7 @@
18_enable_qt3support_qtwebkit_debug_info.diff
20_install_qvfb.diff
21_qt_ia32_library_path.diff
+22_fix_disappearing_cursor.diff
30_webkit_unaligned_access.diff
40_alpha_ice.diff
41_disable_opengl_visibility.diff