summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPino Toscano <pino@kde.org>2010-10-06 13:03:25 +0200
committerPino Toscano <pino@kde.org>2010-10-06 13:03:25 +0200
commite0c8eaeafe5651f11fc773e23c035b135e44c5a3 (patch)
tree4d9396b1023584e1dafabb96ddaca8a7c04e70f8
parent2cc1f114b7fedeaaa862c63ed8b909371bce831a (diff)
downloadqt4-x11-e0c8eaeafe5651f11fc773e23c035b135e44c5a3.tar.gz
Rework and replace 50_kfreebsd_build_fix.diff with 22_use___GLIBC__.diff and 50_kfreebsd_Q_OS.diff.
-rw-r--r--debian/changelog10
-rw-r--r--debian/patches/22_use___GLIBC__.diff35
-rw-r--r--debian/patches/50_kfreebsd_Q_OS.diff15
-rw-r--r--debian/patches/50_kfreebsd_build_fix.diff57
4 files changed, 59 insertions, 58 deletions
diff --git a/debian/changelog b/debian/changelog
index dcdbd2d..590fa0a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,8 @@
qt4-x11 (4:4.7.1-1) UNRELEASED; urgency=low
* New upstream release.
+
+ [ Fathi Boudra ]
* Remove patches:
- 0001_webkit_self_injection_into_qt_configuration.patch - stolen upstream
- 0002_fix_qstatictext_with_opengl1_engine.patch - stolen upstream
@@ -10,7 +12,13 @@ qt4-x11 (4:4.7.1-1) UNRELEASED; urgency=low
* Update installed files.
* Update symbols files.
- -- Fathi Boudra <fabo@debian.org> Wed, 08 Sep 2010 14:10:23 +0300
+ [ Pino Toscano ]
+ * Rework and replace patch 50_kfreebsd_build_fix.diff with two new patches:
+ - 22_use___GLIBC__.diff: use __GLIBC__ instead of Q_OS_LINUX for GLIBC
+ functions
+ - 50_kfreebsd_Q_OS.diff: define Q_OS_FREEBSD_KERNEL for kFreeBSD
+
+ -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Wed, 06 Oct 2010 13:03:12 +0200
qt4-x11 (4:4.7.0~rc1-1) experimental; urgency=low
diff --git a/debian/patches/22_use___GLIBC__.diff b/debian/patches/22_use___GLIBC__.diff
new file mode 100644
index 0000000..d6f1f06
--- /dev/null
+++ b/debian/patches/22_use___GLIBC__.diff
@@ -0,0 +1,35 @@
+Author: Pino Toscano <pino@kde.org>
+Description: Use GLIBC functions on any GLIBC architecture.
+ Make use of __GLIBC__ instead of Q_OS_LINUX for functions available globally
+ in GNU libc, not just on Linux.
+Last-Update: 2010-10-02
+
+--- a/src/corelib/tools/qlocale.cpp
++++ b/src/corelib/tools/qlocale.cpp
+@@ -77,7 +77,7 @@ QT_END_NAMESPACE
+ #include <qdebug.h>
+ #include <time.h>
+
+-#if defined(Q_OS_LINUX) && !defined(__UCLIBC__)
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
+ # include <fenv.h>
+ #endif
+
+@@ -6637,7 +6637,7 @@ Q_CORE_EXPORT char *qdtoa ( double d, in
+ _control87(MCW_EM, MCW_EM);
+ #endif
+
+-#if defined(Q_OS_LINUX) && !defined(__UCLIBC__)
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
+ fenv_t envp;
+ feholdexcept(&envp);
+ #endif
+@@ -6653,7 +6653,7 @@ Q_CORE_EXPORT char *qdtoa ( double d, in
+ #endif //_M_X64
+ #endif //Q_OS_WIN
+
+-#if defined(Q_OS_LINUX) && !defined(__UCLIBC__)
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
+ fesetenv(&envp);
+ #endif
+
diff --git a/debian/patches/50_kfreebsd_Q_OS.diff b/debian/patches/50_kfreebsd_Q_OS.diff
new file mode 100644
index 0000000..9fe7d7a
--- /dev/null
+++ b/debian/patches/50_kfreebsd_Q_OS.diff
@@ -0,0 +1,15 @@
+Author: Pino Toscano <pino@kde.org>
+Description: Fixes FTBFS on GNU/kFreeBSD by creating new Q_OS_FREEBSD_KERNEL.
+Last-Update: 2010-10-06
+
+--- a/src/corelib/global/qglobal.h
++++ b/src/corelib/global/qglobal.h
+@@ -221,6 +221,8 @@
+ #elif defined(__FreeBSD__) || defined(__DragonFly__)
+ # define Q_OS_FREEBSD
+ # define Q_OS_BSD4
++#elif defined(__FreeBSD_kernel__)
++# define Q_OS_FREEBSD_KERNEL
+ #elif defined(__NetBSD__)
+ # define Q_OS_NETBSD
+ # define Q_OS_BSD4
diff --git a/debian/patches/50_kfreebsd_build_fix.diff b/debian/patches/50_kfreebsd_build_fix.diff
deleted file mode 100644
index e029e07..0000000
--- a/debian/patches/50_kfreebsd_build_fix.diff
+++ /dev/null
@@ -1,57 +0,0 @@
-author: Petr Salinger <Petr.Salinger@seznam.cz>
-
-Fixes FTBFS on GNU/kFreeBSD by creating new Q_OS_GLIBC.
-
---- a/src/corelib/global/qglobal.h
-+++ b/src/corelib/global/qglobal.h
-@@ -218,6 +218,12 @@ namespace QT_NAMESPACE {}
- # define Q_OS_RELIANT
- #elif defined(__linux__) || defined(__linux)
- # define Q_OS_LINUX
-+# define Q_OS_GLIBC
-+#elif defined(__GNU_HURD__) || defined(__GNU__)
-+# define Q_OS_HURD
-+# define Q_OS_GLIBC
-+#elif defined(__GLIBC__)
-+# define Q_OS_GLIBC
- #elif defined(__FreeBSD__) || defined(__DragonFly__)
- # define Q_OS_FREEBSD
- # define Q_OS_BSD4
-@@ -238,8 +244,6 @@ namespace QT_NAMESPACE {}
- # define Q_OS_AIX
- #elif defined(__Lynx__)
- # define Q_OS_LYNX
--#elif defined(__GNU__)
--# define Q_OS_HURD
- #elif defined(__DGUX__)
- # define Q_OS_DGUX
- #elif defined(__QNXNTO__)
---- a/src/corelib/tools/qlocale.cpp
-+++ b/src/corelib/tools/qlocale.cpp
-@@ -77,7 +77,7 @@ QT_END_NAMESPACE
- #include <qdebug.h>
- #include <time.h>
-
--#if defined(Q_OS_LINUX) && !defined(__UCLIBC__)
-+#if defined(Q_OS_GLIBC) && !defined(__UCLIBC__)
- # include <fenv.h>
- #endif
-
-@@ -6637,7 +6637,7 @@ Q_CORE_EXPORT char *qdtoa ( double d, in
- _control87(MCW_EM, MCW_EM);
- #endif
-
--#if defined(Q_OS_LINUX) && !defined(__UCLIBC__)
-+#if defined(Q_OS_GLIBC) && !defined(__UCLIBC__)
- fenv_t envp;
- feholdexcept(&envp);
- #endif
-@@ -6653,7 +6653,7 @@ Q_CORE_EXPORT char *qdtoa ( double d, in
- #endif //_M_X64
- #endif //Q_OS_WIN
-
--#if defined(Q_OS_LINUX) && !defined(__UCLIBC__)
-+#if defined(Q_OS_GLIBC) && !defined(__UCLIBC__)
- fesetenv(&envp);
- #endif
-