summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com>2013-02-05 18:51:39 -0300
committerLisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com>2013-02-05 18:51:39 -0300
commit5695cb8823098791b476143ff8be1e08c0cddd42 (patch)
tree869ebeec4290e04296d398cd28b513fca30af488
parentefec96fd8eca6e217b1e02aae30f17af638dbb71 (diff)
downloadqt4-x11-5695cb8823098791b476143ff8be1e08c0cddd42.tar.gz
Drop the changes for the test tst_qsharedmemory.cpp.
We are not shipping it.
-rw-r--r--debian/changelog4
-rw-r--r--debian/patches/change_all_shmget_calls_to_use_user-only_memory.patch24
2 files changed, 10 insertions, 18 deletions
diff --git a/debian/changelog b/debian/changelog
index f2ed8cc..abcc635 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,7 +3,9 @@ qt4-x11 (4:4.8.2+dfsg-11) UNRELEASED; urgency=medium
[ Lisandro Damián Nicanor Pérez Meyer ]
* Take upstream patch change_all_shmget_calls_to_use_user-only_memory.patch.
It changes the shmget calls to get user-only memory, CVE-2013-0254.
- Set urgency to medium.
+ - Set urgency to medium.
+ - Drop changes from tests/auto/qtipc/qsharedmemory/tst_qsharedmemory.cpp,
+ it doesn't exists in the Debian tarball.
-- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Tue, 05 Feb 2013 18:29:49 -0300
diff --git a/debian/patches/change_all_shmget_calls_to_use_user-only_memory.patch b/debian/patches/change_all_shmget_calls_to_use_user-only_memory.patch
index f435cc5..9c2f865 100644
--- a/debian/patches/change_all_shmget_calls_to_use_user-only_memory.patch
+++ b/debian/patches/change_all_shmget_calls_to_use_user-only_memory.patch
@@ -1,10 +1,13 @@
From 20b26bdb3dd5e46b01b9a7e1ce8342074df3c89c Mon Sep 17 00:00:00 2001
From: Thiago Macieira <thiago.macieira@intel.com>
+From: Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
Date: Sat, 22 Dec 2012 08:32:12 -0800
-Subject: [PATCH] Change all shmget calls to user-only memory
-
-Drop the read and write permissions for group and other users in the
-system.
+Description: [PATCH] Change all shmget calls to user-only memory
+ Drop the read and write permissions for group and other users in the
+ system.
+ .
+ The tests/auto/qtipc/qsharedmemory/tst_qsharedmemory.cpp does
+ not exists in the current Debian tarball, so we removed it.
Change-Id: I8fc753f09126651af3fb82df3049050f0b14e876
(cherry-picked from Qt 5 commit 856f209fb63ae336bfb389a12d2a75fa886dc1c5)
@@ -120,19 +123,6 @@ index bf003eb..46a2f97 100644
image_info->shminfo.shmaddr = image->data = (char*)shmat (image_info->shminfo.shmid, 0, 0);
image_info->shminfo.readOnly = False;
-diff --git a/tests/auto/qtipc/qsharedmemory/tst_qsharedmemory.cpp b/tests/auto/qtipc/qsharedmemory/tst_qsharedmemory.cpp
-index 9e77af6..e92a030 100644
---- a/tests/auto/qtipc/qsharedmemory/tst_qsharedmemory.cpp
-+++ b/tests/auto/qtipc/qsharedmemory/tst_qsharedmemory.cpp
-@@ -193,7 +193,7 @@ int tst_QSharedMemory::remove(const QString &key)
- return -3;
- }
-
-- int id = shmget(unix_key, 0, 0660);
-+ int id = shmget(unix_key, 0, 0600);
- if (-1 == id) {
- qDebug() << "shmget failed";
- return -4;
diff --git a/tools/qvfb/qvfbshmem.cpp b/tools/qvfb/qvfbshmem.cpp
index 7f9671f..84b6ebe 100644
--- a/tools/qvfb/qvfbshmem.cpp