summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorModestas Vainius <modax@debian.org>2012-06-09 23:57:46 +0300
committerModestas Vainius <modax@debian.org>2012-06-09 23:57:46 +0300
commitf63f007fe633d945bf0fbaac81eb4029b9e6b7e8 (patch)
treecc7339f2094cc9297b7f414af9cc572a14188e8b
parent39c1edbc448149841a2a0d94a09d3510bdedc4ab (diff)
downloadqt4-x11-f63f007fe633d945bf0fbaac81eb4029b9e6b7e8.tar.gz
Drop patches, merged/stolen from upstream.
- QTBUG-24718_Fix_a_crash_in_cursorToX_when_new_block_is_added.patch - fix_qvfb_build.patch - gcc-4.7.diff
-rw-r--r--debian/changelog5
-rw-r--r--debian/patches/QTBUG-24718_Fix_a_crash_in_cursorToX_when_new_block_is_added.patch30
-rw-r--r--debian/patches/fix_qvfb_build.patch18
-rw-r--r--debian/patches/gcc-4.7.diff37
-rw-r--r--debian/patches/series3
5 files changed, 5 insertions, 88 deletions
diff --git a/debian/changelog b/debian/changelog
index 515a1b2..80f78b3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,11 @@ qt4-x11 (4:4.8.2-0r1) UNRELEASED; urgency=low
* New upstream release.
+ * Drop patches, merged/stolen from upstream:
+ - QTBUG-24718_Fix_a_crash_in_cursorToX_when_new_block_is_added.patch
+ - fix_qvfb_build.patch
+ - gcc-4.7.diff
+
-- Modestas Vainius <modax@debian.org> Sat, 09 Jun 2012 23:53:49 +0300
qt4-x11 (4:4.8.1-2) unstable; urgency=low
diff --git a/debian/patches/QTBUG-24718_Fix_a_crash_in_cursorToX_when_new_block_is_added.patch b/debian/patches/QTBUG-24718_Fix_a_crash_in_cursorToX_when_new_block_is_added.patch
deleted file mode 100644
index 9a7701a..0000000
--- a/debian/patches/QTBUG-24718_Fix_a_crash_in_cursorToX_when_new_block_is_added.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From ebfbabf1f3c2e65acecdb06de3b3a47a933e38f9 Mon Sep 17 00:00:00 2001
-From: Jiang Jiang <jiang.jiang@nokia.com>
-Date: Mon, 2 Apr 2012 12:32:05 +0200
-Subject: [PATCH] Fix a crash in cursorToX() when new block is added
-
-When an empty new block is being added, the layoutData->memory data
-will be 0, thus QTextEngine::attributes() will return 0. We should
-only access the attributes pointer when some text actually exist.
-
-Task-number: QTBUG-24718
-Change-Id: I9ce9f7b57bccf24099a02832ce30fb6cebfaad33
-Reviewed-by: Eskil Abrahamsen Blomfeldt <eskil.abrahamsen-blomfeldt@nokia.com>
-Bug: https://bugreports.qt-project.org/browse/QTBUG-24718
----
- src/gui/text/qtextlayout.cpp | 4 ++++
- 1 file changed, 4 insertions(+)
-
---- a/src/gui/text/qtextlayout.cpp
-+++ b/src/gui/text/qtextlayout.cpp
-@@ -2508,6 +2508,10 @@ qreal QTextLine::cursorToX(int *cursorPo
- int pos = *cursorPos;
- int itm;
- const HB_CharAttributes *attributes = eng->attributes();
-+ if (!attributes) {
-+ *cursorPos = 0;
-+ return x.toReal();
-+ }
- while (pos < line.from + line.length && !attributes[pos].charStop)
- pos++;
- if (pos == line.from + (int)line.length) {
diff --git a/debian/patches/fix_qvfb_build.patch b/debian/patches/fix_qvfb_build.patch
deleted file mode 100644
index 392f48e..0000000
--- a/debian/patches/fix_qvfb_build.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Description: Fix qvfb build failure on Qt 4.8.0
-Bug: https://bugreports.qt.nokia.com/browse/QTBUG-19804
-
----
- tools/qvfb/qvfb.pro | 2 --
- 1 file changed, 2 deletions(-)
-
---- a/tools/qvfb/qvfb.pro
-+++ b/tools/qvfb/qvfb.pro
-@@ -38,8 +38,6 @@ SOURCES = qvfb.cpp \
-
- !embedded {
- DEFINES += QT_NO_QWS_SIGNALHANDLER
-- HEADERS += ../../src/gui/embedded/qlock_p.h
-- SOURCES += ../../src/gui/embedded/qlock.cpp
- }
-
- include(../shared/deviceskin/deviceskin.pri)
diff --git a/debian/patches/gcc-4.7.diff b/debian/patches/gcc-4.7.diff
deleted file mode 100644
index 11ece85..0000000
--- a/debian/patches/gcc-4.7.diff
+++ /dev/null
@@ -1,37 +0,0 @@
-Author: Pino Toscano <pino@debian.org>
-Description: Fix build failures with GCC 4.7
- Fix build issues with GCC 4.7, like code wrongly mistaken for operator"".
-Origin: vendor
-Forwarded: no
-Last-Update: 2012-04-29
-
----
- src/3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalObject.h | 4 +---
- src/3rdparty/javascriptcore/JavaScriptCore/runtime/JSStaticScopeObject.h | 3 +--
- 2 files changed, 2 insertions(+), 5 deletions(-)
-
---- a/src/3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalObject.h
-+++ b/src/3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalObject.h
-@@ -57,9 +57,7 @@ namespace JSC {
-
- class JSGlobalObject : public JSVariableObject {
- protected:
-- using JSVariableObject::JSVariableObjectData;
--
-- struct JSGlobalObjectData : public JSVariableObjectData {
-+ struct JSGlobalObjectData : public JSVariableObject::JSVariableObjectData {
- // We use an explicit destructor function pointer instead of a
- // virtual destructor because we want to avoid adding a vtable
- // pointer to this struct. Adding a vtable pointer would force the
---- a/src/3rdparty/javascriptcore/JavaScriptCore/runtime/JSStaticScopeObject.h
-+++ b/src/3rdparty/javascriptcore/JavaScriptCore/runtime/JSStaticScopeObject.h
-@@ -32,8 +32,7 @@ namespace JSC{
-
- class JSStaticScopeObject : public JSVariableObject {
- protected:
-- using JSVariableObject::JSVariableObjectData;
-- struct JSStaticScopeObjectData : public JSVariableObjectData {
-+ struct JSStaticScopeObjectData : public JSVariableObject::JSVariableObjectData {
- JSStaticScopeObjectData()
- : JSVariableObjectData(&symbolTable, &registerStore + 1)
- {
diff --git a/debian/patches/series b/debian/patches/series
index 41201cf..8bd1e5f 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -2,7 +2,6 @@
Add_support_for_QT_USE_DRAG_DISTANCE_env_var.patch
QTBUG-14724_close_orphaned_file_descriptors_after_printing.patch
QTBUG-21900_Buttons_in_Qt_applications_not_clickable_when_run_under_gnome-shell.patch
-QTBUG-24718_Fix_a_crash_in_cursorToX_when_new_block_is_added.patch
QElfParser-fix-type-of-sh_size.patch
# qt-copy patches
@@ -41,10 +40,8 @@ sh.diff
kfreebsd_monotonic_clock.diff
powerpc_designer_gstabs.diff
qt-multiarch-plugin-path-compat.diff
-fix_qvfb_build.patch
s390x_jscore.diff
add_missing_method_for_QBasicAtomicPointer_on_s390.patch
CVE-2011-3922.patch
qt_atomic_sparc64.patch
-gcc-4.7.diff
no_libicu_message.diff