summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com>2012-12-16 14:57:10 -0300
committerLisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com>2012-12-16 14:57:10 -0300
commit095f2eedd2843fac32b92a604b8a9562f4c5c3f5 (patch)
treee2e576b3404421da4298c440ed10001d65caf5ef
parent1485b79638017a31fbf04faf3206901f6cdc5617 (diff)
downloadqt4-x11-095f2eedd2843fac32b92a604b8a9562f4c5c3f5.tar.gz
Pass -Winvalid to CFLAGS.
Be more verbose to try to catch the IA64 FTBFS.
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/add-winvalid-pch.patch16
-rw-r--r--debian/patches/series1
3 files changed, 19 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index e27689b..d4ffe26 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,8 @@ qt4-x11 (4:4.8.2+dfsg-5) UNRELEASED; urgency=low
[ Lisandro Damián Nicanor Pérez Meyer ]
* Add some changes in order to determine the reason of the FTBFS on ia64:
- Re-allow parallel building on ia64.
+ - Pass -Winvalid-pch to CFLAGS.
+ (Closes: #696096).
-- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Sun, 16 Dec 2012 14:46:08 -0300
diff --git a/debian/patches/add-winvalid-pch.patch b/debian/patches/add-winvalid-pch.patch
new file mode 100644
index 0000000..3183cf2
--- /dev/null
+++ b/debian/patches/add-winvalid-pch.patch
@@ -0,0 +1,16 @@
+Description: Add -Winvalid-pch to CFLAGS.
+ This will allow a more verbose build, which may help us to determine the reason
+ of the FTBFS on ia64.
+Author: Stephan Schreiber <info@fs-driver.org>
+Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=696096
+
+--- a/mkspecs/common/g++-base.conf.orig 2012-12-16 14:36:37.347714646 +0100
++++ b/mkspecs/common/g++-base.conf 2012-12-16 14:37:45.335717820 +0100
+@@ -25,6 +25,6 @@
+ QMAKE_PCH_OUTPUT_EXT = .gch
+
+ QMAKE_CFLAGS_PRECOMPILE = -x c-header -c ${QMAKE_PCH_INPUT} -o ${QMAKE_PCH_OUTPUT}
+-QMAKE_CFLAGS_USE_PRECOMPILE = -include ${QMAKE_PCH_OUTPUT_BASE}
++QMAKE_CFLAGS_USE_PRECOMPILE = -include ${QMAKE_PCH_OUTPUT_BASE} -Winvalid-pch
+ QMAKE_CXXFLAGS_PRECOMPILE = -x c++-header -c ${QMAKE_PCH_INPUT} -o ${QMAKE_PCH_OUTPUT}
+ QMAKE_CXXFLAGS_USE_PRECOMPILE = $$QMAKE_CFLAGS_USE_PRECOMPILE
diff --git a/debian/patches/series b/debian/patches/series
index d37d71b..4dd0d8a 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -51,3 +51,4 @@ qt_atomic_sparc64.patch
no_libicu_message.diff
QTBUG-25324_assistant_segfault_on_start_with_gcc_4.7.patch
fix_use_after_free_qlocale_unix.patch
+add-winvalid-pch.patch