summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com>2012-07-20 12:34:14 -0300
committerLisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com>2012-07-20 12:34:14 -0300
commit625e5db15bc94c7aed6c808b0f03b186cf53d916 (patch)
tree631f0690a9129179215e2e51febb29f463689297
parent4d023273df051ab0d31b0ccaab71a302c006580d (diff)
downloadqt4-x11-625e5db15bc94c7aed6c808b0f03b186cf53d916.tar.gz
Add a patch to solve assistant's segfault on startup.
QTBUG-25324_assistant_segfault_on_start_with_gcc_4.7.patch made by Than Ngo.
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/QTBUG-25324_assistant_segfault_on_start_with_gcc_4.7.patch21
-rw-r--r--debian/patches/series1
3 files changed, 25 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 2441e49..363322f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,8 @@
qt4-x11 (4:4.8.2-2) UNRELEASED; urgency=low
+ [ Lisandro Damián Nicanor Pérez Meyer ]
+ * Add QTBUG-25324_assistant_segfault_on_start_with_gcc_4.7.patch made by
+ Than Ngo to solve a segfault during assistant's startup (Closes: #679874).
-- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Fri, 20 Jul 2012 12:28:16 -0300
diff --git a/debian/patches/QTBUG-25324_assistant_segfault_on_start_with_gcc_4.7.patch b/debian/patches/QTBUG-25324_assistant_segfault_on_start_with_gcc_4.7.patch
new file mode 100644
index 0000000..c56c6a4
--- /dev/null
+++ b/debian/patches/QTBUG-25324_assistant_segfault_on_start_with_gcc_4.7.patch
@@ -0,0 +1,21 @@
+Description: fixes segfault on Assistant's startup
+ This patch calls the static method QApplication::allWidgets()
+ intead of storing them first.
+Author: Than Ngo <than@redhat.com>
+Origin: https://bugreports.qt-project.org/browse/QTBUG-25324?focusedCommentId=179933&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-179933
+Bug: https://bugreports.qt-project.org/browse/QTBUG-25324
+Bug-Debian: http://bugs.debian.org/679874
+Forwarded: not-needed
+
+--- qt4-x11-4.8.2.orig/tools/assistant/tools/assistant/mainwindow.cpp
++++ qt4-x11-4.8.2/tools/assistant/tools/assistant/mainwindow.cpp
+@@ -944,8 +944,7 @@ void MainWindow::updateApplicationFont()
+ if (helpEngine.usesAppFont())
+ font = helpEngine.appFont();
+
+- const QWidgetList &widgets = qApp->allWidgets();
+- foreach (QWidget* widget, widgets)
++ foreach (QWidget* widget, QApplication::allWidgets())
+ widget->setFont(font);
+ }
+
diff --git a/debian/patches/series b/debian/patches/series
index 8bd1e5f..f7b6174 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -45,3 +45,4 @@ add_missing_method_for_QBasicAtomicPointer_on_s390.patch
CVE-2011-3922.patch
qt_atomic_sparc64.patch
no_libicu_message.diff
+QTBUG-25324_assistant_segfault_on_start_with_gcc_4.7.patch