summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPino Toscano <pino@debian.org>2012-05-01 13:09:40 +0200
committerPino Toscano <pino@debian.org>2012-05-01 13:09:40 +0200
commit44b3827bfe4de40b14cf990530851b0f4b6ba1f8 (patch)
tree1dfe6b738e914cc926c38bbd908db5cc0b60d1e1
parentd71e5d519e23acbf78992c8b675aab063f7c0ff4 (diff)
parentcd685368d2fea2fbc29c5bbff77404df8b9168d7 (diff)
downloadqt4-x11-44b3827bfe4de40b14cf990530851b0f4b6ba1f8.tar.gz
Merge remote-tracking branch 'origin/experimental'
-rw-r--r--debian/changelog2
-rw-r--r--debian/control17
-rwxr-xr-xdebian/rules6
3 files changed, 15 insertions, 10 deletions
diff --git a/debian/changelog b/debian/changelog
index e68f237..8d166ec 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -40,6 +40,8 @@ qt4-x11 (4:4.8.1-1) unstable; urgency=low
* Fix build failures with GCC 4.7; patch gcc-4.7.diff. (Closes: #667911)
* Fix atomic support on sparc64, by Aurelien Jarno (thanks!);
patch qt_atomic_sparc64.patch. (Closes: #647265)
+ * Remove ${shlibs:Depends} from all the -dbg packages.
+ * Compress qt4-doc-html as XZ.
-- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Tue, 01 May 2012 12:15:56 +0300
diff --git a/debian/control b/debian/control
index add4d5f..ea194ae 100644
--- a/debian/control
+++ b/debian/control
@@ -602,7 +602,7 @@ Package: libqt4-dbg
Priority: extra
Architecture: any
Section: debug
-Depends: libqtcore4 (= ${binary:Version}), ${misc:Depends}, ${shlibs:Depends}
+Depends: libqtcore4 (= ${binary:Version}), ${misc:Depends}
Breaks: libqt4-debug (<< 4.4.0~beta1-1)
Conflicts: qt-x11-free-dbg
Replaces: libqt4-debug (<< 4.4.0~beta1-1)
@@ -617,8 +617,7 @@ Priority: extra
Architecture: any
Section: debug
Depends: libqt4-designer (= ${binary:Version}),
- ${misc:Depends},
- ${shlibs:Depends}
+ ${misc:Depends}
Breaks: libqt4-dbg (<< 4:4.7.3-3)
Replaces: libqt4-dbg (<< 4:4.7.3-3)
Description: Qt 4 designer library debugging symbols
@@ -632,8 +631,7 @@ Priority: extra
Architecture: any
Section: debug
Depends: libqt4-qt3support (= ${binary:Version}),
- ${misc:Depends},
- ${shlibs:Depends}
+ ${misc:Depends}
Breaks: libqt4-dbg (<< 4:4.7.3-3)
Replaces: libqt4-dbg (<< 4:4.7.3-3)
Description: Qt 3 compatibility library for Qt 4 debugging symbols
@@ -647,7 +645,7 @@ Package: libqt4-script-dbg
Priority: extra
Architecture: any
Section: debug
-Depends: libqt4-script (= ${binary:Version}), ${misc:Depends}, ${shlibs:Depends}
+Depends: libqt4-script (= ${binary:Version}), ${misc:Depends}
Breaks: libqt4-dbg (<< 4:4.7.3-3)
Replaces: libqt4-dbg (<< 4:4.7.3-3)
Description: Qt 4 script library debugging symbols
@@ -673,8 +671,7 @@ Priority: extra
Architecture: any
Section: debug
Depends: libqt4-xmlpatterns (= ${binary:Version}),
- ${misc:Depends},
- ${shlibs:Depends}
+ ${misc:Depends}
Description: Qt 4 XML patterns library debugging symbols
Qt is a cross-platform C++ application framework. Qt's primary feature
is its rich set of widgets that provide standard GUI functionality.
@@ -686,7 +683,7 @@ Package: qt4-bin-dbg
Priority: extra
Architecture: any
Section: debug
-Depends: libqt4-dbg (= ${binary:Version}), ${misc:Depends}, ${shlibs:Depends}
+Depends: libqt4-dbg (= ${binary:Version}), ${misc:Depends}
Breaks: libqt4-dbg (<< 4:4.7.3-3)
Replaces: libqt4-dbg (<< 4:4.7.3-3)
Description: Qt 4 binaries debugging symbols
@@ -699,7 +696,7 @@ Package: qt4-demos-dbg
Priority: extra
Architecture: any
Section: debug
-Depends: qt4-demos (= ${binary:Version}), ${misc:Depends}, ${shlibs:Depends}
+Depends: qt4-demos (= ${binary:Version}), ${misc:Depends}
Description: Qt 4 examples and demos debugging symbols
Qt is a cross-platform C++ application framework. Qt's primary feature
is its rich set of widgets that provide standard GUI functionality.
diff --git a/debian/rules b/debian/rules
index 1d44ef7..0e1aded 100755
--- a/debian/rules
+++ b/debian/rules
@@ -21,6 +21,8 @@ pkgs_dbg := $(shell dh_listpackages | grep dbg | sed -e '/libqt4-dbg/d; s|-dbg||
pkgs_dbgbin := libqt4-dev-bin $(filter-out %-dbg lib% $(pkgs_dbg),$(shell dh_listpackages))
# Library package list for override_dh_makeshlibs, excludes libqt4-phonon
pkgs_lib := $(filter-out %-dev %-dbg libqt4-phonon libqt4-dev-bin,$(filter lib%,$(shell dh_listpackages)))
+# Packages to compress as XZ
+pkgs_compress_xz := qt4-doc-html
# Upstream changelog
upstream_changes := $(wildcard changes-*)
# Current debian version (e.g.: 4:4.5.2-1)
@@ -366,4 +368,8 @@ override_dh_shlibdeps:
dh_shlibdeps -plibqt4-phonon -- -xlibphonon4 -xlibqt4-phonon
dh_shlibdeps --remaining-packages
+override_dh_builddeb:
+ dh_builddeb $(addprefix -p,$(pkgs_compress_xz)) -- -Zxz
+ dh_builddeb --remaining-packages
+
.PHONY: override_dh_auto_test