summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPino Toscano <pino@debian.org>2012-04-29 18:40:52 +0200
committerPino Toscano <pino@debian.org>2012-04-29 18:40:52 +0200
commitea1fee5c391a8a66db82899cec31a2a560932227 (patch)
tree8f43bff92a69becc10d1c10e79340094d65a1eb1
parent829510c9c6f01716b8c8eb91871a4c587a6e62d9 (diff)
downloadqt4-x11-ea1fee5c391a8a66db82899cec31a2a560932227.tar.gz
Revert "Drop the libqt4-phonon package and build with -no-phonon."
phonon is still used by qtconfig, which would not be able to configure phonon(-gstreamer) if qt4 is compiled without phonon support This reverts commit 02b020196b1c40b8b39817199cacc21426558541. Conflicts: debian/changelog
-rw-r--r--debian/changelog3
-rw-r--r--debian/control19
-rw-r--r--debian/libqt4-phonon.install2
-rw-r--r--debian/libqt4-phonon.lintian-overrides1
-rw-r--r--debian/not-installed2
-rwxr-xr-xdebian/rules23
6 files changed, 44 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 0152bb6..92c8b56 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -27,9 +27,6 @@ qt4-x11 (4:4.8.1-0r1) UNRELEASED; urgency=low
- drop elfutils build dependency.
* Bump debhelper build-dependency to 9.
* Fix hyphen-used-as-minus-sign lintian warnings.
- * Drop the libqt4-phonon package and build with -no-phonon.
- It's not needed anymore as QtWebKit is built from an own source package and
- no longer uses phonon anyway.
* Build the documentation in the dh_auto_build-indep target instead of
dh_auto_install.
* Add qt-multiarch-import-path-compat.diff - include legacy pre-multiarch qml
diff --git a/debian/control b/debian/control
index d8580c1..add4d5f 100644
--- a/debian/control
+++ b/debian/control
@@ -431,6 +431,25 @@ Description: Qt 4 test module
The QtTest module provides classes for unit testing Qt applications and
libraries.
+Package: libqt4-phonon
+Architecture: any
+Multi-Arch: same
+Pre-Depends: ${misc:Pre-Depends}
+Depends: ${misc:Depends}, ${shlibs:Depends}
+Conflicts: libphonon4
+Breaks: kdelibs5 (<= 4:4.0.80)
+Replaces: kdelibs5 (<= 4:4.0.80), libphonon4
+Description: Qt 4 Phonon module
+ Qt is a cross-platform C++ application framework. Qt's primary feature
+ is its rich set of widgets that provide standard GUI functionality.
+ .
+ The Qt Phonon module provides a cross-platform multimedia framework that
+ enables the use of audio and video content in Qt applications.
+ .
+ The sole purpose of this package to provide Phonon libraries until libphonon4
+ is built from the phonon source package. Therefore it's only useful when
+ bootstraping new architectures or rebuilding the whole archive from scratch.
+
Package: libqt4-declarative
Architecture: any
Multi-Arch: same
diff --git a/debian/libqt4-phonon.install b/debian/libqt4-phonon.install
new file mode 100644
index 0000000..0f2ac5c
--- /dev/null
+++ b/debian/libqt4-phonon.install
@@ -0,0 +1,2 @@
+usr/lib/*/libphonon.so.4*
+usr/lib/*/qt4/plugins/designer/libphononwidgets.so
diff --git a/debian/libqt4-phonon.lintian-overrides b/debian/libqt4-phonon.lintian-overrides
new file mode 100644
index 0000000..4a91fc8
--- /dev/null
+++ b/debian/libqt4-phonon.lintian-overrides
@@ -0,0 +1 @@
+libqt4-phonon: package-name-doesnt-match-sonames libphonon4
diff --git a/debian/not-installed b/debian/not-installed
index a0bc590..c34972c 100644
--- a/debian/not-installed
+++ b/debian/not-installed
@@ -17,3 +17,5 @@
./usr/lib/libQtWebKit.la
./usr/lib/libQtXml.la
./usr/lib/libQtXmlPatterns.la
+./usr/lib/libphonon.la
+./usr/lib/qt4/plugins/phonon_backend/libphonon_gstreamer.so
diff --git a/debian/rules b/debian/rules
index ea00483..1d44ef7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -19,14 +19,17 @@ export QT_PLUGIN_PATH := $(QTDIR)/plugins
pkgs_dbg := $(shell dh_listpackages | grep dbg | sed -e '/libqt4-dbg/d; s|-dbg||')
# Packages whose debug symbols belong to qt4-bin-dbg
pkgs_dbgbin := libqt4-dev-bin $(filter-out %-dbg lib% $(pkgs_dbg),$(shell dh_listpackages))
-# Library package list for override_dh_makeshlibs
-pkgs_lib := $(filter-out %-dev %-dbg libqt4-dev-bin,$(filter lib%,$(shell dh_listpackages)))
+# Library package list for override_dh_makeshlibs, excludes libqt4-phonon
+pkgs_lib := $(filter-out %-dev %-dbg libqt4-phonon libqt4-dev-bin,$(filter lib%,$(shell dh_listpackages)))
# Upstream changelog
upstream_changes := $(wildcard changes-*)
# Current debian version (e.g.: 4:4.5.2-1)
current_version := $(shell dpkg-parsechangelog | sed -n 's/^Version: //p')
# Specific shlibs version (e.g.: 4:4.5.2)
shlibs_version := $(shell dpkg-parsechangelog | sed -n 's/^Version: //p' | cut -f1 -d '-')
+# libqt4-phonon shlibs. Minimum libphonon4 version may need adjusting for new
+# Qt upstream release
+libqt4phonon_shlibs := libphonon4 (>= 4:4.6.0) | libqt4-phonon (= $(current_version))
# Distribution vendor
vendor := $(shell dpkg-vendor --query Vendor)
@@ -138,7 +141,7 @@ endif
-xmlpatterns \
-no-multimedia \
-audio-backend \
- -no-phonon \
+ -phonon \
-no-phonon-backend \
-svg \
-no-webkit \
@@ -302,6 +305,13 @@ override_dh_auto_install:
# QTBUG-12159 workaround
rm -f debian/tmp//usr/share/qt4/mkspecs/modules/qt_webkit_version.pri
+ # Remove phonon development files
+ rm -f debian/tmp/usr/lib/*/libphonon.la
+ rm -f debian/tmp/usr/lib/*/libphonon.prl
+ rm -f debian/tmp/usr/lib/*/libphonon.so
+ rm -f debian/tmp/usr/lib/*/pkgconfig/phonon.pc
+ rm -rf debian/tmp/usr/include/qt4/phonon
+
# Remove leftover directories
find $(CURDIR)/debian/tmp/usr/lib/qt4 -depth -type d \( -false \
-o -name .moc\* \
@@ -337,11 +347,13 @@ override_dh_installchangelogs:
override_dh_strip:
$(foreach pkg,$(pkgs_dbg),dh_strip -p$(pkg) --dbg-package=$(pkg)-dbg;)
dh_strip $(foreach pkg,$(pkgs_dbgbin),-p$(pkg)) --dbg-package=qt4-bin-dbg
+ dh_strip -plibqt4-phonon
dh_strip --remaining-packages --dbg-package=libqt4-dbg
override_dh_makeshlibs:
# Specific shlibs version (e.g.: 4:4.5.2)
$(foreach pkg,$(pkgs_lib),dh_makeshlibs -p$(pkg) -V '$(pkg) (>= $(shlibs_version))' -- -c0;)
+ dh_makeshlibs -plibqt4-phonon -V'$(libqt4phonon_shlibs)'
# Generate shlibs local files
for pkg in $(pkgs_lib); do \
if test -e debian/$${pkg}/DEBIAN/shlibs ; then \
@@ -349,4 +361,9 @@ override_dh_makeshlibs:
fi \
done
+override_dh_shlibdeps:
+ # Exclude phonon deps from libqt4-phonon itself (they get injected there somehow)
+ dh_shlibdeps -plibqt4-phonon -- -xlibphonon4 -xlibqt4-phonon
+ dh_shlibdeps --remaining-packages
+
.PHONY: override_dh_auto_test