summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFathi Boudra <fabo@debian.org>2008-09-19 16:38:11 +0000
committerFathi Boudra <fabo@debian.org>2008-09-19 16:38:11 +0000
commit05fc9c93525140a159dd18ee4b41fe3c8d52bb9e (patch)
tree08e9cfe7d324fb9b7fb954d2910a9ba8ead251c8
parentc34af8fc5c2791488cfa0d61b0d9a90a4c206aa0 (diff)
downloadqt4-x11-05fc9c93525140a159dd18ee4b41fe3c8d52bb9e.tar.gz
Add PostgreSQL 8.3 support.
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/17_add_postgresql_8.3_support.diff46
-rw-r--r--debian/patches/series1
3 files changed, 49 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index c377256..5733c94 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,8 @@ qt4-x11 (4.4.2-1) UNRELEASED; urgency=low
* Remove upstream patches:
- 0002_https_lowercase.diff
+ * Add Debian patches:
+ - 17_add_postgresql_8.3_support.diff
* Remove Debian patches:
- 72_generic_arch_atomic_header_fix.diff
* Sync qt-copy patches:
diff --git a/debian/patches/17_add_postgresql_8.3_support.diff b/debian/patches/17_add_postgresql_8.3_support.diff
new file mode 100644
index 0000000..adc03e0
--- /dev/null
+++ b/debian/patches/17_add_postgresql_8.3_support.diff
@@ -0,0 +1,46 @@
+Enable PostgreSQL 8.3 support.
+
+--- a/src/sql/drivers/psql/qsql_psql.cpp
++++ b/src/sql/drivers/psql/qsql_psql.cpp
+@@ -639,9 +639,12 @@
+ serverVersion = QPSQLDriver::Version81;
+ break;
+ case 2:
+- default:
+ serverVersion = QPSQLDriver::Version82;
+ break;
++ case 3:
++ default:
++ serverVersion = QPSQLDriver::Version83;
++ break;
+ }
+ break;
+ default:
+@@ -922,6 +925,7 @@
+ case QPSQLDriver::Version8:
+ case QPSQLDriver::Version81:
+ case QPSQLDriver::Version82:
++ case QPSQLDriver::Version83:
+ stmt = QLatin1String("SELECT pg_attribute.attname, pg_attribute.atttypid::int, "
+ "pg_class.relname "
+ "FROM pg_attribute, pg_class "
+@@ -995,6 +999,7 @@
+ case QPSQLDriver::Version8:
+ case QPSQLDriver::Version81:
+ case QPSQLDriver::Version82:
++ case QPSQLDriver::Version83:
+ stmt = QLatin1String("select pg_attribute.attname, pg_attribute.atttypid::int, "
+ "pg_attribute.attnotnull, pg_attribute.attlen, pg_attribute.atttypmod, "
+ "pg_attrdef.adsrc "
+--- a/src/sql/drivers/psql/qsql_psql.h
++++ b/src/sql/drivers/psql/qsql_psql.h
+@@ -106,7 +106,8 @@
+ Version74 = 10,
+ Version8 = 11,
+ Version81 = 12,
+- Version82 = 13
++ Version82 = 13,
++ Version83 = 14
+ };
+
+ explicit QPSQLDriver(QObject *parent=0);
diff --git a/debian/patches/series b/debian/patches/series
index 86aa671..1d91a6c 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -26,6 +26,7 @@
14_add_libraries_to_gui_build_where_actually_needed.diff
15_fix_qmake_makefile_generation.diff
16_hide_std_symbols_on_qtwebkit.diff
+17_add_postgresql_8.3_support.diff
20_mips_atomic_ops.diff
30_webkit_unaligned_access.diff
40_alpha_ice.diff