summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSune Vuorela <debian@pusling.com>2008-07-18 00:36:33 +0000
committerSune Vuorela <debian@pusling.com>2008-07-18 00:36:33 +0000
commit3c76152d1d3f8a855bae0f89b3540232f0be1803 (patch)
tree2017e5aaf589faeb93f2e7a88bcc3a134a7a71d1
parent0783d67bdb5ca59f796830dd0f817539f3e277d5 (diff)
downloadqt4-x11-3c76152d1d3f8a855bae0f89b3540232f0be1803.tar.gz
Make the rules file parallel build safe.
-rw-r--r--debian/changelog1
-rwxr-xr-xdebian/rules9
2 files changed, 9 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 7b491d1..b23a583 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,7 @@ qt4-x11 (4.4.0-5) UNRELEASED; urgency=low
* Remove watchfile. it doesn't work.
* mention qmake-qt4 in description of libqt4-dev. (Closes: 415816)
* Apply patch from friendly hurd porters. (Closes: 485931)
+ * Make the rules file parallel build safe.
-- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Fri, 18 Jul 2008 00:57:42 +0200
diff --git a/debian/rules b/debian/rules
index c9a8a0c..5160573 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,7 +14,7 @@ include /usr/share/cdbs/1/rules/patchsys-quilt.mk
include /usr/share/cdbs/1/rules/utils.mk
DEB_MAKE_INVOKE := $(MAKE)
-DEB_MAKE_BUILD_TARGET := sub-src sub-tools
+DEB_MAKE_BUILD_TARGET := sub-src
DEB_MAKE_INSTALL_TARGET := INSTALL_ROOT=$(DEB_DESTDIR) install
DEB_DH_INSTALL_SOURCEDIR := debian/tmp
@@ -49,6 +49,12 @@ else
PLATFORM_ARG = glibc-g++
endif
+common-build-arch:: debian/stamp-makefile-build-tools
+
+debian/stamp-makefile-build-tools: debian/stamp-makefile-build
+ $(MAKE) sub-tools
+ touch $@
+
common-configure-arch:: config.status
config.status:
@@ -177,6 +183,7 @@ clean::
# Generated on build
rm -f debian/shlibs.local
+ rm -f debian/stamp-makefile-build-tools
common-install-arch::
# Fix wrong path in pkgconfig files