summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFathi Boudra <fabo@debian.org>2008-09-27 07:42:55 +0000
committerFathi Boudra <fabo@debian.org>2008-09-27 07:42:55 +0000
commit4f70e5cc9b022c7c746b1e60f487bf63b95f0be2 (patch)
tree95835a0d2203c88d79d7a74af2c3c4f1f6151d1f
parentb9b96def5ef7b6cfeaf48fda67b9688a8a491a18 (diff)
downloadqt4-x11-4f70e5cc9b022c7c746b1e60f487bf63b95f0be2.tar.gz
* Add qt-copy patches:debian/4.4.2-2
- 0254-fix-qgraphicsproxywidget-deletion-crash.diff Fix deletion of a qgraphicsproxywidget if it is in a layout. It Will be included in Qt 4.4.4.
-rw-r--r--debian/changelog10
-rw-r--r--debian/patches/0248-fix-qwidget-scroll-slowness.diff4
-rw-r--r--debian/patches/0254-fix-qgraphicsproxywidget-deletion-crash.diff23
-rw-r--r--debian/patches/series1
4 files changed, 34 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index fd680da..2c6de2d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,15 +1,21 @@
-qt4-x11 (4.4.2-2) UNRELEASED; urgency=low
+qt4-x11 (4.4.2-2) unstable; urgency=low
+++ Changes by Fathi Boudra:
+
* Add missing Replaces to qt4-qmake.
+ * Add qt-copy patches:
+ - 0254-fix-qgraphicsproxywidget-deletion-crash.diff
+ Fix deletion of a qgraphicsproxywidget if it is in a layout.
+ It Will be included in Qt 4.4.4.
+++ Changes by Ana Beatriz Guerrero Lopez:
+
* Small updates in debian/control:
- Use always Qt 4 instead of Qt4.
- Remove architectures that are not being worked on anymore.
- Some typo.
- -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Thu, 18 Sep 2008 18:22:04 +0200
+ -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Tue, 23 Sep 2008 10:19:36 +0200
qt4-x11 (4.4.2-1) unstable; urgency=low
diff --git a/debian/patches/0248-fix-qwidget-scroll-slowness.diff b/debian/patches/0248-fix-qwidget-scroll-slowness.diff
index 00766f6..7169832 100644
--- a/debian/patches/0248-fix-qwidget-scroll-slowness.diff
+++ b/debian/patches/0248-fix-qwidget-scroll-slowness.diff
@@ -1,5 +1,5 @@
-qt-bugs@ issue : none yet
-Trolltech task ID : none yet
+qt-bugs@ issue : N227210
+Trolltech task ID : 228764
bugs.kde.org number : 167739
applied: no
author: Germain Garand <germain@ebooksfrance.org>
diff --git a/debian/patches/0254-fix-qgraphicsproxywidget-deletion-crash.diff b/debian/patches/0254-fix-qgraphicsproxywidget-deletion-crash.diff
new file mode 100644
index 0000000..34e0970
--- /dev/null
+++ b/debian/patches/0254-fix-qgraphicsproxywidget-deletion-crash.diff
@@ -0,0 +1,23 @@
+qt-bugs@ issue : none
+Trolltech task ID : None
+applied: no
+author: Alexis Menard <alexis.menard@trolltech.com>
+
+Fix deletion of a qgraphicsproxywidget if it is in a layout
+
+Will be included in 4.4.4
+
+--- a/src/gui/graphicsview/qgraphicsproxywidget.cpp
++++ b/src/gui/graphicsview/qgraphicsproxywidget.cpp
+@@ -521,9 +521,8 @@
+ {
+ Q_D(QGraphicsProxyWidget);
+ if (d->widget) {
+- QWidget *w = d->widget;
+- setWidget(0);
+- delete w;
++ QObject::disconnect(d->widget, SIGNAL(destroyed()), this, SLOT(_q_removeWidgetSlot()));
++ delete d->widget;
+ }
+ }
+
diff --git a/debian/patches/series b/debian/patches/series
index cf0f5b5..00ff59e 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -13,6 +13,7 @@
0245-fix-randr-changes-detecting.diff
0248-fix-qwidget-scroll-slowness.diff
0249-webkit-stale-frame-pointer.diff
+0254-fix-qgraphicsproxywidget-deletion-crash.diff
# debian patches
01_qmake_for_debian.diff