summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFathi Boudra <fabo@debian.org>2008-08-02 22:12:48 +0000
committerFathi Boudra <fabo@debian.org>2008-08-02 22:12:48 +0000
commit5b0a3037b55701f6da396320d2916fc8ee631633 (patch)
tree96a78592a195a0b2a550c71be14b75ce76968756
parentd784099ec28acbeddb1e4629c7c2273b8ec96750 (diff)
downloadqt4-x11-5b0a3037b55701f6da396320d2916fc8ee631633.tar.gz
Rename 0002_https_lowercase.cpp to 0002_https_lowercase.diff
Rename 0003_tab_text_cutoff.diff to 0238-fix-qt-qttabbar-size.diff Refresh patches with quilt as it was before. Add 0241-fix-null-stylesheet-warning.diff from qt-copy Close #483790, fixed by Qt4.4.1
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/0002_https_lowercase.diff (renamed from debian/patches/0002_https_lowercase.cpp)2
-rw-r--r--debian/patches/0167-fix-group-reading.diff4
-rw-r--r--debian/patches/0180-window-role.diff26
-rw-r--r--debian/patches/0195-compositing-properties.diff6
-rw-r--r--debian/patches/0203-qtexthtmlparser-link-color.diff6
-rw-r--r--debian/patches/0209-prevent-qt-mixing.diff6
-rw-r--r--debian/patches/0214-fix-qgraphicsproxywidget-tab-crash.diff6
-rw-r--r--debian/patches/0216-allow-isystem-for-headers.diff6
-rw-r--r--debian/patches/0224-fast-qpixmap-fill.diff6
-rw-r--r--debian/patches/0225-invalidate-tabbar-geometry-on-refresh.patch6
-rw-r--r--debian/patches/0226-qtreeview-column_resize_when_needed.diff34
-rw-r--r--debian/patches/0230-qtextcontrol-selectnextword.diff8
-rw-r--r--debian/patches/0232-fix-qdesktopwidget-screen-merge.diff2
-rw-r--r--debian/patches/0233-fix-q3textbrowser-image.diff4
-rw-r--r--debian/patches/0234-fix-mysql-threaded.diff4
-rw-r--r--debian/patches/0235-qdbus-dispatch-async-timeout.diff4
-rw-r--r--debian/patches/0236-qtoolbararealayout-restore.diff8
-rw-r--r--debian/patches/0238-fix-qt-qttabbar-size.diff (renamed from debian/patches/0003_tab_text_cutoff.diff)7
-rw-r--r--debian/patches/0241-fix-null-stylesheet-warning.diff22
-rw-r--r--debian/patches/16_hide_std_symbols_on_qtwebkit.diff4
-rw-r--r--debian/patches/30_webkit-unaligned-access.patch12
-rw-r--r--debian/patches/72_generic_arch_atomic_header_fix.diff2
-rw-r--r--debian/patches/series6
24 files changed, 92 insertions, 107 deletions
diff --git a/debian/changelog b/debian/changelog
index b4a390b..9262d91 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,11 +1,15 @@
qt4-x11 (4.4.1-0r2) UNRELEASED; urgency=low
- * New upstream release.
+ * New upstream release. (Closes: #483790)
+
+ +++ Changes by Fathi Boudra:
+
+ * Add 0241-fix-null-stylesheet-warning.diff from qt-copy.
+++ Changes by Sune Vuorela:
* Remove watchfile. it doesn't work.
- * mention qmake-qt4 in description of libqt4-dev. (Closes: 415816)
+ * mention qmake-qt4 in description of libqt4-dev. (Closes: 415816)
* Apply patch from friendly hurd porters. (Closes: 485931)
* Make the rules file parallel build safe.
diff --git a/debian/patches/0002_https_lowercase.cpp b/debian/patches/0002_https_lowercase.diff
index 3c900d4..15886ef 100644
--- a/debian/patches/0002_https_lowercase.cpp
+++ b/debian/patches/0002_https_lowercase.diff
@@ -1,8 +1,6 @@
Fetched from 4.4.2
treat Https, HTtps, hTTps, ... as https as well
-Index: b/src/network/access/qnetworkaccesshttpbackend.cpp
-===================================================================
--- a/src/network/access/qnetworkaccesshttpbackend.cpp
+++ b/src/network/access/qnetworkaccesshttpbackend.cpp
@@ -64,7 +64,7 @@
diff --git a/debian/patches/0167-fix-group-reading.diff b/debian/patches/0167-fix-group-reading.diff
index 556f29e..5253b1e 100644
--- a/debian/patches/0167-fix-group-reading.diff
+++ b/debian/patches/0167-fix-group-reading.diff
@@ -7,8 +7,8 @@ author: Dirk Mueller <mueller@kde.org>
in big user environments, getgrgid_r() needs more memory than sysconf() returns.
Try a bit harder.
---- a/src/corelib//io/qfsfileengine_unix.cpp
-+++ b/src/corelib//io/qfsfileengine_unix.cpp
+--- a/src/corelib/io/qfsfileengine_unix.cpp
++++ b/src/corelib/io/qfsfileengine_unix.cpp
@@ -835,9 +835,13 @@
size_max = sysconf(_SC_GETGR_R_SIZE_MAX);
if (size_max == -1)
diff --git a/debian/patches/0180-window-role.diff b/debian/patches/0180-window-role.diff
index d3dead5..a3b24e9 100644
--- a/debian/patches/0180-window-role.diff
+++ b/debian/patches/0180-window-role.diff
@@ -12,9 +12,9 @@ name as the window role and most Qt3/KDE3 code is ported to call setObjectName()
this makes the window role set in many cases (which KWin uses for window identifying).
---- a/src/corelib/kernel/qobject.cpp.sav 2008-02-22 09:03:40.000000000 +0100
-+++ b/src/corelib/kernel/qobject.cpp 2008-02-23 16:15:51.000000000 +0100
-@@ -1016,9 +1016,18 @@ void QObject::setObjectName(const QStrin
+--- a/src/corelib/kernel/qobject.cpp
++++ b/src/corelib/kernel/qobject.cpp
+@@ -1016,9 +1016,18 @@
{
Q_D(QObject);
d->objectName = name;
@@ -33,9 +33,9 @@ this makes the window role set in many cases (which KWin uses for window identif
#ifdef QT3_SUPPORT
/*! \internal
QObject::child is compat but needs to call itself recursively,
---- a/src/corelib/kernel/qobject_p.h.sav 2008-02-22 09:23:44.000000000 +0100
-+++ b/src/corelib/kernel/qobject_p.h 2008-02-23 16:16:46.000000000 +0100
-@@ -146,6 +146,9 @@ public:
+--- a/src/corelib/kernel/qobject_p.h
++++ b/src/corelib/kernel/qobject_p.h
+@@ -146,6 +146,9 @@
mutable quint32 connectedSignals;
QString objectName;
@@ -45,9 +45,9 @@ this makes the window role set in many cases (which KWin uses for window identif
// Note: you must hold the signalSlotLock() before accessing the lists below or calling the functions
struct Connection
---- a/src/gui/kernel/qwidget_p.h.sav 2008-02-22 09:04:04.000000000 +0100
-+++ b/src/gui/kernel/qwidget_p.h 2008-02-23 16:17:07.000000000 +0100
-@@ -331,6 +331,7 @@ public:
+--- a/src/gui/kernel/qwidget_p.h
++++ b/src/gui/kernel/qwidget_p.h
+@@ -331,6 +331,7 @@
#if defined(Q_WS_X11)
void setWindowRole();
@@ -55,9 +55,9 @@ this makes the window role set in many cases (which KWin uses for window identif
void sendStartupMessage(const char *message) const;
void setNetWmWindowTypes();
#endif
---- a/src/gui/kernel/qwidget_x11.cpp.sav 2008-02-23 15:28:47.000000000 +0100
-+++ b/src/gui/kernel/qwidget_x11.cpp 2008-02-23 16:31:47.000000000 +0100
-@@ -719,13 +719,17 @@ void QWidgetPrivate::create_sys(WId wind
+--- a/src/gui/kernel/qwidget_x11.cpp
++++ b/src/gui/kernel/qwidget_x11.cpp
+@@ -719,13 +719,17 @@
data.fstrut_dirty = 1;
// declare the widget's window role
@@ -81,7 +81,7 @@ this makes the window role set in many cases (which KWin uses for window identif
}
// set client leader property
-@@ -2686,6 +2792,17 @@ void QWidgetPrivate::setWindowRole()
+@@ -2686,6 +2690,17 @@
(unsigned char *)windowRole.constData(), windowRole.length());
}
diff --git a/debian/patches/0195-compositing-properties.diff b/debian/patches/0195-compositing-properties.diff
index 4ffad6a..1e5b453 100644
--- a/debian/patches/0195-compositing-properties.diff
+++ b/debian/patches/0195-compositing-properties.diff
@@ -9,7 +9,7 @@ so they can be used when compositing.
--- a/src/gui/kernel/qwidget_x11.cpp
+++ b/src/gui/kernel/qwidget_x11.cpp
-@@ -662,6 +662,11 @@ void QWidgetPrivate::create_sys(WId window, bool initializeWindow, bool destroyO
+@@ -662,6 +662,11 @@
Q_ASSERT(id);
XChangeWindowAttributes(dpy, id, CWOverrideRedirect | CWSaveUnder,
&wsa);
@@ -21,7 +21,7 @@ so they can be used when compositing.
} else if (topLevel && !desktop) { // top-level widget
if (!X11->wm_client_leader)
create_wm_client_leader();
-@@ -710,13 +715,21 @@ void QWidgetPrivate::create_sys(WId window, bool initializeWindow, bool destroyO
+@@ -710,13 +715,21 @@
// set EWMH window types
setNetWmWindowTypes();
@@ -45,7 +45,7 @@ so they can be used when compositing.
// declare the widget's window role
QByteArray windowRole;
-@@ -736,10 +749,6 @@ void QWidgetPrivate::create_sys(WId window, bool initializeWindow, bool destroyO
+@@ -736,10 +749,6 @@
XChangeProperty(dpy, id, ATOM(WM_CLIENT_LEADER),
XA_WINDOW, 32, PropModeReplace,
(unsigned char *)&X11->wm_client_leader, 1);
diff --git a/debian/patches/0203-qtexthtmlparser-link-color.diff b/debian/patches/0203-qtexthtmlparser-link-color.diff
index 81fc9ba..1e091b7 100644
--- a/debian/patches/0203-qtexthtmlparser-link-color.diff
+++ b/debian/patches/0203-qtexthtmlparser-link-color.diff
@@ -5,9 +5,9 @@ author: Rafael Fernández López <ereslibre@kde.org>
Links are assigned a foreground color according to the system current color scheme.
---- a/src/gui/text/qtexthtmlparser.cpp (revisión: 745183)
-+++ b/src/gui/text/qtexthtmlparser.cpp (copia de trabajo)
-@@ -1053,7 +1053,7 @@ void QTextHtmlParserNode::initializeProp
+--- a/src/gui/text/qtexthtmlparser.cpp
++++ b/src/gui/text/qtexthtmlparser.cpp
+@@ -1053,7 +1053,7 @@
&& !attributes.at(i + 1).isEmpty()) {
hasHref = true;
charFormat.setUnderlineStyle(QTextCharFormat::SingleUnderline);
diff --git a/debian/patches/0209-prevent-qt-mixing.diff b/debian/patches/0209-prevent-qt-mixing.diff
index 46790e4..e16793c 100644
--- a/debian/patches/0209-prevent-qt-mixing.diff
+++ b/debian/patches/0209-prevent-qt-mixing.diff
@@ -13,9 +13,9 @@ cause problems when mixed with upstream Qt.
This patch does not make qt-copy binary incompatible with upstream Qt.
It only further enforces using the same sources for the whole Qt build.
---- a/src/corelib/kernel/qobject_p.h.sav 2008-01-29 19:37:26.000000000 +0100
-+++ b/src/corelib/kernel/qobject_p.h 2008-01-30 14:08:15.000000000 +0100
-@@ -85,7 +85,9 @@ extern QSignalSpyCallbackSet Q_CORE_EXPO
+--- a/src/corelib/kernel/qobject_p.h
++++ b/src/corelib/kernel/qobject_p.h
+@@ -85,7 +85,9 @@
inline QObjectData::~QObjectData() {}
diff --git a/debian/patches/0214-fix-qgraphicsproxywidget-tab-crash.diff b/debian/patches/0214-fix-qgraphicsproxywidget-tab-crash.diff
index dabd77c..20080e1 100644
--- a/debian/patches/0214-fix-qgraphicsproxywidget-tab-crash.diff
+++ b/debian/patches/0214-fix-qgraphicsproxywidget-tab-crash.diff
@@ -8,10 +8,8 @@ QGraphicsProxyWidget item in a QGraphicsScene had a QWidget associated
with it. As soon as the user pressed <Tab>, QGraphicsProxyWidget
attempted to give the focus to *some* QWidget (even if it was null).
-Index: src/gui/graphicsview/qgraphicsproxywidget.cpp
-===================================================================
---- a/src/gui/graphicsview/qgraphicsproxywidget.cpp (revision 775038)
-+++ b/src/gui/graphicsview/qgraphicsproxywidget.cpp (working copy)
+--- a/src/gui/graphicsview/qgraphicsproxywidget.cpp
++++ b/src/gui/graphicsview/qgraphicsproxywidget.cpp
@@ -386,6 +386,10 @@
}
}
diff --git a/debian/patches/0216-allow-isystem-for-headers.diff b/debian/patches/0216-allow-isystem-for-headers.diff
index f693d76..f844d65 100644
--- a/debian/patches/0216-allow-isystem-for-headers.diff
+++ b/debian/patches/0216-allow-isystem-for-headers.diff
@@ -22,10 +22,8 @@ This patch adds support for using -isystem to allow putting an include
directory at the end of the compiler's header search path.
-Index: configure
-===================================================================
---- a/configure (revision 777050)
-+++ b/configure (working copy)
+--- a/configure
++++ b/configure
@@ -832,6 +832,11 @@
VAL=`echo $1 | sed 's,-D,,'`
fi
diff --git a/debian/patches/0224-fast-qpixmap-fill.diff b/debian/patches/0224-fast-qpixmap-fill.diff
index ab0049f..6e6c5c6 100644
--- a/debian/patches/0224-fast-qpixmap-fill.diff
+++ b/debian/patches/0224-fast-qpixmap-fill.diff
@@ -14,10 +14,8 @@ This patch avoids the expensive image->pixmap conversion by simply discarding
the old pixmap, creating a new one with the correct format, and doing the
fill server side.
-Index: src/gui/image/qpixmap_x11.cpp
-===================================================================
---- a/src/gui/image/qpixmap_x11.cpp (revision 798574)
-+++ b/src/gui/image/qpixmap_x11.cpp (working copy)
+--- a/src/gui/image/qpixmap_x11.cpp
++++ b/src/gui/image/qpixmap_x11.cpp
@@ -1107,7 +1107,26 @@
{
if (fillColor.alpha() != 255) {
diff --git a/debian/patches/0225-invalidate-tabbar-geometry-on-refresh.patch b/debian/patches/0225-invalidate-tabbar-geometry-on-refresh.patch
index 2396619..a02361c 100644
--- a/debian/patches/0225-invalidate-tabbar-geometry-on-refresh.patch
+++ b/debian/patches/0225-invalidate-tabbar-geometry-on-refresh.patch
@@ -19,10 +19,8 @@ of 0, which will be kept in the cache and so the tab bar will never be shown.
This patch fixes the problem by calling updateGeometry() whenever the tab bar's layout is refreshed.
-Index: src/gui/widgets/qtabbar.cpp
-===================================================================
---- a/src/gui/widgets/qtabbar.cpp (revision 796858)
-+++ b/src/gui/widgets/qtabbar.cpp (working copy)
+--- a/src/gui/widgets/qtabbar.cpp
++++ b/src/gui/widgets/qtabbar.cpp
@@ -533,8 +533,8 @@
layoutTabs();
makeVisible(currentIndex);
diff --git a/debian/patches/0226-qtreeview-column_resize_when_needed.diff b/debian/patches/0226-qtreeview-column_resize_when_needed.diff
index e755a19..ea78da2 100644
--- a/debian/patches/0226-qtreeview-column_resize_when_needed.diff
+++ b/debian/patches/0226-qtreeview-column_resize_when_needed.diff
@@ -16,26 +16,22 @@ a
This patch assures that if no header is shown, or if we only have one column (so
no other columns become shrinked), the contents will be visible.
-Index: src/gui/itemviews/qtreeview.h
-===================================================================
---- a/src/gui/itemviews/qtreeview.h (revisión: 803370)
-+++ b/src/gui/itemviews/qtreeview.h (copia de trabajo)
+--- a/src/gui/itemviews/qtreeview.h
++++ b/src/gui/itemviews/qtreeview.h
@@ -229,6 +229,7 @@
Q_PRIVATE_SLOT(d_func(), void _q_columnsAboutToBeRemoved(const QModelIndex &, int, int))
Q_PRIVATE_SLOT(d_func(), void _q_columnsRemoved(const QModelIndex &, int, int))
Q_PRIVATE_SLOT(d_func(), void _q_modelAboutToBeReset())
+ Q_PRIVATE_SLOT(d_func(), void _q_forceColumnResizeToFitContents())
};
-
+
#endif // QT_NO_TREEVIEW
-Index: src/gui/itemviews/qtreeview.cpp
-===================================================================
---- a/src/gui/itemviews/qtreeview.cpp (revisión: 803370)
-+++ b/src/gui/itemviews/qtreeview.cpp (copia de trabajo)
+--- a/src/gui/itemviews/qtreeview.cpp
++++ b/src/gui/itemviews/qtreeview.cpp
@@ -246,6 +246,19 @@
-
+
connect(d->model, SIGNAL(modelAboutToBeReset()), SLOT(_q_modelAboutToBeReset()));
-
+
+ // we connect these signals from the model to a slot that will call
+ // resizeColumnToContents. This is important because if we call it only on
+ // expand() method, when we expand a node, the filling of the model can be
@@ -59,7 +55,7 @@ Index: src/gui/itemviews/qtreeview.cpp
+
+ _q_forceColumnResizeToFitContents();
}
-
+
void QTreeViewPrivate::collapse(int item, bool emitSignal)
@@ -2836,6 +2851,8 @@
else
@@ -68,12 +64,12 @@ Index: src/gui/itemviews/qtreeview.cpp
+
+ _q_forceColumnResizeToFitContents();
}
-
+
void QTreeViewPrivate::prepareAnimatedOperation(int item, AnimatedOperation::Type type)
@@ -2947,6 +2964,25 @@
viewItems.clear();
}
-
+
+void QTreeViewPrivate::_q_forceColumnResizeToFitContents()
+{
+ Q_Q(QTreeView);
@@ -96,15 +92,13 @@ Index: src/gui/itemviews/qtreeview.cpp
void QTreeViewPrivate::_q_columnsAboutToBeRemoved(const QModelIndex &parent, int start, int end)
{
Q_UNUSED(parent);
-Index: src/gui/itemviews/qtreeview_p.h
-===================================================================
---- a/src/gui/itemviews/qtreeview_p.h (revision 803534)
-+++ b/src/gui/itemviews/qtreeview_p.h (working copy)
+--- a/src/gui/itemviews/qtreeview_p.h
++++ b/src/gui/itemviews/qtreeview_p.h
@@ -101,6 +101,7 @@
QPixmap after;
};
-
+
+ void _q_forceColumnResizeToFitContents();
void expand(int item, bool emitSignal);
void collapse(int item, bool emitSignal);
-
+
diff --git a/debian/patches/0230-qtextcontrol-selectnextword.diff b/debian/patches/0230-qtextcontrol-selectnextword.diff
index f57dfa0..810e6a7 100644
--- a/debian/patches/0230-qtextcontrol-selectnextword.diff
+++ b/debian/patches/0230-qtextcontrol-selectnextword.diff
@@ -14,11 +14,9 @@ The patch below adds a few useful ones, i.e. possibly-conflicting ones. I guess
be exhaustive and list all possible shortcuts there....
-Index: src/gui/text/qtextcontrol.cpp
-===================================================================
---- a/src/gui/text/qtextcontrol.cpp (revision 803104)
-+++ b/src/gui/text/qtextcontrol.cpp (working copy)
-@@ -1065,6 +1065,14 @@ void QTextControl::processEvent(QEvent *
+--- a/src/gui/text/qtextcontrol.cpp
++++ b/src/gui/text/qtextcontrol.cpp
+@@ -1065,6 +1065,14 @@
|| ke == QKeySequence::MoveToPreviousWord
|| ke == QKeySequence::MoveToStartOfDocument
|| ke == QKeySequence::MoveToEndOfDocument
diff --git a/debian/patches/0232-fix-qdesktopwidget-screen-merge.diff b/debian/patches/0232-fix-qdesktopwidget-screen-merge.diff
index 8aeed24..1e9edb9 100644
--- a/debian/patches/0232-fix-qdesktopwidget-screen-merge.diff
+++ b/debian/patches/0232-fix-qdesktopwidget-screen-merge.diff
@@ -8,7 +8,7 @@ merge screens even if they're identical in size but overlaying
--- a/src/gui/kernel/qdesktopwidget_x11.cpp
+++ b/src/gui/kernel/qdesktopwidget_x11.cpp
-@@ -186,10 +186,11 @@ void QDesktopWidgetPrivate::init()
+@@ -186,10 +186,11 @@
// merge a "cloned" screen with the previous, hiding all crtcs
// that are currently showing a sub-rect of the previous screen
rects[j].setRect(x, y, w, h);
diff --git a/debian/patches/0233-fix-q3textbrowser-image.diff b/debian/patches/0233-fix-q3textbrowser-image.diff
index 852ea3a..d8d8f2a 100644
--- a/debian/patches/0233-fix-q3textbrowser-image.diff
+++ b/debian/patches/0233-fix-q3textbrowser-image.diff
@@ -5,8 +5,8 @@ author: TT :) (bug reported by Laurent Montel montel@kde.org and patch provides
In qt4.4.x there is a regression in Q3TextBrowser it can load an image.
---- a/src/qt3support/other/q3mimefactory.cpp 2008-06-25 14:30:02 -0000
-+++ b/src/qt3support/other/q3mimefactory.cpp 2008-06-25 14:30:02 -0000
+--- a/src/qt3support/other/q3mimefactory.cpp
++++ b/src/qt3support/other/q3mimefactory.cpp
@@ -182,9 +182,8 @@
QByteArray mimetype("application/octet-stream");
if (extensions.contains(e))
diff --git a/debian/patches/0234-fix-mysql-threaded.diff b/debian/patches/0234-fix-mysql-threaded.diff
index f38a656..05c400b 100644
--- a/debian/patches/0234-fix-mysql-threaded.diff
+++ b/debian/patches/0234-fix-mysql-threaded.diff
@@ -7,8 +7,8 @@ author: Tobias Koenig <tokoe@kde.org>
This patch will fix the handling of connections to
mysql server in a multithreaded environment
---- a/src/sql/drivers/mysql/qsql_mysql.cpp (revision 804421)
-+++ b/src/sql/drivers/mysql/qsql_mysql.cpp (working copy)
+--- a/src/sql/drivers/mysql/qsql_mysql.cpp
++++ b/src/sql/drivers/mysql/qsql_mysql.cpp
@@ -1215,6 +1215,10 @@
d->preparedQuerysEnabled = false;
#endif
diff --git a/debian/patches/0235-qdbus-dispatch-async-timeout.diff b/debian/patches/0235-qdbus-dispatch-async-timeout.diff
index 802946c..0b8ee6e 100644
--- a/debian/patches/0235-qdbus-dispatch-async-timeout.diff
+++ b/debian/patches/0235-qdbus-dispatch-async-timeout.diff
@@ -8,8 +8,8 @@ This patch dispatches synthesized timeout messages directly
after handling them. This is neccessary in order to receive timeout
errors to asynchroneous messages.
---- a/src/dbus/qdbusintegrator.cpp (Revision 827848)
-+++ b/src/dbus/qdbusintegrator.cpp (Arbeitskopie)
+--- a/src/dbus/qdbusintegrator.cpp
++++ b/src/dbus/qdbusintegrator.cpp
@@ -988,6 +988,7 @@
{
DBusTimeout *timeout = timeouts.value(e->timerId(), 0);
diff --git a/debian/patches/0236-qtoolbararealayout-restore.diff b/debian/patches/0236-qtoolbararealayout-restore.diff
index ae9fc03..bdb629d 100644
--- a/debian/patches/0236-qtoolbararealayout-restore.diff
+++ b/debian/patches/0236-qtoolbararealayout-restore.diff
@@ -7,11 +7,9 @@ author: TT
QMainWindow::restoreState doesn't layout toolbars properly, regression
from Qt-4.4
-Index: src/gui/widgets/qtoolbararealayout.cpp
-===================================================================
---- a/src/gui/widgets/qtoolbararealayout.cpp (revision 829449)
-+++ b/src/gui/widgets/qtoolbararealayout.cpp (working copy)
-@@ -1323,7 +1323,8 @@ bool QToolBarAreaLayout::restoreState(QD
+--- a/src/gui/widgets/qtoolbararealayout.cpp
++++ b/src/gui/widgets/qtoolbararealayout.cpp
+@@ -1323,7 +1323,8 @@
toolBar->setVisible(shown);
toolBar->d_func()->setWindowState(floating, true, rect);
diff --git a/debian/patches/0003_tab_text_cutoff.diff b/debian/patches/0238-fix-qt-qttabbar-size.diff
index 9f90b9b..27f329e 100644
--- a/debian/patches/0003_tab_text_cutoff.diff
+++ b/debian/patches/0238-fix-qt-qttabbar-size.diff
@@ -7,11 +7,6 @@ author: Michael Leupold <lemma@confuego.org>
This patch fixes some characters in a tabbar being cut-off due
to a wrong size hint (visible if using a kstyle).
-More info here.
-http://lists.kde.org/?l=kde-core-devel&m=121526335523921&w=2
-It might very well very soon be a qtcopy patch
-Index: b/src/gui/widgets/qtabbar.cpp
-===================================================================
--- a/src/gui/widgets/qtabbar.cpp
+++ b/src/gui/widgets/qtabbar.cpp
@@ -1084,7 +1084,7 @@
@@ -19,7 +14,7 @@ Index: b/src/gui/widgets/qtabbar.cpp
initStyleOption(&opt, index);
opt.text = d->tabList.at(index).text;
- QSize iconSize = tab->icon.isNull() ? QSize() : opt.iconSize;
-+ QSize iconSize = tab->icon.isNull() ? QSize(0,0) : opt.iconSize;
++ QSize iconSize = tab->icon.isNull() ? QSize(0, 0) : opt.iconSize;
int hframe = style()->pixelMetric(QStyle::PM_TabBarTabHSpace, &opt, this);
int vframe = style()->pixelMetric(QStyle::PM_TabBarTabVSpace, &opt, this);
const QFontMetrics fm = fontMetrics();
diff --git a/debian/patches/0241-fix-null-stylesheet-warning.diff b/debian/patches/0241-fix-null-stylesheet-warning.diff
new file mode 100644
index 0000000..194efd6
--- /dev/null
+++ b/debian/patches/0241-fix-null-stylesheet-warning.diff
@@ -0,0 +1,22 @@
+qt-bugs@ issue : none
+Trolltech task ID : none
+bugs.kde.org number : none
+applied: no
+author: Robert Knight <robertknight@gmail.com>
+
+Fix a QObject::connect() warning when calling QWidget::setFont()
+on a widget which does not have its own style sheet and which has
+children with Qt::WA_StyleSheet set (as a result of being polished
+by a style sheet style)
+
+--- a/src/gui/kernel/qwidget.cpp
++++ b/src/gui/kernel/qwidget.cpp
+@@ -4001,7 +4001,7 @@
+ QWidget *w = qobject_cast<QWidget*>(children.at(i));
+ if (w) {
+ #ifndef QT_NO_STYLE_STYLESHEET
+- if (w->testAttribute(Qt::WA_StyleSheet))
++ if (cssStyle && w->testAttribute(Qt::WA_StyleSheet))
+ cssStyle->updateStyleSheetFont(w);
+ else
+ #endif
diff --git a/debian/patches/16_hide_std_symbols_on_qtwebkit.diff b/debian/patches/16_hide_std_symbols_on_qtwebkit.diff
index 5df9aa4..9cd4bba 100644
--- a/debian/patches/16_hide_std_symbols_on_qtwebkit.diff
+++ b/debian/patches/16_hide_std_symbols_on_qtwebkit.diff
@@ -1,5 +1,3 @@
-Index: b/src/3rdparty/webkit/WebKit.pri
-===================================================================
--- a/src/3rdparty/webkit/WebKit.pri
+++ b/src/3rdparty/webkit/WebKit.pri
@@ -27,6 +27,7 @@
@@ -10,8 +8,6 @@ Index: b/src/3rdparty/webkit/WebKit.pri
gtk-port:INCLUDEPATH += \
$$BASE_DIR/WebCore/platform/gtk \
$$BASE_DIR/WebCore/platform/network/curl \
-Index: b/src/3rdparty/webkit/symbols.filter
-===================================================================
--- /dev/null
+++ b/src/3rdparty/webkit/symbols.filter
@@ -0,0 +1,5 @@
diff --git a/debian/patches/30_webkit-unaligned-access.patch b/debian/patches/30_webkit-unaligned-access.patch
index 5bec884..fdfdf4b 100644
--- a/debian/patches/30_webkit-unaligned-access.patch
+++ b/debian/patches/30_webkit-unaligned-access.patch
@@ -12,8 +12,6 @@ Some compiler warnings about alignment remain, but I don't know if they are
a real problem yet.
---
-Index: b/src/3rdparty/webkit/JavaScriptCore/wtf/FastMalloc.cpp
-===================================================================
--- a/src/3rdparty/webkit/JavaScriptCore/wtf/FastMalloc.cpp
+++ b/src/3rdparty/webkit/JavaScriptCore/wtf/FastMalloc.cpp
@@ -1267,14 +1267,14 @@
@@ -33,8 +31,6 @@ Index: b/src/3rdparty/webkit/JavaScriptCore/wtf/FastMalloc.cpp
TCMalloc_PageHeap m_pageHeap;
} PageHeapUnion;
-Index: b/src/3rdparty/webkit/JavaScriptCore/wtf/ListHashSet.h
-===================================================================
--- a/src/3rdparty/webkit/JavaScriptCore/wtf/ListHashSet.h
+++ b/src/3rdparty/webkit/JavaScriptCore/wtf/ListHashSet.h
@@ -122,7 +122,7 @@
@@ -67,8 +63,6 @@ Index: b/src/3rdparty/webkit/JavaScriptCore/wtf/ListHashSet.h
};
template<typename ValueArg> struct ListHashSetNode {
-Index: b/src/3rdparty/webkit/JavaScriptCore/wtf/Platform.h
-===================================================================
--- a/src/3rdparty/webkit/JavaScriptCore/wtf/Platform.h
+++ b/src/3rdparty/webkit/JavaScriptCore/wtf/Platform.h
@@ -167,6 +167,23 @@
@@ -95,8 +89,6 @@ Index: b/src/3rdparty/webkit/JavaScriptCore/wtf/Platform.h
/* Compiler */
/* COMPILER(MSVC) */
-Index: b/src/3rdparty/webkit/JavaScriptCore/wtf/Vector.h
-===================================================================
--- a/src/3rdparty/webkit/JavaScriptCore/wtf/Vector.h
+++ b/src/3rdparty/webkit/JavaScriptCore/wtf/Vector.h
@@ -355,8 +355,7 @@
@@ -109,8 +101,6 @@ Index: b/src/3rdparty/webkit/JavaScriptCore/wtf/Vector.h
};
template<typename T, size_t inlineCapacity = 0>
-Index: b/src/3rdparty/webkit/WebCore/platform/AtomicString.cpp
-===================================================================
--- a/src/3rdparty/webkit/WebCore/platform/AtomicString.cpp
+++ b/src/3rdparty/webkit/WebCore/platform/AtomicString.cpp
@@ -104,7 +104,7 @@
@@ -122,8 +112,6 @@ Index: b/src/3rdparty/webkit/WebCore/platform/AtomicString.cpp
const UChar* strChars = str->characters();
const UChar* bufChars = buf.s;
-Index: b/src/3rdparty/webkit/WebCore/platform/StringHash.h
-===================================================================
--- a/src/3rdparty/webkit/WebCore/platform/StringHash.h
+++ b/src/3rdparty/webkit/WebCore/platform/StringHash.h
@@ -44,6 +44,15 @@
diff --git a/debian/patches/72_generic_arch_atomic_header_fix.diff b/debian/patches/72_generic_arch_atomic_header_fix.diff
index a6a1f8d..b61efcf 100644
--- a/debian/patches/72_generic_arch_atomic_header_fix.diff
+++ b/debian/patches/72_generic_arch_atomic_header_fix.diff
@@ -2,8 +2,6 @@ http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=475767
This mostly affects hppa, but hppa is "community supported" - meaning that the Trolls doesn't care much.
-Index: b/src/corelib/arch/qatomic_generic.h
-===================================================================
--- a/src/corelib/arch/qatomic_generic.h
+++ b/src/corelib/arch/qatomic_generic.h
@@ -223,7 +223,7 @@
diff --git a/debian/patches/series b/debian/patches/series
index 66ea99d..2cf25b9 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,6 +1,6 @@
# patches from upstream
-0002_https_lowercase.cpp
-0003_tab_text_cutoff.diff
+0002_https_lowercase.diff
+
# qt-copy patches
0167-fix-group-reading.diff
0180-window-role.diff
@@ -18,6 +18,8 @@
0234-fix-mysql-threaded.diff
0235-qdbus-dispatch-async-timeout.diff
0236-qtoolbararealayout-restore.diff
+0238-fix-qt-qttabbar-size.diff
+0241-fix-null-stylesheet-warning.diff
# debian patches
01_qmake_for_debian.diff