summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSune Vuorela <debian@pusling.com>2008-07-09 00:23:26 +0000
committerSune Vuorela <debian@pusling.com>2008-07-09 00:23:26 +0000
commit72f3fd66c010f2af61821a0e265d6db96ddb2435 (patch)
tree9aa17bcfdd13b2282a6ed2fc11fe907840c9e7bb
parent642eae84652170e0eed47c5eebe2f9894e6c37da (diff)
downloadqt4-x11-72f3fd66c010f2af61821a0e265d6db96ddb2435.tar.gz
Don't make the std:: symbols in webkit public. Solution based on the work
of Mike Hommey in the gtk webkit package.
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/16_hide_std_symbols_on_qtwebkit.diff22
-rw-r--r--debian/patches/series1
3 files changed, 25 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 6d3b896..0fbff7b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,8 @@ qt4-x11 (4.4.0-4~pre1) unstable; urgency=low
* Fix some unaligned access issues that makes any webkit using application
crash (SIGBUS) on archs where this isn't allowed. Patch by Mike Hommey.
See #487745 for details.
+ * Don't make the std:: symbols in webkit public. Solution based on the work
+ of Mike Hommey in the gtk webkit package.
+++ Changes by Modestas Vainius:
diff --git a/debian/patches/16_hide_std_symbols_on_qtwebkit.diff b/debian/patches/16_hide_std_symbols_on_qtwebkit.diff
new file mode 100644
index 0000000..5df9aa4
--- /dev/null
+++ b/debian/patches/16_hide_std_symbols_on_qtwebkit.diff
@@ -0,0 +1,22 @@
+Index: b/src/3rdparty/webkit/WebKit.pri
+===================================================================
+--- a/src/3rdparty/webkit/WebKit.pri
++++ b/src/3rdparty/webkit/WebKit.pri
+@@ -27,6 +27,7 @@
+ BASE_DIR = $$PWD
+ qt-port:INCLUDEPATH += \
+ $$PWD/WebKit/qt/Api
++qt-port:QMAKE_LFLAGS += -Wl,--version-script,$$BASE_DIR/symbols.filter
+ gtk-port:INCLUDEPATH += \
+ $$BASE_DIR/WebCore/platform/gtk \
+ $$BASE_DIR/WebCore/platform/network/curl \
+Index: b/src/3rdparty/webkit/symbols.filter
+===================================================================
+--- /dev/null
++++ b/src/3rdparty/webkit/symbols.filter
+@@ -0,0 +1,5 @@
++{
++local:
++_ZSt*;
++_ZNSt*;
++};
diff --git a/debian/patches/series b/debian/patches/series
index f4b2ec4..e1c1e0c 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -32,6 +32,7 @@
12_fix_qmake_pkgconfig.diff
14_add_libraries_to_gui_build_where_actually_needed.diff
15_fix_qmake_makefile_generation.diff
+16_hide_std_symbols_on_qtwebkit.diff
20_mips_atomic_ops.diff
21_qprintdialog_honour_fileprintersadded.diff
30_webkit-unaligned-access.patch