summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2008-04-21 16:22:19 +0000
committerModestas Vainius <modestas@vainius.eu>2008-04-21 16:22:19 +0000
commit84af1ee17d9780b2afb45c05e64216bb9f623601 (patch)
tree7090c08ca442108d5edb13789687771d3be53c04
parentbfaeb1ab60958d9bce8b85437d9b3b4b39436d7b (diff)
downloadqt4-x11-84af1ee17d9780b2afb45c05e64216bb9f623601.tar.gz
Fix initialization of X11->ptrXcursorLibraryLoadCursor when libxcursor1 is not installed on the system (Closes grave: #476608)
-rw-r--r--debian/changelog5
-rw-r--r--debian/patches/16_always_init_prtxcursor.diff11
-rw-r--r--debian/patches/series1
3 files changed, 16 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 534d1f0..cf6d398 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -32,8 +32,11 @@ qt4-x11 (4.4.0~rc1-5) UNRELEASED; urgency=low
the specific plugin(s). Finally, this resolves circular dependencies among
libqt4-sql and its plugins.
* Add myself to Uploaders.
+ * Add 16_always_init_prtxcursor.diff, which properly initializes
+ X11->ptrXcursorLibraryLoadCursor to NULL when Xcursor library is not
+ available on the system. (Closes: #476608)
- -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Sun, 20 Apr 2008 13:24:08 +0300
+ -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Mon, 21 Apr 2008 19:17:19 +0300
qt4-x11 (4.4.0~rc1-4) unstable; urgency=low
diff --git a/debian/patches/16_always_init_prtxcursor.diff b/debian/patches/16_always_init_prtxcursor.diff
new file mode 100644
index 0000000..1b1f956
--- /dev/null
+++ b/debian/patches/16_always_init_prtxcursor.diff
@@ -0,0 +1,11 @@
+--- qt4-x11-4.4.0~rc1.orig/src/gui/kernel/qapplication_x11.cpp 2008-04-21 19:11:01.000000000 +0300
++++ qt4-x11-4.4.0~rc1/src/gui/kernel/qapplication_x11.cpp 2008-04-21 19:13:17.000000000 +0300
+@@ -1778,6 +1778,8 @@
+ if (xcursorLib.load()) {
+ X11->ptrXcursorLibraryLoadCursor =
+ (PtrXcursorLibraryLoadCursor) xcursorLib.resolve("XcursorLibraryLoadCursor");
++ } else {
++ X11->ptrXcursorLibraryLoadCursor = NULL;
+ }
+ #else
+ X11->ptrXcursorLibraryLoadCursor = XcursorLibraryLoadCursor;
diff --git a/debian/patches/series b/debian/patches/series
index d4db67b..ef49c66 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -26,6 +26,7 @@
12_fix_qmake_pkgconfig.diff
14_add_libraries_to_gui_build_where_actually_needed.diff
15_fix_qmake_makefile_generation.diff
+16_always_init_prtxcursor.diff
20_mips_atomic_ops.diff
40_alpha_ice.diff
41_disable_opengl_visibility.diff