summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSune Vuorela <debian@pusling.com>2008-06-12 06:51:35 +0000
committerSune Vuorela <debian@pusling.com>2008-06-12 06:51:35 +0000
commit90549d6d842612afd8ee1f0a891d472629d63637 (patch)
tree4bd219537dbd93f5ab035d9852706e2fb8846797
parent7cf68afd65cdef9cd71a7ceb17c6ba185abe0431 (diff)
downloadqt4-x11-90549d6d842612afd8ee1f0a891d472629d63637.tar.gz
fix qtwebkit-scrollbar rendering issue
-rw-r--r--debian/changelog9
-rw-r--r--debian/patches/0001_webkit_backround_in_scrollbars_webkit-5b0ea6b840a6e25e97b886e1852c3fc6ef8e8d0d.diff42
-rw-r--r--debian/patches/series2
3 files changed, 52 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 30546d2..8f81dad 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,11 @@
-qt4-x11 (4.4.0-3) UNRELEASED; urgency=low
+qt4-x11 (4.4.0-4) unstable; urgency=low
+
+ * Get patch from 4.4.2 (yes!) to fix painting of scrollbars in webkit with
+ some styles.
+
+ -- Sune Vuorela <debian@pusling.com> Wed, 11 Jun 2008 23:22:22 +0200
+
+qt4-x11 (4.4.0-3) unstable; urgency=low
+++ Changes by Sune Vuorela:
diff --git a/debian/patches/0001_webkit_backround_in_scrollbars_webkit-5b0ea6b840a6e25e97b886e1852c3fc6ef8e8d0d.diff b/debian/patches/0001_webkit_backround_in_scrollbars_webkit-5b0ea6b840a6e25e97b886e1852c3fc6ef8e8d0d.diff
new file mode 100644
index 0000000..5e3195c
--- /dev/null
+++ b/debian/patches/0001_webkit_backround_in_scrollbars_webkit-5b0ea6b840a6e25e97b886e1852c3fc6ef8e8d0d.diff
@@ -0,0 +1,42 @@
+This is expected to be in 4.4.2
+
+
+From: Tor Arne Vestbø <tavestbo@trolltech.com>
+Date: Tue, 10 Jun 2008 16:04:06 +0000 (+0200)
+Subject: Fill the background of scrollbars to the window color before
+X-Git-Url: http://code.staikos.net/cgi-bin/gitweb.cgi?p=webkit;a=commitdiff_plain;h=5b0ea6b840a6e25e97b886e1852c3fc6ef8e8d0d
+
+Fill the background of scrollbars to the window color before
+letting the QStyle paint its primitive elements.
+
+Signed-off-by: Simon
+---
+
++2008-06-10 Tor Arne Vestbø <tavestbo@trolltech.com>
++
++ Reviewed by Simon
++
++ Fill the background of scrollbars to the window color before
++ letting the QStyle paint its primitive elements.
++
++ * platform/qt/PlatformScrollBarQt.cpp:
++ (WebCore::PlatformScrollbar::paint):
++
+ 2008-05-30 Adam Treat <treat@kde.org>
+
+ Reviewed by Simon.
+diff --git a/WebCore/platform/qt/PlatformScrollBarQt.cpp b/WebCore/platform/qt/PlatformScrollBarQt.cpp
+index 66063eb..c7f5bdd 100644
+--- a/src/3rdparty/webkit/WebCore/platform/qt/PlatformScrollBarQt.cpp
++++ b/src/3rdparty/webkit/WebCore/platform/qt/PlatformScrollBarQt.cpp
+@@ -183,6 +183,10 @@ void PlatformScrollbar::paint(GraphicsContext* graphicsContext, const IntRect& d
+ #else
+ p->translate(topLeft);
+ m_opt.rect.moveTo(QPoint(0, 0));
++
++ // The QStyle expects the background to be already filled
++ p->fillRect(m_opt.rect, m_opt.palette.background());
++
+ QApplication::style()->drawComplexControl(QStyle::CC_ScrollBar, &m_opt, p, 0);
+ m_opt.rect.moveTo(topLeft);
+ #endif
diff --git a/debian/patches/series b/debian/patches/series
index c2e2e6a..acb148c 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,5 @@
+# patches from upstream
+0001_webkit_backround_in_scrollbars_webkit-5b0ea6b840a6e25e97b886e1852c3fc6ef8e8d0d.diff
# qt-copy patches
0167-fix-group-reading.diff
0180-window-role.diff