summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSune Vuorela <debian@pusling.com>2008-07-09 00:51:05 +0000
committerSune Vuorela <debian@pusling.com>2008-07-09 00:51:05 +0000
commitb046907eaad4bb0f0a13b589ba7278746f88ec73 (patch)
tree99d1cd998f2927d7dd79a24fad1ca5652d720623
parent1769b05ea1b809dd409a24f69c96c810d001b951 (diff)
downloadqt4-x11-b046907eaad4bb0f0a13b589ba7278746f88ec73.tar.gz
Add 0003_tab_text_cutoff.diff patch to fix rendering of text in tabs.
Patch available in qt4.5.
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/0003_tab_text_cutoff.diff25
-rw-r--r--debian/patches/series1
3 files changed, 28 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 9f86b9a..4247106 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -14,6 +14,8 @@ qt4-x11 (4.4.0-4~pre1) unstable; urgency=low
by Thiago.
* Add 0236-qtoolbararealayout-restore.diff to fix a regression in qt4.4.
Patch from Trolltech.
+ * Add 0003_tab_text_cutoff.diff patch to fix rendering of text in tabs.
+ Patch available in qt4.5.
+++ Changes by Modestas Vainius:
diff --git a/debian/patches/0003_tab_text_cutoff.diff b/debian/patches/0003_tab_text_cutoff.diff
new file mode 100644
index 0000000..9f90b9b
--- /dev/null
+++ b/debian/patches/0003_tab_text_cutoff.diff
@@ -0,0 +1,25 @@
+qt-bugs@ issue : N216195
+Trolltech task ID : 216537
+bugs.kde.org number : 162737
+applied: no
+author: Michael Leupold <lemma@confuego.org>
+
+This patch fixes some characters in a tabbar being cut-off due
+to a wrong size hint (visible if using a kstyle).
+
+More info here.
+http://lists.kde.org/?l=kde-core-devel&m=121526335523921&w=2
+It might very well very soon be a qtcopy patch
+Index: b/src/gui/widgets/qtabbar.cpp
+===================================================================
+--- a/src/gui/widgets/qtabbar.cpp
++++ b/src/gui/widgets/qtabbar.cpp
+@@ -1084,7 +1084,7 @@
+ QStyleOptionTabV2 opt;
+ initStyleOption(&opt, index);
+ opt.text = d->tabList.at(index).text;
+- QSize iconSize = tab->icon.isNull() ? QSize() : opt.iconSize;
++ QSize iconSize = tab->icon.isNull() ? QSize(0,0) : opt.iconSize;
+ int hframe = style()->pixelMetric(QStyle::PM_TabBarTabHSpace, &opt, this);
+ int vframe = style()->pixelMetric(QStyle::PM_TabBarTabVSpace, &opt, this);
+ const QFontMetrics fm = fontMetrics();
diff --git a/debian/patches/series b/debian/patches/series
index 3284ff2..53ede42 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,6 +1,7 @@
# patches from upstream
0001_webkit_backround_in_scrollbars_webkit-5b0ea6b840a6e25e97b886e1852c3fc6ef8e8d0d.diff
0002_https_lowercase.cpp
+0003_tab_text_cutoff.diff
# qt-copy patches
0167-fix-group-reading.diff
0180-window-role.diff