summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmin Berres <trigger+debian@space-based.de>2008-11-30 23:17:49 +0000
committerArmin Berres <trigger+debian@space-based.de>2008-11-30 23:17:49 +0000
commitc6857e17d2e54b2b874bbdb8ae3e08ede84cac10 (patch)
tree570b598cd103218c0281b59ab6847f21bcbf66d8
parente0254b8993bbeadf89bb83376aa8e7b91fa52b7f (diff)
downloadqt4-x11-c6857e17d2e54b2b874bbdb8ae3e08ede84cac10.tar.gz
+++ Changes by Armin Berres:
* Fix offsets in all patches.
-rw-r--r--debian/changelog10
-rw-r--r--debian/patches/01_qmake_for_debian.diff2
-rw-r--r--debian/patches/0238-fix-qt-qttabbar-size.diff2
-rw-r--r--debian/patches/0245-fix-randr-changes-detecting.diff2
-rw-r--r--debian/patches/0248-fix-qwidget-scroll-slowness.diff4
-rw-r--r--debian/patches/0249-webkit-stale-frame-pointer.diff22
-rw-r--r--debian/patches/0254-fix-qgraphicsproxywidget-deletion-crash.diff2
-rw-r--r--debian/patches/02_launch_assistant-qt4.diff4
-rw-r--r--debian/patches/03_launch_moc-qt4.diff2
-rw-r--r--debian/patches/04_launch_uic-qt4.diff2
-rw-r--r--debian/patches/05_append_qt4_target.diff36
-rw-r--r--debian/patches/07_trust_dpkg-arch_over_uname-m.diff2
-rw-r--r--debian/patches/09_qmake_lflags_as-needed.diff2
-rw-r--r--debian/patches/10_config_tests_fixes.diff8
-rw-r--r--debian/patches/12_fix_qmake_pkgconfig.diff2
-rw-r--r--debian/patches/14_add_libraries_to_gui_build_where_actually_needed.diff4
-rw-r--r--debian/patches/15_fix_qmake_makefile_generation.diff2
-rw-r--r--debian/patches/16_hide_std_symbols_on_qtwebkit.diff2
-rw-r--r--debian/patches/17_add_postgresql_8.3_support.diff8
-rw-r--r--debian/patches/20_mips_atomic_ops.diff14
-rw-r--r--debian/patches/30_webkit_unaligned_access.diff16
-rw-r--r--debian/patches/40_alpha_ice.diff6
-rw-r--r--debian/patches/41_disable_opengl_visibility.diff2
-rw-r--r--debian/patches/50_kfreebsd_build_fix.diff12
-rw-r--r--debian/patches/71_hppa_unaligned_access_fix_458133.diff4
-rw-r--r--debian/patches/80_hurd_max_path.diff2
-rw-r--r--debian/patches/series6
27 files changed, 95 insertions, 85 deletions
diff --git a/debian/changelog b/debian/changelog
index 46e9b96..18e805c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,12 +1,16 @@
-qt4-x11 (4.4.3-2) UNRELEASED; urgency=low
+qt4-x11 (4.4.3-2.1) UNRELEASED; urgency=low
+
+ +++ Changes by Armin Berres:
+
+ * Fix offsets in all patches.
+++ Changes by Fathi Boudra:
* Add Qt Eclipse Integration for C++. Configure Qt with
'-qtnamespace QtCppIntegration -qtlibinfix CppIntegration'
to create custom designer plugins.
-
- -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Tue, 07 Oct 2008 14:58:01 +0200
+
+ -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Mon, 01 Dec 2008 00:15:06 +0100
qt4-x11 (4.4.3-1) unstable; urgency=low
diff --git a/debian/patches/01_qmake_for_debian.diff b/debian/patches/01_qmake_for_debian.diff
index d03f635..24b2893 100644
--- a/debian/patches/01_qmake_for_debian.diff
+++ b/debian/patches/01_qmake_for_debian.diff
@@ -4,7 +4,7 @@ Ensures qmake generates Makefiles that use the -qt4 tools.
--- a/mkspecs/common/linux.conf
+++ b/mkspecs/common/linux.conf
-@@ -23,8 +23,8 @@
+@@ -23,8 +23,8 @@ QMAKE_LIBS_OPENGL = -lGLU -lGL
QMAKE_LIBS_OPENGL_QT = -lGL
QMAKE_LIBS_THREAD = -lpthread
diff --git a/debian/patches/0238-fix-qt-qttabbar-size.diff b/debian/patches/0238-fix-qt-qttabbar-size.diff
index aaaa085..8b35ab0 100644
--- a/debian/patches/0238-fix-qt-qttabbar-size.diff
+++ b/debian/patches/0238-fix-qt-qttabbar-size.diff
@@ -9,7 +9,7 @@ to a wrong size hint (visible if using a kstyle).
--- a/src/gui/widgets/qtabbar.cpp
+++ b/src/gui/widgets/qtabbar.cpp
-@@ -1084,7 +1084,7 @@
+@@ -1078,7 +1078,7 @@ QSize QTabBar::tabSizeHint(int index) co
QStyleOptionTabV2 opt;
initStyleOption(&opt, index);
opt.text = d->tabList.at(index).text;
diff --git a/debian/patches/0245-fix-randr-changes-detecting.diff b/debian/patches/0245-fix-randr-changes-detecting.diff
index a2f500b..5eaf5a9 100644
--- a/debian/patches/0245-fix-randr-changes-detecting.diff
+++ b/debian/patches/0245-fix-randr-changes-detecting.diff
@@ -9,7 +9,7 @@ Fix QDesktopWidget not detecting some changes in multiscreen setups
--- a/src/gui/kernel/qapplication_x11.cpp
+++ b/src/gui/kernel/qapplication_x11.cpp
-@@ -3000,11 +3000,11 @@
+@@ -2994,11 +2994,11 @@ int QApplication::x11ProcessEvent(XEvent
QSize oldSize(w->size());
w->data->crect.setWidth(DisplayWidth(X11->display, scr));
w->data->crect.setHeight(DisplayHeight(X11->display, scr));
diff --git a/debian/patches/0248-fix-qwidget-scroll-slowness.diff b/debian/patches/0248-fix-qwidget-scroll-slowness.diff
index 7169832..8e0353b 100644
--- a/debian/patches/0248-fix-qwidget-scroll-slowness.diff
+++ b/debian/patches/0248-fix-qwidget-scroll-slowness.diff
@@ -11,7 +11,7 @@ and non-blitting QWidget::scroll calls.
--- a/src/gui/painting/qbackingstore.cpp
+++ b/src/gui/painting/qbackingstore.cpp
-@@ -523,7 +523,8 @@
+@@ -517,7 +517,8 @@ void QWidgetPrivate::scrollRect(const QR
}
bool overlapped = false;
@@ -21,7 +21,7 @@ and non-blitting QWidget::scroll calls.
#if defined(Q_WS_QWS)
QWSWindowSurface *surface;
-@@ -558,13 +559,13 @@
+@@ -552,13 +553,13 @@ void QWidgetPrivate::scrollRect(const QR
#ifdef Q_WS_QWS
QWSWindowSurface *surface = static_cast<QWSWindowSurface*>(wbs->windowSurface);
const QRegion clip = surface->clipRegion().translated(-toplevelOffset)
diff --git a/debian/patches/0249-webkit-stale-frame-pointer.diff b/debian/patches/0249-webkit-stale-frame-pointer.diff
index 06747f3..c966d9a 100644
--- a/debian/patches/0249-webkit-stale-frame-pointer.diff
+++ b/debian/patches/0249-webkit-stale-frame-pointer.diff
@@ -14,7 +14,7 @@ Cascading Style Sheets (CSS) import statements.
--- a/src/3rdparty/webkit/WebCore/dom/Document.cpp
+++ b/src/3rdparty/webkit/WebCore/dom/Document.cpp
-@@ -291,9 +291,8 @@
+@@ -291,9 +291,8 @@ Document::Document(DOMImplementation* im
m_renderArena = 0;
m_axObjectCache = 0;
@@ -26,7 +26,7 @@ Cascading Style Sheets (CSS) import statements.
visuallyOrdered = false;
m_bParsing = false;
-@@ -1169,15 +1168,23 @@
+@@ -1169,15 +1168,23 @@ void Document::detach()
if (render)
render->destroy();
@@ -55,7 +55,7 @@ Cascading Style Sheets (CSS) import statements.
m_windowEventListeners.clear();
--- a/src/3rdparty/webkit/WebCore/dom/Document.h
+++ b/src/3rdparty/webkit/WebCore/dom/Document.h
-@@ -344,6 +344,8 @@
+@@ -344,6 +344,8 @@ public:
virtual void attach();
virtual void detach();
@@ -78,7 +78,7 @@ Cascading Style Sheets (CSS) import statements.
, m_doc(doc)
, m_requestCount(0)
, m_autoLoadImages(true)
-@@ -53,6 +52,11 @@
+@@ -53,6 +52,11 @@ DocLoader::DocLoader(Frame *frame, Docum
m_cache->addDocLoader(this);
}
@@ -90,7 +90,7 @@ Cascading Style Sheets (CSS) import statements.
DocLoader::~DocLoader()
{
HashMap<String, CachedResource*>::iterator end = m_docResources.end();
-@@ -146,7 +150,7 @@
+@@ -146,7 +150,7 @@ CachedResource* DocLoader::requestResour
}
}
@@ -99,7 +99,7 @@ Cascading Style Sheets (CSS) import statements.
setCachePolicy(CachePolicyReload);
checkForReload(fullURL);
-@@ -197,8 +201,8 @@
+@@ -197,8 +201,8 @@ void DocLoader::removeCachedResource(Cac
void DocLoader::setLoadInProgress(bool load)
{
m_loadInProgress = load;
@@ -110,7 +110,7 @@ Cascading Style Sheets (CSS) import statements.
}
void DocLoader::checkCacheObjectStatus(CachedResource* resource)
-@@ -217,7 +221,7 @@
+@@ -217,7 +221,7 @@ void DocLoader::checkCacheObjectStatus(C
}
// Notify the caller that we "loaded".
@@ -119,7 +119,7 @@ Cascading Style Sheets (CSS) import statements.
return;
ResourceRequest request(resource->url());
-@@ -226,9 +230,9 @@
+@@ -226,9 +230,9 @@ void DocLoader::checkCacheObjectStatus(C
if (resource->sendResourceLoadCallbacks()) {
// FIXME: If the WebKit client changes or cancels the request, WebCore does not respect this and continues the load.
@@ -133,7 +133,7 @@ Cascading Style Sheets (CSS) import statements.
void DocLoader::incrementRequestCount()
--- a/src/3rdparty/webkit/WebCore/loader/DocLoader.h
+++ b/src/3rdparty/webkit/WebCore/loader/DocLoader.h
-@@ -49,7 +49,7 @@
+@@ -49,7 +49,7 @@ friend class Cache;
friend class HTMLImageLoader;
public:
@@ -142,7 +142,7 @@ Cascading Style Sheets (CSS) import statements.
~DocLoader();
CachedImage* requestImage(const String& url);
-@@ -73,7 +73,7 @@
+@@ -73,7 +73,7 @@ public:
CachePolicy cachePolicy() const { return m_cachePolicy; }
void setCachePolicy(CachePolicy);
@@ -151,7 +151,7 @@ Cascading Style Sheets (CSS) import statements.
Document* doc() const { return m_doc; }
void removeCachedResource(CachedResource*) const;
-@@ -100,7 +100,6 @@
+@@ -100,7 +100,6 @@ private:
HashSet<String> m_reloadedURLs;
mutable HashMap<String, CachedResource*> m_docResources;
CachePolicy m_cachePolicy;
diff --git a/debian/patches/0254-fix-qgraphicsproxywidget-deletion-crash.diff b/debian/patches/0254-fix-qgraphicsproxywidget-deletion-crash.diff
index 34e0970..e9eefe9 100644
--- a/debian/patches/0254-fix-qgraphicsproxywidget-deletion-crash.diff
+++ b/debian/patches/0254-fix-qgraphicsproxywidget-deletion-crash.diff
@@ -9,7 +9,7 @@ Will be included in 4.4.4
--- a/src/gui/graphicsview/qgraphicsproxywidget.cpp
+++ b/src/gui/graphicsview/qgraphicsproxywidget.cpp
-@@ -521,9 +521,8 @@
+@@ -515,9 +515,8 @@ QGraphicsProxyWidget::~QGraphicsProxyWid
{
Q_D(QGraphicsProxyWidget);
if (d->widget) {
diff --git a/debian/patches/02_launch_assistant-qt4.diff b/debian/patches/02_launch_assistant-qt4.diff
index aeb1c33..f086432 100644
--- a/debian/patches/02_launch_assistant-qt4.diff
+++ b/debian/patches/02_launch_assistant-qt4.diff
@@ -1,6 +1,6 @@
--- a/demos/qtdemo/menumanager.cpp
+++ b/demos/qtdemo/menumanager.cpp
-@@ -291,7 +291,7 @@
+@@ -285,7 +285,7 @@ void MenuManager::showDocInAssistant(con
if (this->assistantProcess.state() != QProcess::Running){
QString app = QLibraryInfo::location(QLibraryInfo::BinariesPath) + QDir::separator();
#if !defined(Q_OS_MAC)
@@ -11,7 +11,7 @@
#endif
--- a/tools/designer/src/designer/assistantclient.cpp
+++ b/tools/designer/src/designer/assistantclient.cpp
-@@ -115,7 +115,7 @@
+@@ -109,7 +109,7 @@ QString AssistantClient::binary()
{
QString app = QLibraryInfo::location(QLibraryInfo::BinariesPath) + QDir::separator();
#if !defined(Q_OS_MAC)
diff --git a/debian/patches/03_launch_moc-qt4.diff b/debian/patches/03_launch_moc-qt4.diff
index b3a354a..e5bfcf4 100644
--- a/debian/patches/03_launch_moc-qt4.diff
+++ b/debian/patches/03_launch_moc-qt4.diff
@@ -4,7 +4,7 @@ Ensure the Qt4 version of moc is launched.
--- a/tools/qdbus/qdbuscpp2xml/qdbuscpp2xml.cpp
+++ b/tools/qdbus/qdbuscpp2xml/qdbuscpp2xml.cpp
-@@ -398,7 +398,7 @@
+@@ -392,7 +392,7 @@ int main(int argc, char **argv)
else {
// run moc on this file
QProcess proc;
diff --git a/debian/patches/04_launch_uic-qt4.diff b/debian/patches/04_launch_uic-qt4.diff
index 70e5595..eedb093 100644
--- a/debian/patches/04_launch_uic-qt4.diff
+++ b/debian/patches/04_launch_uic-qt4.diff
@@ -2,7 +2,7 @@ author: Fathi Boudra <fabo@debian.org>
--- a/tools/designer/src/lib/shared/qdesigner_utils.cpp
+++ b/tools/designer/src/lib/shared/qdesigner_utils.cpp
-@@ -488,7 +488,7 @@
+@@ -482,7 +482,7 @@ namespace qdesigner_internal
binary += QDir::separator();
switch (mode) {
case UIC_GenerateCode:
diff --git a/debian/patches/05_append_qt4_target.diff b/debian/patches/05_append_qt4_target.diff
index a02ffba..32dfeea 100644
--- a/debian/patches/05_append_qt4_target.diff
+++ b/debian/patches/05_append_qt4_target.diff
@@ -2,7 +2,7 @@ author: Fathi Boudra <fabo@debian.org>
--- a/config.tests/unix/compile.test
+++ b/config.tests/unix/compile.test
-@@ -53,7 +53,7 @@
+@@ -53,7 +53,7 @@ test -d "$OUTDIR/$TEST" || mkdir -p "$OU
cd "$OUTDIR/$TEST"
make distclean >/dev/null 2>&1
@@ -13,7 +13,7 @@ author: Fathi Boudra <fabo@debian.org>
make
--- a/config.tests/unix/doubleformat.test
+++ b/config.tests/unix/doubleformat.test
-@@ -10,7 +10,7 @@
+@@ -10,7 +10,7 @@ OUTDIR=$4
# build and run a test program
test -d "$OUTDIR/config.tests/unix/doubleformat" || mkdir -p "$OUTDIR/config.tests/unix/doubleformat"
@@ -24,7 +24,7 @@ author: Fathi Boudra <fabo@debian.org>
DOUBLEFORMAT="UNKNOWN"
--- a/config.tests/unix/endian.test
+++ b/config.tests/unix/endian.test
-@@ -10,7 +10,7 @@
+@@ -10,7 +10,7 @@ OUTDIR=$4
# build and run a test program
test -d "$OUTDIR/config.tests/unix/endian" || mkdir -p "$OUTDIR/config.tests/unix/endian"
@@ -35,7 +35,7 @@ author: Fathi Boudra <fabo@debian.org>
--- a/config.tests/unix/ptrsize.test
+++ b/config.tests/unix/ptrsize.test
-@@ -10,7 +10,7 @@
+@@ -10,7 +10,7 @@ OUTDIR=$4
# build and run a test program
test -d "$OUTDIR/config.tests/unix/ptrsize" || mkdir -p "$OUTDIR/config.tests/unix/ptrsize"
@@ -46,7 +46,7 @@ author: Fathi Boudra <fabo@debian.org>
if [ "$VERBOSE" = "yes" ]; then
--- a/config.tests/x11/notype.test
+++ b/config.tests/x11/notype.test
-@@ -27,7 +27,7 @@
+@@ -27,7 +27,7 @@ if [ $XPLATFORM = "solaris-g++" -o $XPLA
NOTYPE=yes
test -d "$OUTDIR/config.tests/x11/notype" || mkdir -p "$OUTDIR/config.tests/x11/notype"
@@ -57,7 +57,7 @@ author: Fathi Boudra <fabo@debian.org>
if [ "$VERBOSE" = "yes" ]; then
--- a/configure
+++ b/configure
-@@ -3829,7 +3829,7 @@
+@@ -3789,7 +3789,7 @@ END {
}
# build qmake
@@ -66,7 +66,7 @@ author: Fathi Boudra <fabo@debian.org>
echo "Creating qmake. Please wait..."
OLD_QCONFIG_H=
-@@ -6071,8 +6071,8 @@
+@@ -6031,8 +6031,8 @@ QMAKE_ABSOLUTE_SOURCE_ROOT = \$\$QT_SOUR
QMAKE_MOC_SRC = \$\$QT_BUILD_TREE/src/moc
#local paths that cannot be queried from the QT_INSTALL_* properties while building QTDIR
@@ -77,7 +77,7 @@ author: Fathi Boudra <fabo@debian.org>
QMAKE_UIC3 = \$\$QT_BUILD_TREE/bin/uic3
QMAKE_RCC = \$\$QT_BUILD_TREE/bin/rcc
QMAKE_QDBUSXML2CPP = \$\$QT_BUILD_TREE/bin/qdbusxml2cpp
-@@ -6373,11 +6373,11 @@
+@@ -6333,11 +6333,11 @@ EXEC=""
#-------------------------------------------------------------------------------
echo "Finding project files. Please wait..."
@@ -91,7 +91,7 @@ author: Fathi Boudra <fabo@debian.org>
fi
# .projects -> projects to process
-@@ -6550,7 +6550,7 @@
+@@ -6510,7 +6510,7 @@ for file in .projects .projects.3; do
echo " for $a\c"
fi
@@ -102,7 +102,7 @@ author: Fathi Boudra <fabo@debian.org>
if echo '\c' | grep '\c' >/dev/null; then
--- a/projects.pro
+++ b/projects.pro
-@@ -116,7 +116,7 @@
+@@ -116,7 +116,7 @@ qmake.path=$$[QT_INSTALL_BINS]
win32 {
qmake.files=$$QT_BUILD_TREE/bin/qmake.exe
} else {
@@ -113,7 +113,7 @@ author: Fathi Boudra <fabo@debian.org>
--- a/qmake/Makefile.unix
+++ b/qmake/Makefile.unix
-@@ -98,17 +98,17 @@
+@@ -98,17 +98,17 @@ CPPFLAGS = -I. -Igenerators -Igenerators
CXXFLAGS = @QMAKE_CXXFLAGS@ $(CPPFLAGS)
@@ -137,7 +137,7 @@ author: Fathi Boudra <fabo@debian.org>
makedepend -D__MAKEDEPEND__ $(CPPFLAGS) $(DEPEND_SRC)
--- a/tools/linguist/lrelease/lrelease.pro
+++ b/tools/linguist/lrelease/lrelease.pro
-@@ -29,7 +29,7 @@
+@@ -29,7 +29,7 @@ HEADERS += $$PROPARSERPATH/proitems.h \
SOURCES += $$PROPARSERPATH/proitems.cpp \
$$PROPARSERPATH/proreader.cpp
@@ -148,7 +148,7 @@ author: Fathi Boudra <fabo@debian.org>
--- a/tools/linguist/lupdate/lupdate.pro
+++ b/tools/linguist/lupdate/lupdate.pro
-@@ -42,7 +42,7 @@
+@@ -42,7 +42,7 @@ SOURCES += $$PROPARSERPATH/proitems.cpp
$$PROPARSERPATH/proreader.cpp
@@ -168,7 +168,7 @@ author: Fathi Boudra <fabo@debian.org>
CONFIG -= qt
--- a/src/tools/uic/uic.pro
+++ b/src/tools/uic/uic.pro
-@@ -9,7 +9,7 @@
+@@ -9,7 +9,7 @@ build_all:!build_pass {
unix:!contains(QT_CONFIG, zlib):LIBS += -lz
@@ -179,7 +179,7 @@ author: Fathi Boudra <fabo@debian.org>
DEFINES += QT_BOOTSTRAPPED QT_UIC QT_LITE_UNICODE QT_NO_DATASTREAM \
--- a/tools/assistant/tools/assistant/assistant.pro
+++ b/tools/assistant/tools/assistant/assistant.pro
-@@ -2,7 +2,7 @@
+@@ -2,7 +2,7 @@ include($$QT_SOURCE_TREE/tools/shared/fo
TEMPLATE = app
LANGUAGE = C++
@@ -190,7 +190,7 @@ author: Fathi Boudra <fabo@debian.org>
--- a/tools/designer/src/designer/designer.pro
+++ b/tools/designer/src/designer/designer.pro
-@@ -24,7 +24,7 @@
+@@ -24,7 +24,7 @@ contains(CONFIG, static) {
DEFINES += QT_DESIGNER_STATIC
}
@@ -201,7 +201,7 @@ author: Fathi Boudra <fabo@debian.org>
include($$QT_SOURCE_TREE/tools/shared/qttoolbardialog/qttoolbardialog.pri)
--- a/tools/linguist/linguist/linguist.pro
+++ b/tools/linguist/linguist/linguist.pro
-@@ -67,7 +67,7 @@
+@@ -67,7 +67,7 @@ HEADERS += batchtranslationdialog.h \
contains(QT_PRODUCT, OpenSource.*):DEFINES *= QT_OPENSOURCE
DEFINES += QT_KEYWORDS
DESTDIR = ../../../bin
@@ -212,7 +212,7 @@ author: Fathi Boudra <fabo@debian.org>
static:CONFIG -= global_init_link_order
--- a/tools/qtconfig/qtconfig.pro
+++ b/tools/qtconfig/qtconfig.pro
-@@ -19,7 +19,7 @@
+@@ -19,7 +19,7 @@ FORMS = mainwindowbase.ui palette
RESOURCES = qtconfig.qrc
PROJECTNAME = Qt Configuration
diff --git a/debian/patches/07_trust_dpkg-arch_over_uname-m.diff b/debian/patches/07_trust_dpkg-arch_over_uname-m.diff
index 4671553..48fa1ae 100644
--- a/debian/patches/07_trust_dpkg-arch_over_uname-m.diff
+++ b/debian/patches/07_trust_dpkg-arch_over_uname-m.diff
@@ -2,7 +2,7 @@ author: Sune Vuorela
Reported to trolltech as N180631 - and task 181882
--- a/configure
+++ b/configure
-@@ -93,7 +93,50 @@
+@@ -94,7 +94,50 @@ getQMakeConf()
#-------------------------------------------------------------------------------
# need that throughout the script
diff --git a/debian/patches/09_qmake_lflags_as-needed.diff b/debian/patches/09_qmake_lflags_as-needed.diff
index 5a6d11c..4a191bf 100644
--- a/debian/patches/09_qmake_lflags_as-needed.diff
+++ b/debian/patches/09_qmake_lflags_as-needed.diff
@@ -5,7 +5,7 @@ Bug reported to Trolltech.
--- a/configure
+++ b/configure
-@@ -503,6 +503,8 @@
+@@ -463,6 +463,8 @@ mkdir -p "$outpath/config.tests"
rm -f "$outpath/config.tests/.qmake.cache"
cp "$QMAKE_VARS_FILE" "$outpath/config.tests/.qmake.cache"
diff --git a/debian/patches/10_config_tests_fixes.diff b/debian/patches/10_config_tests_fixes.diff
index eafb8d3..acb0670 100644
--- a/debian/patches/10_config_tests_fixes.diff
+++ b/debian/patches/10_config_tests_fixes.diff
@@ -16,7 +16,7 @@
+LIBS += -liodbc
--- a/src/plugins/sqldrivers/odbc/odbc.pro
+++ b/src/plugins/sqldrivers/odbc/odbc.pro
-@@ -12,7 +12,7 @@
+@@ -12,7 +12,7 @@ mac {
unix {
!contains( LIBS, .*odbc.* ) {
@@ -27,7 +27,7 @@
--- a/src/sql/drivers/drivers.pri
+++ b/src/sql/drivers/drivers.pri
-@@ -48,7 +48,7 @@
+@@ -48,7 +48,7 @@ contains(sql-drivers, odbc) {
SOURCES += drivers/odbc/qsql_odbc.cpp
mac:!contains( LIBS, .*odbc.* ):LIBS *= -liodbc
@@ -36,7 +36,7 @@
win32 {
!win32-borland:LIBS *= -lodbc32
-@@ -93,7 +93,7 @@
+@@ -93,7 +93,7 @@ contains(sql-drivers, ibase) {
HEADERS += drivers/ibase/qsql_ibase.h
SOURCES += drivers/ibase/qsql_ibase.cpp
@@ -47,7 +47,7 @@
!win32-borland:LIBS *= -lgds32_ms
--- a/src/plugins/sqldrivers/ibase/ibase.pro
+++ b/src/plugins/sqldrivers/ibase/ibase.pro
-@@ -4,7 +4,7 @@
+@@ -4,7 +4,7 @@ HEADERS = ../../../sql/drivers/ibase/qs
SOURCES = main.cpp \
../../../sql/drivers/ibase/qsql_ibase.cpp
diff --git a/debian/patches/12_fix_qmake_pkgconfig.diff b/debian/patches/12_fix_qmake_pkgconfig.diff
index 33fffbb..1535dce 100644
--- a/debian/patches/12_fix_qmake_pkgconfig.diff
+++ b/debian/patches/12_fix_qmake_pkgconfig.diff
@@ -1,6 +1,6 @@
--- a/qmake/generators/unix/unixmake2.cpp
+++ b/qmake/generators/unix/unixmake2.cpp
-@@ -1440,6 +1440,8 @@
+@@ -1434,6 +1434,8 @@ UnixMakefileGenerator::writePkgConfigFil
pkgConfiglibName = "-l" + lname.left(lname.length()-Option::libtool_ext.length());
}
t << pkgConfiglibDir << " " << pkgConfiglibName << " ";
diff --git a/debian/patches/14_add_libraries_to_gui_build_where_actually_needed.diff b/debian/patches/14_add_libraries_to_gui_build_where_actually_needed.diff
index df85eed..aa988de 100644
--- a/debian/patches/14_add_libraries_to_gui_build_where_actually_needed.diff
+++ b/debian/patches/14_add_libraries_to_gui_build_where_actually_needed.diff
@@ -1,6 +1,6 @@
--- a/src/gui/kernel/kernel.pri
+++ b/src/gui/kernel/kernel.pri
-@@ -141,6 +141,8 @@
+@@ -141,6 +141,8 @@ embedded {
HEADERS += \
kernel/qeventdispatcher_glib_qws_p.h
QMAKE_CXXFLAGS += $$QT_CFLAGS_GLIB
@@ -11,7 +11,7 @@
--- a/src/gui/painting/painting.pri
+++ b/src/gui/painting/painting.pri
-@@ -63,6 +63,8 @@
+@@ -63,6 +63,8 @@ SOURCES += \
painting/qpathclipper.cpp \
painting/qmemrotate.cpp
diff --git a/debian/patches/15_fix_qmake_makefile_generation.diff b/debian/patches/15_fix_qmake_makefile_generation.diff
index 94307e4..17f810b 100644
--- a/debian/patches/15_fix_qmake_makefile_generation.diff
+++ b/debian/patches/15_fix_qmake_makefile_generation.diff
@@ -1,6 +1,6 @@
--- a/qmake/generators/makefile.cpp
+++ b/qmake/generators/makefile.cpp
-@@ -2334,7 +2334,7 @@
+@@ -2328,7 +2328,7 @@ MakefileGenerator::writeSubTargets(QText
QString mkfile = subtarget->makefile;
if(!in_directory.isEmpty())
diff --git a/debian/patches/16_hide_std_symbols_on_qtwebkit.diff b/debian/patches/16_hide_std_symbols_on_qtwebkit.diff
index 9cd4bba..3ecbd99 100644
--- a/debian/patches/16_hide_std_symbols_on_qtwebkit.diff
+++ b/debian/patches/16_hide_std_symbols_on_qtwebkit.diff
@@ -1,6 +1,6 @@
--- a/src/3rdparty/webkit/WebKit.pri
+++ b/src/3rdparty/webkit/WebKit.pri
-@@ -27,6 +27,7 @@
+@@ -27,6 +27,7 @@ CONFIG(release) {
BASE_DIR = $$PWD
qt-port:INCLUDEPATH += \
$$PWD/WebKit/qt/Api
diff --git a/debian/patches/17_add_postgresql_8.3_support.diff b/debian/patches/17_add_postgresql_8.3_support.diff
index adc03e0..7edc391 100644
--- a/debian/patches/17_add_postgresql_8.3_support.diff
+++ b/debian/patches/17_add_postgresql_8.3_support.diff
@@ -2,7 +2,7 @@ Enable PostgreSQL 8.3 support.
--- a/src/sql/drivers/psql/qsql_psql.cpp
+++ b/src/sql/drivers/psql/qsql_psql.cpp
-@@ -639,9 +639,12 @@
+@@ -633,9 +633,12 @@ static QPSQLDriver::Protocol getPSQLVers
serverVersion = QPSQLDriver::Version81;
break;
case 2:
@@ -16,7 +16,7 @@ Enable PostgreSQL 8.3 support.
}
break;
default:
-@@ -922,6 +925,7 @@
+@@ -916,6 +919,7 @@ QSqlIndex QPSQLDriver::primaryIndex(cons
case QPSQLDriver::Version8:
case QPSQLDriver::Version81:
case QPSQLDriver::Version82:
@@ -24,7 +24,7 @@ Enable PostgreSQL 8.3 support.
stmt = QLatin1String("SELECT pg_attribute.attname, pg_attribute.atttypid::int, "
"pg_class.relname "
"FROM pg_attribute, pg_class "
-@@ -995,6 +999,7 @@
+@@ -989,6 +993,7 @@ QSqlRecord QPSQLDriver::record(const QSt
case QPSQLDriver::Version8:
case QPSQLDriver::Version81:
case QPSQLDriver::Version82:
@@ -34,7 +34,7 @@ Enable PostgreSQL 8.3 support.
"pg_attrdef.adsrc "
--- a/src/sql/drivers/psql/qsql_psql.h
+++ b/src/sql/drivers/psql/qsql_psql.h
-@@ -106,7 +106,8 @@
+@@ -100,7 +100,8 @@ public:
Version74 = 10,
Version8 = 11,
Version81 = 12,
diff --git a/debian/patches/20_mips_atomic_ops.diff b/debian/patches/20_mips_atomic_ops.diff
index e4d7646..11b7fb2 100644
--- a/debian/patches/20_mips_atomic_ops.diff
+++ b/debian/patches/20_mips_atomic_ops.diff
@@ -17,7 +17,7 @@ Fix compilation for Linux MIPS-I code.
beqz $2,1b
nop
jr $31
-@@ -24,6 +26,7 @@
+@@ -24,6 +26,7 @@ q_atomic_test_and_set_int:
.ent q_atomic_test_and_set_acquire_int
.set mips2
q_atomic_test_and_set_acquire_int:
@@ -25,7 +25,7 @@ Fix compilation for Linux MIPS-I code.
1: ll $8,0($4)
bne $8,$5,2f
move $2,$6
-@@ -33,6 +36,7 @@
+@@ -33,6 +36,7 @@ q_atomic_test_and_set_acquire_int:
jr $31
nop
2: sync
@@ -33,7 +33,7 @@ Fix compilation for Linux MIPS-I code.
jr $31
move $2,$0
.set mips0
-@@ -42,11 +46,13 @@
+@@ -42,11 +46,13 @@ q_atomic_test_and_set_acquire_int:
.ent q_atomic_test_and_set_release_int
.set mips2
q_atomic_test_and_set_release_int:
@@ -47,7 +47,7 @@ Fix compilation for Linux MIPS-I code.
beqz $2,1b
nop
jr $31
-@@ -60,10 +66,12 @@
+@@ -60,10 +66,12 @@ q_atomic_test_and_set_release_int:
.ent q_atomic_test_and_set_ptr
.set mips2
q_atomic_test_and_set_ptr:
@@ -60,7 +60,7 @@ Fix compilation for Linux MIPS-I code.
beqz $2,1b
nop
jr $31
-@@ -77,6 +85,7 @@
+@@ -77,6 +85,7 @@ q_atomic_test_and_set_ptr:
.ent q_atomic_test_and_set_acquire_ptr
.set mips2
q_atomic_test_and_set_acquire_ptr:
@@ -68,7 +68,7 @@ Fix compilation for Linux MIPS-I code.
1: ll $8,0($4)
bne $8,$5,2f
move $2,$6
-@@ -86,6 +95,7 @@
+@@ -86,6 +95,7 @@ q_atomic_test_and_set_acquire_ptr:
jr $31
nop
2: sync
@@ -76,7 +76,7 @@ Fix compilation for Linux MIPS-I code.
jr $31
move $2,$0
.set mips0
-@@ -95,11 +105,13 @@
+@@ -95,11 +105,13 @@ q_atomic_test_and_set_acquire_ptr:
.ent q_atomic_test_and_set_release_ptr
.set mips2
q_atomic_test_and_set_release_ptr:
diff --git a/debian/patches/30_webkit_unaligned_access.diff b/debian/patches/30_webkit_unaligned_access.diff
index fdfdf4b..8bc9211 100644
--- a/debian/patches/30_webkit_unaligned_access.diff
+++ b/debian/patches/30_webkit_unaligned_access.diff
@@ -14,7 +14,7 @@ a real problem yet.
--- a/src/3rdparty/webkit/JavaScriptCore/wtf/FastMalloc.cpp
+++ b/src/3rdparty/webkit/JavaScriptCore/wtf/FastMalloc.cpp
-@@ -1267,14 +1267,14 @@
+@@ -1267,14 +1267,14 @@ static TCMalloc_Central_FreeListPadded c
// Page-level allocator
static SpinLock pageheap_lock = SPINLOCK_INITIALIZER;
@@ -33,7 +33,7 @@ a real problem yet.
--- a/src/3rdparty/webkit/JavaScriptCore/wtf/ListHashSet.h
+++ b/src/3rdparty/webkit/JavaScriptCore/wtf/ListHashSet.h
-@@ -122,7 +122,7 @@
+@@ -122,7 +122,7 @@ namespace WTF {
: m_freeList(pool())
, m_isDoneWithInitialFreeList(false)
{
@@ -42,7 +42,7 @@ a real problem yet.
}
Node* allocate()
-@@ -166,7 +166,7 @@
+@@ -166,7 +166,7 @@ namespace WTF {
}
private:
@@ -51,7 +51,7 @@ a real problem yet.
Node* pastPool() { return pool() + m_poolSize; }
bool inPool(Node* node)
-@@ -177,10 +177,7 @@
+@@ -177,10 +177,7 @@ namespace WTF {
Node* m_freeList;
bool m_isDoneWithInitialFreeList;
static const size_t m_poolSize = 256;
@@ -91,7 +91,7 @@ a real problem yet.
/* COMPILER(MSVC) */
--- a/src/3rdparty/webkit/JavaScriptCore/wtf/Vector.h
+++ b/src/3rdparty/webkit/JavaScriptCore/wtf/Vector.h
-@@ -355,8 +355,7 @@
+@@ -355,8 +355,7 @@ namespace WTF {
static const size_t m_inlineBufferSize = inlineCapacity * sizeof(T);
T* inlineBuffer() { return reinterpret_cast<T*>(&m_inlineBuffer); }
@@ -103,7 +103,7 @@ a real problem yet.
template<typename T, size_t inlineCapacity = 0>
--- a/src/3rdparty/webkit/WebCore/platform/AtomicString.cpp
+++ b/src/3rdparty/webkit/WebCore/platform/AtomicString.cpp
-@@ -104,7 +104,7 @@
+@@ -104,7 +104,7 @@ struct UCharBufferTranslator {
if (strLength != bufLength)
return false;
@@ -114,7 +114,7 @@ a real problem yet.
--- a/src/3rdparty/webkit/WebCore/platform/StringHash.h
+++ b/src/3rdparty/webkit/WebCore/platform/StringHash.h
-@@ -44,6 +44,15 @@
+@@ -44,6 +44,15 @@ namespace WTF {
if (aLength != bLength)
return false;
@@ -130,7 +130,7 @@ a real problem yet.
const uint32_t* aChars = reinterpret_cast<const uint32_t*>(a->characters());
const uint32_t* bChars = reinterpret_cast<const uint32_t*>(b->characters());
-@@ -56,6 +65,7 @@
+@@ -56,6 +65,7 @@ namespace WTF {
return false;
return true;
diff --git a/debian/patches/40_alpha_ice.diff b/debian/patches/40_alpha_ice.diff
index 524ae33..621bc8a 100644
--- a/debian/patches/40_alpha_ice.diff
+++ b/debian/patches/40_alpha_ice.diff
@@ -1,6 +1,6 @@
--- a/src/corelib/global/qlibraryinfo.cpp
+++ b/src/corelib/global/qlibraryinfo.cpp
-@@ -78,14 +78,7 @@
+@@ -72,14 +72,7 @@ class QLibraryInfoPrivate
{
public:
static QSettings *findConfiguration();
@@ -16,7 +16,7 @@
static QSettings *configuration()
{
#ifdef QT_NO_THREAD
-@@ -104,6 +97,15 @@
+@@ -98,6 +91,15 @@ public:
}
};
@@ -34,7 +34,7 @@
settings = QLibraryInfoPrivate::findConfiguration();
--- a/src/corelib/tools/qhash.h
+++ b/src/corelib/tools/qhash.h
-@@ -499,7 +499,7 @@
+@@ -493,7 +493,7 @@ Q_INLINE_TEMPLATE void QHash<Key, T>::de
}
template <class Key, class T>
diff --git a/debian/patches/41_disable_opengl_visibility.diff b/debian/patches/41_disable_opengl_visibility.diff
index f27b26e..6557b2d 100644
--- a/debian/patches/41_disable_opengl_visibility.diff
+++ b/debian/patches/41_disable_opengl_visibility.diff
@@ -2,7 +2,7 @@ temporary fix because of alpha, has to be dropped as soon as gcc's bug is fixed.
--- a/src/opengl/opengl.pro
+++ b/src/opengl/opengl.pro
-@@ -6,6 +6,7 @@
+@@ -6,6 +6,7 @@ DEFINES += QT_NO_USING_NAMESPACE
win32-msvc*|win32-icc:QMAKE_LFLAGS += /BASE:0x63000000
solaris-cc*:QMAKE_CXXFLAGS_RELEASE -= -O2
diff --git a/debian/patches/50_kfreebsd_build_fix.diff b/debian/patches/50_kfreebsd_build_fix.diff
index 6c890dd..03a9cb4 100644
--- a/debian/patches/50_kfreebsd_build_fix.diff
+++ b/debian/patches/50_kfreebsd_build_fix.diff
@@ -4,7 +4,7 @@ Fixes FTBFS on GNU/kFreeBSD by creating new Q_OS_GLIBC.
--- a/src/corelib/global/qglobal.h
+++ b/src/corelib/global/qglobal.h
-@@ -210,6 +210,12 @@
+@@ -204,6 +204,12 @@ namespace QT_NAMESPACE {}
# define Q_OS_RELIANT
#elif defined(__linux__) || defined(__linux)
# define Q_OS_LINUX
@@ -17,7 +17,7 @@ Fixes FTBFS on GNU/kFreeBSD by creating new Q_OS_GLIBC.
#elif defined(__FreeBSD__) || defined(__DragonFly__)
# define Q_OS_FREEBSD
# define Q_OS_BSD4
-@@ -230,8 +236,6 @@
+@@ -224,8 +230,6 @@ namespace QT_NAMESPACE {}
# define Q_OS_AIX
#elif defined(__Lynx__)
# define Q_OS_LYNX
@@ -28,7 +28,7 @@ Fixes FTBFS on GNU/kFreeBSD by creating new Q_OS_GLIBC.
#elif defined(__QNXNTO__)
--- a/src/corelib/plugin/qlibrary.cpp
+++ b/src/corelib/plugin/qlibrary.cpp
-@@ -292,13 +292,13 @@
+@@ -286,13 +286,13 @@ static bool qt_parse_pattern(const char
#if defined(Q_OS_UNIX) && !defined(Q_OS_MAC) && !defined(QT_NO_PLUGIN_CHECK)
@@ -46,7 +46,7 @@ Fixes FTBFS on GNU/kFreeBSD by creating new Q_OS_GLIBC.
const char *pattern, ulong p_len)
--- a/src/corelib/tools/qlocale.cpp
+++ b/src/corelib/tools/qlocale.cpp
-@@ -80,7 +80,7 @@
+@@ -74,7 +74,7 @@ QT_END_NAMESPACE
#include <qdebug.h>
#include <time.h>
@@ -55,7 +55,7 @@ Fixes FTBFS on GNU/kFreeBSD by creating new Q_OS_GLIBC.
# include <fenv.h>
#endif
-@@ -6259,7 +6259,7 @@
+@@ -6253,7 +6253,7 @@ Q_CORE_EXPORT char *qdtoa ( double d, in
_control87(MCW_EM, MCW_EM);
#endif
@@ -64,7 +64,7 @@ Fixes FTBFS on GNU/kFreeBSD by creating new Q_OS_GLIBC.
fenv_t envp;
feholdexcept(&envp);
#endif
-@@ -6275,7 +6275,7 @@
+@@ -6269,7 +6269,7 @@ Q_CORE_EXPORT char *qdtoa ( double d, in
#endif //_M_X64
#endif //Q_OS_WIN
diff --git a/debian/patches/71_hppa_unaligned_access_fix_458133.diff b/debian/patches/71_hppa_unaligned_access_fix_458133.diff
index 3d77bf8..4d22cbc 100644
--- a/debian/patches/71_hppa_unaligned_access_fix_458133.diff
+++ b/debian/patches/71_hppa_unaligned_access_fix_458133.diff
@@ -4,7 +4,7 @@ Fix unaligned access on hppa
--- a/src/3rdparty/sha1/sha1.cpp
+++ b/src/3rdparty/sha1/sha1.cpp
-@@ -151,10 +151,10 @@
+@@ -145,10 +145,10 @@ static inline void sha1ProcessChunk(Sha1
quint32 d = state->h3;
quint32 e = state->h4;
@@ -18,7 +18,7 @@ Fix unaligned access on hppa
for (int i = 0; i < 16; ++i)
chunk->words[i] = qFromBigEndian(chunk->words[i]);
-@@ -190,7 +190,7 @@
+@@ -184,7 +184,7 @@ static inline void sha1ProcessChunk(Sha1
// Wipe variables
#ifdef SHA1_WIPE_VARIABLES
a = b = c = d = e = 0;
diff --git a/debian/patches/80_hurd_max_path.diff b/debian/patches/80_hurd_max_path.diff
index bda822e..a6983cc 100644
--- a/debian/patches/80_hurd_max_path.diff
+++ b/debian/patches/80_hurd_max_path.diff
@@ -2,7 +2,7 @@ author: Brian Nelson <pyro@debian.org>
--- a/src/corelib/io/qfsfileengine_unix.cpp
+++ b/src/corelib/io/qfsfileengine_unix.cpp
-@@ -66,6 +66,10 @@
+@@ -60,6 +60,10 @@
QT_BEGIN_NAMESPACE
diff --git a/debian/patches/series b/debian/patches/series
index 9008aef..e1b1327 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -14,6 +14,12 @@
0248-fix-qwidget-scroll-slowness.diff
0249-webkit-stale-frame-pointer.diff
0254-fix-qgraphicsproxywidget-deletion-crash.diff
+0255-qtreeview-selection-columns-hidden.diff
+0256-fix-recursive-backingstore-sync-crash.diff
+0257-qurl-validate-speedup.diff
+0260-fix-qgraphicswidget-deletionclearFocus.diff
+0261-sync-before-reset-errorhandler.patch
+0262-fix-treeview-animation-crash.diff
# debian patches
01_qmake_for_debian.diff