summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorFathi Boudra <fabo@debian.org>2009-07-05 09:35:20 +0000
committerFathi Boudra <fabo@debian.org>2009-07-05 09:35:20 +0000
commit05e7c71c1ca6981fd5bd490d2e8a1bbe276e206d (patch)
tree87c4053bbe2fd544fb50476a9c645ab3962dddf7 /debian/rules
parent013e9abd370ac83786316cb5907cfcdf968ec092 (diff)
downloadqt4-x11-05e7c71c1ca6981fd5bd490d2e8a1bbe276e206d.tar.gz
call pkgkde-symbolshelper on binary-fixup target
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 59294eb..1e74236 100755
--- a/debian/rules
+++ b/debian/rules
@@ -282,6 +282,9 @@ binary-post-install/libqt4-dev::
install -D -p -m0644 doc/html/qt.tags \
$(DEB_DESTDIR)/usr/share/qt4/doc/html/qt.tags
+binary-fixup/libphonon4::
+ pkgkde-symbolshelper symbolfile -p libphonon4 -o debian/libphonon4.symbols
+
# Automatically install lintian overrides, stolen from debian-qt-kde.mk
$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
if test -e debian/$(cdbs_curpkg).lintian; then \
@@ -291,7 +294,6 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
# Generate shlibs local files
$(patsubst %,binary-fixup/%,$(DEB_ALL_PACKAGES)) :: binary-fixup/%: binary-strip/%
- pkgkde-symbolshelper symbolfile -p libphonon4 -o debian/libphonon4.symbols
if test -e debian/$(cdbs_curpkg)/DEBIAN/shlibs ; then \
sed 's/>=[^)]*/= $(CURRENTVERSION)/' debian/$(cdbs_curpkg)/DEBIAN/shlibs >> debian/shlibs.local ;\
fi