summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorFathi Boudra <fabo@debian.org>2009-06-30 10:34:53 +0000
committerFathi Boudra <fabo@debian.org>2009-06-30 10:34:53 +0000
commit7dd5b20365bcf832b8f8b846bf0067c20b4ce611 (patch)
treec99656ce2a0518100e1179395660831c0eb4eee7 /debian/rules
parent2cf480e68967b839453d7ca625e03630198be430 (diff)
downloadqt4-x11-7dd5b20365bcf832b8f8b846bf0067c20b4ce611.tar.gz
Add phonon-dbg package
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 8 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 80b93bf..b04db49 100755
--- a/debian/rules
+++ b/debian/rules
@@ -20,7 +20,7 @@ DEB_MAKE_BUILD_TARGET := sub-src
DEB_MAKE_INSTALL_TARGET := INSTALL_ROOT=$(DEB_DESTDIR) install
DEB_DH_INSTALL_SOURCEDIR := debian/tmp
-# Ensure the *.debug files aren't included in any package other than libqt4-dbg
+# Ensure the *.debug files aren't included in any package other than *-dbg
DEB_DH_INSTALL_ARGS := --exclude=.debug
DEB_MAKE_CLEAN_TARGET := confclean distclean
@@ -32,6 +32,9 @@ SHLIBSVERSION := 4.5.1
$(foreach libpkg,$(filter-out %-dev %-dbg,$(filter lib%,$(DEB_ARCH_PACKAGES))),$(eval DEB_DH_MAKESHLIBS_ARGS_$(libpkg) := -V'$(libpkg) (>= $(SHLIBSVERSION))'))
DEB_DH_STRIP_ARGS_libqt4-dbg := --exclude=.debug
+DEB_DH_STRIP_ARGS_libqt4-webkit-dbg := --exclude=.debug
+DEB_DH_STRIP_ARGS_libqt4-xmlpatterns-dbg := --exclude=.debug
+DEB_DH_STRIP_ARGS_phonon-dbg := --exclude=.debug
DEB_DH_SHLIBDEPS_ARGS_ALL := --exclude=.debug
@@ -258,6 +261,10 @@ binary-install/libqt4-xmlpatterns-dbg::
# Run dh_install without the default DEB_DH_INSTALL_ARGS to install the *.debug files
dh_install -plibqt4-xmlpatterns-dbg --sourcedir=$(DEB_DH_INSTALL_SOURCEDIR)
+binary-install/phonon-dbg::
+# Run dh_install without the default DEB_DH_INSTALL_ARGS to install the *.debug files
+ dh_install -pphonon-dbg --sourcedir=$(DEB_DH_INSTALL_SOURCEDIR)
+
binary-post-install/libqt4-dev::
install -D -p -m0644 doc/html/qt.tags \
$(DEB_DESTDIR)/usr/share/qt4/doc/html/qt.tags