summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorFathi Boudra <fabo@kde.org>2010-01-06 22:43:08 +0100
committerFathi Boudra <fabo@kde.org>2010-01-06 22:43:08 +0100
commitacbed1e3fc74d25a85507dfe9ad55403bbeea8e5 (patch)
tree26708be97c2ed1f306dbc30569aedcf85e6a28f2 /debian/rules
parent5aa9b9e681b8a61fe590a39f3cf19cb52db62b63 (diff)
downloadqt4-x11-acbed1e3fc74d25a85507dfe9ad55403bbeea8e5.tar.gz
Add sparc64 to linux64_architectures
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 4 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 5d3864d..5a2d51f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -30,14 +30,13 @@ ifeq ($(DEB_HOST_ARCH),arm)
extra_configure_opts += -DQT_QLOCALE_USES_FCVT
endif
-# TODO: add sparc 64
-64bits_architectures := amd64 ia64 kfreebsd-amd64
+linux64_architectures := amd64 ia64 kfreebsd-amd64 sparc64
ifeq ($(DEB_HOST_ARCH_OS),linux)
-ifeq ($(DEB_HOST_ARCH),$(findstring $(DEB_HOST_ARCH), $(64bits_architectures)))
+ ifeq ($(DEB_HOST_ARCH),$(findstring $(DEB_HOST_ARCH), $(linux64_architectures)))
platform_arg = linux-g++-64
-else
+ else
platform_arg = linux-g++
-endif
+ endif
else
platform_arg = glibc-g++
endif