summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorFathi Boudra <fabo@debian.org>2009-10-09 11:45:32 +0200
committerFathi Boudra <fabo@debian.org>2009-10-09 11:45:32 +0200
commitb7a18b288d840c09e67639509e0e369963f714ef (patch)
tree8fab612edd177e16b22d8d81699d4e9975c5b5f7 /debian/rules
parenta8c6f0f7ba2f0336f877198990678219afa6b4bd (diff)
downloadqt4-x11-b7a18b288d840c09e67639509e0e369963f714ef.tar.gz
* Add Debian patch: 12_add_nostrip_for_debug_packages
Set nostrip to generate debug packages as expected. * Cleanup debian/rules: remove deprecated .debug handling.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 0 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index 6c3ff68..b012250 100755
--- a/debian/rules
+++ b/debian/rules
@@ -230,10 +230,6 @@ override_dh_auto_install:
debian/desktop/qtconfig.png.uu
override_dh_install:
-# # Run dh_install without the exclude argument to install the *.debug files
-# $(foreach pkg,$(pkgs_dbg),dh_install -p$(pkg) --sourcedir=debian/tmp;)
-# # Ensure the *.debug files aren't included in any package other than *-dbg
-# dh_install --remaining-packages --sourcedir=debian/tmp --exclude=.debug
dh_install --list-missing --sourcedir=debian/tmp
override_dh_installdocs:
@@ -243,8 +239,6 @@ override_dh_installchangelogs:
dh_installchangelogs $(upstream_changes)
override_dh_strip:
-# $(foreach pkg,$(pkgs_dbg),dh_strip -p$(pkg) --exclude=.debug;)
-# dh_strip --remaining-packages
$(foreach pkg,$(pkgs_dbg),dh_strip -p$(pkg) --dbg-package=$(pkg)-dbg;)
dh_strip -plibphonon4 --dbg-package=phonon-dbg
dh_strip --remaining-packages --dbg-package=libqt4-dbg
@@ -261,7 +255,4 @@ override_dh_makeshlibs:
fi \
done
-#override_dh_shlibdeps:
-# dh_shlibdeps --exclude=.debug
-
.PHONY: override_dh_auto_test