summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorFathi Boudra <fabo@debian.org>2011-06-12 20:47:11 +0300
committerFathi Boudra <fabo@debian.org>2011-06-12 21:32:51 +0300
commit0a9622e564bfcdb24612e157c3d72022bbdf5606 (patch)
tree4b8a42181f26364948d8206cb3b15d83242496bc /debian
parent0ddf299d4b6d6dcfd96c62891c1a87897a7d3da6 (diff)
downloadqt4-x11-0a9622e564bfcdb24612e157c3d72022bbdf5606.tar.gz
use explicit variable: gles2_architectures
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules7
1 files changed, 4 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 82cfe17..266b904 100755
--- a/debian/rules
+++ b/debian/rules
@@ -38,11 +38,12 @@ ifeq ($(DEB_HOST_ARCH),armhf)
extra_configure_opts += -arch armv6
endif
-ifeq ($(DEB_HOST_ARCH),$(findstring $(DEB_HOST_ARCH), armel armhf))
+gles2_architectures := armel armhf
+ifeq ($(DEB_HOST_ARCH),$(findstring $(DEB_HOST_ARCH), $(gles2_architectures)))
extra_configure_opts += -opengl es2
else
- extra_configure_opts += -opengl desktop
- extra_configure_opts += -no-egl
+ extra_configure_opts += -opengl desktop \
+ -no-egl
endif
ifeq ($(DEB_HOST_ARCH_OS),linux)