summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorFathi Boudra <fabo@debian.org>2011-06-27 09:16:23 +0300
committerFathi Boudra <fabo@debian.org>2011-06-27 09:16:23 +0300
commit23b8b4c3fdaff55c2445ab6a20d7df82885c1e17 (patch)
tree4d0d1d81b091797a6335ee77352b7f5cfaa5e138 /debian
parentd92ec99cad8152ee20c296c9b5a391c8e075161d (diff)
downloadqt4-x11-23b8b4c3fdaff55c2445ab6a20d7df82885c1e17.tar.gz
Add support for vendor specifics in debian/rules.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules8
2 files changed, 13 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 71cdcdd..60ffced 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+qt4-x11 (4:4.7.3-5) UNRELEASED; urgency=low
+
+ * Add support for vendor specifics in debian/rules.
+
+ -- Fathi Boudra <fabo@debian.org> Mon, 27 Jun 2011 09:15:29 +0300
+
qt4-x11 (4:4.7.3-4) unstable; urgency=low
* Update Fix_fontconfig_usage_in_X11_font_database.patch to fix crashes in
diff --git a/debian/rules b/debian/rules
index 96111c8..f5cedb5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,6 +23,8 @@ shlibs_version := $(shell dpkg-parsechangelog | sed -n 's/^Version: //p' | cut -
# libqt4-phonon shlibs. Minimum libphonon4 version may need adjusting for new
# Qt upstream release
libqt4phonon_shlibs := libphonon4 (>= 4:4.6.0) | libqt4-phonon (= $(current_version))
+# Distribution vendor
+vendor := $(shell dpkg-vendor --query Vendor)
ifneq (,$(filter %-sql-ibase,$(shell dh_listpackages)))
extra_configure_opts += -plugin-sql-ibase
@@ -34,7 +36,11 @@ ifeq ($(DEB_HOST_ARCH),arm)
extra_configure_opts += -DQT_QLOCALE_USES_FCVT
endif
-ifeq ($(DEB_HOST_ARCH),armhf)
+armv6_architectures := armhf
+ifeq ($(vendor),Ubuntu)
+ armv6_architectures += armel
+endif
+ifeq ($(DEB_HOST_ARCH),$(findstring $(DEB_HOST_ARCH), $(armv6_architectures)))
extra_configure_opts += -arch armv6
endif