summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog9
-rw-r--r--debian/control2
-rw-r--r--debian/patches/0007_qsslsocket_improve_error_handling_CVE-2010-2621.patch7
-rwxr-xr-xdebian/rules2
4 files changed, 12 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index 80f5b9b..aa8a34e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+qt4-x11 (4:4.6.3-3) unstable; urgency=low
+
+ * Update debian/control: add missing Replaces libqt4-dev (<< 4:4.6.3-2) to
+ libqt4-dbus package.
+ * Update debian/rules: replace -dbus configure option by -dbus-linked to link
+ against dbus library instead of dlopen it. (Closes: #599224)
+
+ -- Fathi Boudra <fabo@debian.org> Wed, 06 Oct 2010 12:57:17 +0300
+
qt4-x11 (4:4.6.3-2) unstable; urgency=low
[ Fathi Boudra ]
diff --git a/debian/control b/debian/control
index a14d298..2740163 100644
--- a/debian/control
+++ b/debian/control
@@ -248,7 +248,7 @@ Description: Qt 4 XML patterns module
Package: libqt4-dbus
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
-Replaces: libqt4-core (<< 4.4.0~beta1-1)
+Replaces: libqt4-core (<< 4.4.0~beta1-1), libqt4-dev (<< 4:4.6.3-2)
Description: Qt 4 D-Bus module
Qt is a cross-platform C++ application framework. Qt's primary feature
is its rich set of widgets that provide standard GUI functionality.
diff --git a/debian/patches/0007_qsslsocket_improve_error_handling_CVE-2010-2621.patch b/debian/patches/0007_qsslsocket_improve_error_handling_CVE-2010-2621.patch
index d79311b..4ba0816 100644
--- a/debian/patches/0007_qsslsocket_improve_error_handling_CVE-2010-2621.patch
+++ b/debian/patches/0007_qsslsocket_improve_error_handling_CVE-2010-2621.patch
@@ -10,11 +10,9 @@ Task-number: QT-3567
src/network/ssl/qsslsocket_openssl.cpp | 14 +++++++++++++-
1 files changed, 13 insertions(+), 1 deletions(-)
-diff --git a/src/network/ssl/qsslsocket_openssl.cpp b/src/network/ssl/qsslsocket_openssl.cpp
-index c6e340f..46213ff 100644
--- a/src/network/ssl/qsslsocket_openssl.cpp
+++ b/src/network/ssl/qsslsocket_openssl.cpp
-@@ -965,8 +965,20 @@ void QSslSocketBackendPrivate::transmit()
+@@ -680,8 +680,20 @@ void QSslSocketBackendPrivate::transmit(
#endif
plainSocket->disconnectFromHost();
break;
@@ -36,6 +34,3 @@ index c6e340f..46213ff 100644
q->setErrorString(QSslSocket::tr("Error while reading: %1").arg(SSL_ERRORSTR()));
q->setSocketError(QAbstractSocket::UnknownSocketError);
emit q->error(QAbstractSocket::UnknownSocketError);
---
-1.6.1
-
diff --git a/debian/rules b/debian/rules
index e04e4fb..cab3281 100755
--- a/debian/rules
+++ b/debian/rules
@@ -113,7 +113,7 @@ endif
-system-libjpeg \
-no-rpath \
-optimized-qmake \
- -dbus \
+ -dbus-linked \
-no-separate-debug-info \
-verbose \
-gtkstyle \