summaryrefslogtreecommitdiff
path: root/debian/patches/05_append_qt4_target.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/05_append_qt4_target.diff')
-rw-r--r--debian/patches/05_append_qt4_target.diff36
1 files changed, 18 insertions, 18 deletions
diff --git a/debian/patches/05_append_qt4_target.diff b/debian/patches/05_append_qt4_target.diff
index a02ffba..32dfeea 100644
--- a/debian/patches/05_append_qt4_target.diff
+++ b/debian/patches/05_append_qt4_target.diff
@@ -2,7 +2,7 @@ author: Fathi Boudra <fabo@debian.org>
--- a/config.tests/unix/compile.test
+++ b/config.tests/unix/compile.test
-@@ -53,7 +53,7 @@
+@@ -53,7 +53,7 @@ test -d "$OUTDIR/$TEST" || mkdir -p "$OU
cd "$OUTDIR/$TEST"
make distclean >/dev/null 2>&1
@@ -13,7 +13,7 @@ author: Fathi Boudra <fabo@debian.org>
make
--- a/config.tests/unix/doubleformat.test
+++ b/config.tests/unix/doubleformat.test
-@@ -10,7 +10,7 @@
+@@ -10,7 +10,7 @@ OUTDIR=$4
# build and run a test program
test -d "$OUTDIR/config.tests/unix/doubleformat" || mkdir -p "$OUTDIR/config.tests/unix/doubleformat"
@@ -24,7 +24,7 @@ author: Fathi Boudra <fabo@debian.org>
DOUBLEFORMAT="UNKNOWN"
--- a/config.tests/unix/endian.test
+++ b/config.tests/unix/endian.test
-@@ -10,7 +10,7 @@
+@@ -10,7 +10,7 @@ OUTDIR=$4
# build and run a test program
test -d "$OUTDIR/config.tests/unix/endian" || mkdir -p "$OUTDIR/config.tests/unix/endian"
@@ -35,7 +35,7 @@ author: Fathi Boudra <fabo@debian.org>
--- a/config.tests/unix/ptrsize.test
+++ b/config.tests/unix/ptrsize.test
-@@ -10,7 +10,7 @@
+@@ -10,7 +10,7 @@ OUTDIR=$4
# build and run a test program
test -d "$OUTDIR/config.tests/unix/ptrsize" || mkdir -p "$OUTDIR/config.tests/unix/ptrsize"
@@ -46,7 +46,7 @@ author: Fathi Boudra <fabo@debian.org>
if [ "$VERBOSE" = "yes" ]; then
--- a/config.tests/x11/notype.test
+++ b/config.tests/x11/notype.test
-@@ -27,7 +27,7 @@
+@@ -27,7 +27,7 @@ if [ $XPLATFORM = "solaris-g++" -o $XPLA
NOTYPE=yes
test -d "$OUTDIR/config.tests/x11/notype" || mkdir -p "$OUTDIR/config.tests/x11/notype"
@@ -57,7 +57,7 @@ author: Fathi Boudra <fabo@debian.org>
if [ "$VERBOSE" = "yes" ]; then
--- a/configure
+++ b/configure
-@@ -3829,7 +3829,7 @@
+@@ -3789,7 +3789,7 @@ END {
}
# build qmake
@@ -66,7 +66,7 @@ author: Fathi Boudra <fabo@debian.org>
echo "Creating qmake. Please wait..."
OLD_QCONFIG_H=
-@@ -6071,8 +6071,8 @@
+@@ -6031,8 +6031,8 @@ QMAKE_ABSOLUTE_SOURCE_ROOT = \$\$QT_SOUR
QMAKE_MOC_SRC = \$\$QT_BUILD_TREE/src/moc
#local paths that cannot be queried from the QT_INSTALL_* properties while building QTDIR
@@ -77,7 +77,7 @@ author: Fathi Boudra <fabo@debian.org>
QMAKE_UIC3 = \$\$QT_BUILD_TREE/bin/uic3
QMAKE_RCC = \$\$QT_BUILD_TREE/bin/rcc
QMAKE_QDBUSXML2CPP = \$\$QT_BUILD_TREE/bin/qdbusxml2cpp
-@@ -6373,11 +6373,11 @@
+@@ -6333,11 +6333,11 @@ EXEC=""
#-------------------------------------------------------------------------------
echo "Finding project files. Please wait..."
@@ -91,7 +91,7 @@ author: Fathi Boudra <fabo@debian.org>
fi
# .projects -> projects to process
-@@ -6550,7 +6550,7 @@
+@@ -6510,7 +6510,7 @@ for file in .projects .projects.3; do
echo " for $a\c"
fi
@@ -102,7 +102,7 @@ author: Fathi Boudra <fabo@debian.org>
if echo '\c' | grep '\c' >/dev/null; then
--- a/projects.pro
+++ b/projects.pro
-@@ -116,7 +116,7 @@
+@@ -116,7 +116,7 @@ qmake.path=$$[QT_INSTALL_BINS]
win32 {
qmake.files=$$QT_BUILD_TREE/bin/qmake.exe
} else {
@@ -113,7 +113,7 @@ author: Fathi Boudra <fabo@debian.org>
--- a/qmake/Makefile.unix
+++ b/qmake/Makefile.unix
-@@ -98,17 +98,17 @@
+@@ -98,17 +98,17 @@ CPPFLAGS = -I. -Igenerators -Igenerators
CXXFLAGS = @QMAKE_CXXFLAGS@ $(CPPFLAGS)
@@ -137,7 +137,7 @@ author: Fathi Boudra <fabo@debian.org>
makedepend -D__MAKEDEPEND__ $(CPPFLAGS) $(DEPEND_SRC)
--- a/tools/linguist/lrelease/lrelease.pro
+++ b/tools/linguist/lrelease/lrelease.pro
-@@ -29,7 +29,7 @@
+@@ -29,7 +29,7 @@ HEADERS += $$PROPARSERPATH/proitems.h \
SOURCES += $$PROPARSERPATH/proitems.cpp \
$$PROPARSERPATH/proreader.cpp
@@ -148,7 +148,7 @@ author: Fathi Boudra <fabo@debian.org>
--- a/tools/linguist/lupdate/lupdate.pro
+++ b/tools/linguist/lupdate/lupdate.pro
-@@ -42,7 +42,7 @@
+@@ -42,7 +42,7 @@ SOURCES += $$PROPARSERPATH/proitems.cpp
$$PROPARSERPATH/proreader.cpp
@@ -168,7 +168,7 @@ author: Fathi Boudra <fabo@debian.org>
CONFIG -= qt
--- a/src/tools/uic/uic.pro
+++ b/src/tools/uic/uic.pro
-@@ -9,7 +9,7 @@
+@@ -9,7 +9,7 @@ build_all:!build_pass {
unix:!contains(QT_CONFIG, zlib):LIBS += -lz
@@ -179,7 +179,7 @@ author: Fathi Boudra <fabo@debian.org>
DEFINES += QT_BOOTSTRAPPED QT_UIC QT_LITE_UNICODE QT_NO_DATASTREAM \
--- a/tools/assistant/tools/assistant/assistant.pro
+++ b/tools/assistant/tools/assistant/assistant.pro
-@@ -2,7 +2,7 @@
+@@ -2,7 +2,7 @@ include($$QT_SOURCE_TREE/tools/shared/fo
TEMPLATE = app
LANGUAGE = C++
@@ -190,7 +190,7 @@ author: Fathi Boudra <fabo@debian.org>
--- a/tools/designer/src/designer/designer.pro
+++ b/tools/designer/src/designer/designer.pro
-@@ -24,7 +24,7 @@
+@@ -24,7 +24,7 @@ contains(CONFIG, static) {
DEFINES += QT_DESIGNER_STATIC
}
@@ -201,7 +201,7 @@ author: Fathi Boudra <fabo@debian.org>
include($$QT_SOURCE_TREE/tools/shared/qttoolbardialog/qttoolbardialog.pri)
--- a/tools/linguist/linguist/linguist.pro
+++ b/tools/linguist/linguist/linguist.pro
-@@ -67,7 +67,7 @@
+@@ -67,7 +67,7 @@ HEADERS += batchtranslationdialog.h \
contains(QT_PRODUCT, OpenSource.*):DEFINES *= QT_OPENSOURCE
DEFINES += QT_KEYWORDS
DESTDIR = ../../../bin
@@ -212,7 +212,7 @@ author: Fathi Boudra <fabo@debian.org>
static:CONFIG -= global_init_link_order
--- a/tools/qtconfig/qtconfig.pro
+++ b/tools/qtconfig/qtconfig.pro
-@@ -19,7 +19,7 @@
+@@ -19,7 +19,7 @@ FORMS = mainwindowbase.ui palette
RESOURCES = qtconfig.qrc
PROJECTNAME = Qt Configuration