summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com>2014-03-05 16:01:15 -0300
committerLisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com>2014-03-05 16:01:15 -0300
commit3bc3175055598389ae5ea44ef8d45caedfd82ad2 (patch)
tree0c34d48538bcd43ce49d809cddde6407a6a71517
parentb2913ca81d6c7bf9b09bc80b68f466a1a2c0a325 (diff)
downloadqt5webkit-3bc3175055598389ae5ea44ef8d45caedfd82ad2.tar.gz
Create reduce_memory_usage.patch forcing ld to not cache the symbol tables.
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/reduce_memory_usage.patch19
-rw-r--r--debian/patches/series1
3 files changed, 23 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 43e24a2..bba810d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,9 @@ qtwebkit-opensource-src (5.2.1+dfsg-4) UNRELEASED; urgency=medium
[ Lisandro Damián Nicanor Pérez Meyer ]
* Backport dont_pollute_pri_and_pc_with_private_deps.patch to avoid
propagating wrong linker flags (Closes: #711307).
+ * Create reduce_memory_usage.patch forcing ld to not cache the symbol tables
+ of input files in memory to avoid memory exhaustion during the linking
+ phase.
-- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Wed, 05 Mar 2014 12:13:03 -0300
diff --git a/debian/patches/reduce_memory_usage.patch b/debian/patches/reduce_memory_usage.patch
new file mode 100644
index 0000000..0a30ef9
--- /dev/null
+++ b/debian/patches/reduce_memory_usage.patch
@@ -0,0 +1,19 @@
+Description: force ld to not cache symbols tables.
+ This patch, wich should be considered Debian-only (in other words, it should
+ not be pushed upstream), forces ld to not cache the symbol tables of input
+ files in memory to avoid memory exhaustion during the linking phase.
+ .
+ This might make linking slower but reducing the overall memory comsuption.
+Author: Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
+Forwarded: not-needed
+Last-Update: 2014-03-05
+
+--- a/Tools/qmake/mkspecs/features/unix/default_post.prf
++++ b/Tools/qmake/mkspecs/features/unix/default_post.prf
+@@ -66,3 +66,6 @@ CONFIG(debug, debug|release)|force_debug
+ }
+
+ load(default_post)
++
++# Make ld not cache the symbol tables of input files in memory to avoid memory exhaustion during the linking phase.
++QMAKE_LFLAGS += -Wl,--no-keep-memory
diff --git a/debian/patches/series b/debian/patches/series
index 02d64c6..1ee8b12 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -3,6 +3,7 @@ fix_ftbfs_in_archs_without_jit_support.patch
dont_pollute_pri_and_pc_with_private_deps.patch
# debian patches
+reduce_memory_usage.patch
05_sparc_unaligned_access.diff
no_gc_sections.diff
hurd.diff