summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 6 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index 2d9b2e6..58a1b61 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,14 +7,14 @@ DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
-gstabs_architectures := amd64 powerpc ppc64el s390x
-
export DEB_CPPFLAGS_MAINT_APPEND = -DNDEBUG
-export DEB_CXXFLAGS_MAINT_STRIP = -g
-# Enable gstabs debugging symbols only on gstabs_architectures
-ifneq (,$(filter $(DEB_HOST_ARCH_CPU),$(gstabs_architectures)))
- export DEB_CXXFLAGS_MAINT_APPEND = -gstabs
+# The debug packages produced by webkit are huge and cause problems in
+# most buildds, so use -g1 in all architectures except the ones that
+# are known to work fine
+ifeq (,$(filter $(DEB_HOST_ARCH_CPU),ppc64 ppc64el s390x))
+ export DEB_CXXFLAGS_MAINT_STRIP = -g
+ export DEB_CXXFLAGS_MAINT_APPEND = -g1
endif
# JIT is only supported on x86 / armhf / aarch64 / mips32