summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com>2013-05-13 17:55:27 -0300
committerLisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com>2013-05-13 17:55:27 -0300
commit166d960aec19cc717f2f2230e2a0776c4b690d26 (patch)
treeca2d0fb0552175982c89af7b58b509a9be07d466
parente2ec6928056fbe3260a8d93f1c18881ed4e30907 (diff)
downloadqtbase-166d960aec19cc717f2f2230e2a0776c4b690d26.tar.gz
Add qt5-triplet.conf and arch-qualified qt5.conf.
See qtchooser's README.Debian for more details.
-rw-r--r--debian/changelog5
-rw-r--r--debian/libqt5core5.install3
-rw-r--r--debian/qt5-default.install2
-rwxr-xr-xdebian/rules10
4 files changed, 12 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index 7452cb0..39ed250 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,9 +9,8 @@ qtbase-opensource-src (5.0.2+dfsg1-4) UNRELEASED; urgency=low
* libqt5sql5-sqlite listed as first in recommends, being the lightest.
[ Lisandro Damián Nicanor Pérez Meyer ]
- * Move qt5.conf from qtbase5-dev to libqt5core5. It will not be strange to find
- apps explicitely calling the qt5 config.
- - Add Breaks+Replaces to libqt5core5 against qtbase5-dev << 5.0.2+dfsg1-4~.
+ * Add qt5-triplet.conf and arch-qualified qt5.conf. See qtchooser's
+ README.Debian for more details.
* Fix typo in qtbase5-private-dev's Breaks+Replaces.
-- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Fri, 26 Apr 2013 13:21:51 +0200
diff --git a/debian/libqt5core5.install b/debian/libqt5core5.install
index 4358b7f..36d4b10 100644
--- a/debian/libqt5core5.install
+++ b/debian/libqt5core5.install
@@ -1,2 +1,3 @@
usr/lib/*/libQt5Core.so.*
-usr/share/qtchooser/qt5.conf
+usr/lib/*/qtchooser/qt5.conf
+usr/share/qtchooser/qt5-*.conf
diff --git a/debian/qt5-default.install b/debian/qt5-default.install
index 85422d0..6b53775 100644
--- a/debian/qt5-default.install
+++ b/debian/qt5-default.install
@@ -1 +1 @@
-usr/share/qtchooser/default.conf
+usr/lib/*/qtchooser/default.conf
diff --git a/debian/rules b/debian/rules
index af01227..d79dd9d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -219,9 +219,13 @@ override_dh_auto_install:
# Add a configuration for qtchooser
mkdir -p $(CURDIR)/debian/tmp/usr/share/qtchooser
- echo "/usr/lib/$(DEB_HOST_MULTIARCH)/qt5/bin" > $(CURDIR)/debian/tmp/usr/share/qtchooser/qt5.conf
- echo "/usr/lib/$(DEB_HOST_MULTIARCH)" >> $(CURDIR)/debian/tmp/usr/share/qtchooser/qt5.conf
- ln -s /usr/share/qtchooser/qt5.conf $(CURDIR)/debian/tmp/usr/share/qtchooser/default.conf
+ echo "/usr/lib/$(DEB_HOST_MULTIARCH)/qt5/bin" > $(CURDIR)/debian/tmp/usr/share/qtchooser/qt5-$(DEB_HOST_MULTIARCH).conf
+ echo "/usr/lib/$(DEB_HOST_MULTIARCH)" >> $(CURDIR)/debian/tmp/usr/share/qtchooser/qt5-$(DEB_HOST_MULTIARCH).conf
+
+ # Ship qt5.conf for this arch, and a default.conf.
+ mkdir -p $(CURDIR)/debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/qtchooser
+ ln -s /usr/share/qtchooser/qt5-$(DEB_HOST_MULTIARCH).conf $(CURDIR)/debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/qtchooser/qt5.conf
+ ln -s /usr/share/qtchooser/qt5-$(DEB_HOST_MULTIARCH).conf $(CURDIR)/debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/qtchooser/default.conf
# Remove leftover directories
find $(CURDIR)/debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/qt5 -depth -type d \( -false \