summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com>2013-08-08 16:48:00 -0300
committerLisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com>2013-08-08 16:48:00 -0300
commitf709e02c3723f1747652209533836cda33140ca2 (patch)
tree6df36f73600f05a8166a842dea59cf142ee7074e
parent18dfe33e61f7439fd96c6bc86b85cf407fa1425e (diff)
downloadqtbase-f709e02c3723f1747652209533836cda33140ca2.tar.gz
Add Dont_check_for_the_existence_of_priv_inc_dirs.patch
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/Dont_check_for_the_existence_of_priv_inc_dirs.patch64
-rw-r--r--debian/patches/series1
3 files changed, 68 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 51011e5..0b2598c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,9 @@ qtbase-opensource-src (5.1.0+dfsg-2) UNRELEASED; urgency=low
* Add libxkbcommon-dev as build dependency, thus avoiding using the bundled
lib.
* Minor improvement of mark_private_symbols.sh.
+ * Add Dont_check_for_the_existence_of_priv_inc_dirs.patch that avoids making
+ our users install private headers in order to compile with CMake
+ (Closes: #718348).
-- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Tue, 09 Jul 2013 20:24:35 -0300
diff --git a/debian/patches/Dont_check_for_the_existence_of_priv_inc_dirs.patch b/debian/patches/Dont_check_for_the_existence_of_priv_inc_dirs.patch
new file mode 100644
index 0000000..d751043
--- /dev/null
+++ b/debian/patches/Dont_check_for_the_existence_of_priv_inc_dirs.patch
@@ -0,0 +1,64 @@
+From ed90bd61f77549e3e896388682596017441a1172 Mon Sep 17 00:00:00 2001
+From: Stephen Kelly <stephen.kelly@kdab.com>
+Date: Thu, 18 Jul 2013 11:11:31 +0200
+Subject: [PATCH] Don't check for the existence of private include directories.
+
+Some packagers don't want to install the private headers.
+
+Check the existence of private headers only if the 'Private' component
+is specified when finding the package.
+
+Task-number: QTBUG-32466
+Change-Id: I1fdbfb25e8ce485cd051564b937f766b2733741a
+---
+ mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in | 17 ++++++++++++-----
+ tests/auto/cmake/test_private_includes/CMakeLists.txt | 2 +-
+ 2 files changed, 13 insertions(+), 6 deletions(-)
+
+diff --git a/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in b/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in
+index 3862334..bcff316 100644
+--- a/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in
++++ b/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in
+@@ -119,14 +119,21 @@ if (NOT TARGET Qt5::$${CMAKE_MODULE_NAME})
+ set(Qt5$${CMAKE_MODULE_NAME}_PRIVATE_INCLUDE_DIRS)
+ !!ENDIF
+
+- foreach(_dir ${_Qt5$${CMAKE_MODULE_NAME}_OWN_INCLUDE_DIRS}
+-!!IF isEmpty(CMAKE_BUILD_IS_FRAMEWORK)
+- ${Qt5$${CMAKE_MODULE_NAME}_PRIVATE_INCLUDE_DIRS}
+-!!ENDIF
+- )
++ foreach(_dir ${_Qt5$${CMAKE_MODULE_NAME}_OWN_INCLUDE_DIRS})
+ _qt5_$${CMAKE_MODULE_NAME}_check_file_exists(${_dir})
+ endforeach()
+
++!!IF isEmpty(CMAKE_BUILD_IS_FRAMEWORK)
++ # Only check existence of private includes if the Private component is
++ # specified.
++ list(FIND Qt5$${CMAKE_MODULE_NAME}_FIND_COMPONENTS Private _check_private)
++ if (NOT _check_private STREQUAL -1)
++ foreach(_dir ${Qt5$${CMAKE_MODULE_NAME}_PRIVATE_INCLUDE_DIRS})
++ _qt5_$${CMAKE_MODULE_NAME}_check_file_exists(${_dir})
++ endforeach()
++ endif()
++!!ENDIF
++
+ set(Qt5$${CMAKE_MODULE_NAME}_INCLUDE_DIRS ${_Qt5$${CMAKE_MODULE_NAME}_OWN_INCLUDE_DIRS})
+
+ set(Qt5$${CMAKE_MODULE_NAME}_DEFINITIONS -D$${MODULE_DEFINE})
+diff --git a/tests/auto/cmake/test_private_includes/CMakeLists.txt b/tests/auto/cmake/test_private_includes/CMakeLists.txt
+index f283bc2..9095836 100644
+--- a/tests/auto/cmake/test_private_includes/CMakeLists.txt
++++ b/tests/auto/cmake/test_private_includes/CMakeLists.txt
+@@ -3,7 +3,7 @@ cmake_minimum_required(VERSION 2.8)
+
+ project(test_private_includes)
+
+-find_package(Qt5Gui REQUIRED)
++find_package(Qt5Gui REQUIRED Private)
+
+ include_directories(
+ ${Qt5Gui_INCLUDE_DIRS}
+--
+1.8.4.rc1
+
diff --git a/debian/patches/series b/debian/patches/series
index dff76ac..c347bd7 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
deppath_gnu.diff
+Dont_check_for_the_existence_of_priv_inc_dirs.patch
# Debian specific.