summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Shachnev <mitya57@gmail.com>2014-12-20 12:56:58 +0300
committerDmitry Shachnev <mitya57@gmail.com>2014-12-20 12:56:58 +0300
commitee4c5ba36cb1f5bd043993c92bcb19814229a06b (patch)
tree907c8ae79f528dae23d2f87db44d9ffb53b56ce4
parent7489681da57240488d53cdc0297e21cf4a81680a (diff)
downloadqtbase-ee4c5ba36cb1f5bd043993c92bcb19814229a06b.tar.gz
Really fix FTBFS on kfreebsd.
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/bsd_statfs.diff11
2 files changed, 11 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index a2527ad..493eb15 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,8 @@
qtbase-opensource-src (5.4.0+dfsg-4) UNRELEASED; urgency=medium
+ [ Dmitry Shachnev ]
+ * debian/patches/bsd_statfs.diff: Third attempt to fix the build
+ failure on kfreebsd.
-- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Sat, 20 Dec 2014 12:45:21 +0300
diff --git a/debian/patches/bsd_statfs.diff b/debian/patches/bsd_statfs.diff
index 9f80617..9e1d8da 100644
--- a/debian/patches/bsd_statfs.diff
+++ b/debian/patches/bsd_statfs.diff
@@ -1,11 +1,16 @@
Description: fix qstorageinfo build failure on kFreeBSD and Hurd
Author: Dmitry Shachnev <mitya57@debian.org>
Forwarded: not-yet
-Last-Update: 2014-12-19
+Last-Update: 2014-12-20
--- a/src/corelib/io/qstorageinfo_unix.cpp
+++ b/src/corelib/io/qstorageinfo_unix.cpp
-@@ -56,13 +56,13 @@
+@@ -52,17 +52,18 @@
+
+ #if defined(Q_OS_BSD4)
+ # include <sys/mount.h>
++# include <sys/statvfs.h>
+ #elif defined(Q_OS_ANDROID)
# include <sys/mount.h>
# include <sys/vfs.h>
# include <mntent.h>
@@ -21,7 +26,7 @@ Last-Update: 2014-12-19
#endif
#if defined(Q_OS_BSD4)
-@@ -118,7 +118,7 @@
+@@ -118,7 +119,7 @@
inline QByteArray device() const;
private:
#if defined(Q_OS_BSD4)