summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPino Toscano <pino@debian.org>2014-12-27 19:41:54 +0100
committerPino Toscano <pino@debian.org>2014-12-27 19:41:54 +0100
commit2ba105bdee2d81130d6b6f89f6f46f5191f9553d (patch)
treeca7eec507a9ffb66e8627c76fbbb264a87c79e83
parenta9969bb0a6f827307f7f00cba984f00da6d4bb0f (diff)
downloadqtscript-2ba105bdee2d81130d6b6f89f6f46f5191f9553d.tar.gz
fix build on GNU/kFreeBSD
make sure that pthread_np.h is not used
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/kfreebsd.diff18
-rw-r--r--debian/patches/series1
3 files changed, 22 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 77f15cf..eb25a28 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,8 @@
qtscript-opensource-src (5.4.0+dfsg-2) UNRELEASED; urgency=medium
+ [ Pino Toscano ]
+ * Fix build on GNU/kFreeBSD, making sure that pthread_np.h is not used;
+ patch kfreebsd.diff.
-- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Sat, 27 Dec 2014 19:39:55 +0100
diff --git a/debian/patches/kfreebsd.diff b/debian/patches/kfreebsd.diff
new file mode 100644
index 0000000..d7dc8a7
--- /dev/null
+++ b/debian/patches/kfreebsd.diff
@@ -0,0 +1,18 @@
+Author: Pino Toscano <toscano.pino@tiscali.it>
+Description: Disable pthread_np.h on BSD w/ GNU libc
+ pthread_np.h exists on BSD userlands only, so do not enable it on BSD
+ kernels with GNU libc/userland (e.g. GNU/kFreeBSD).
+Last-Update: 2014-12-27
+Forwarded: https://codereview.qt-project.org/#/c/102659/
+
+--- a/src/3rdparty/javascriptcore/JavaScriptCore/config.h
++++ b/src/3rdparty/javascriptcore/JavaScriptCore/config.h
+@@ -53,7 +53,7 @@
+
+ #endif
+
+-#if OS(FREEBSD) || OS(OPENBSD)
++#if (OS(FREEBSD) || OS(OPENBSD)) && !defined(__GLIBC__)
+ #define HAVE_PTHREAD_NP_H 1
+ #endif
+
diff --git a/debian/patches/series b/debian/patches/series
index 021a4c5..357ecb2 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
enable-make-check.patch
disable_v8_sunspider_tests.patch
s390x_jscore.diff
+kfreebsd.diff