summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2015-03-01 20:33:52 +0300
committerIgor Pashev <pashev.igor@gmail.com>2015-03-01 20:33:52 +0300
commit7fc8ab01976ca829d94f3750751473ee4626a508 (patch)
treea6807d8087d113a0778123bd5fc466529c2097fb /debian/rules
parentddad7732266f43b3033382b75f7e04a40a21d5ef (diff)
parent17337d1a9ca0412015c470503b3c961a122a82c6 (diff)
downloadqtscript-7fc8ab01976ca829d94f3750751473ee4626a508.tar.gz
Merge git://anonscm.debian.org/pkg-kde/qt/qtscript
Conflicts: debian/changelog
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 6 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 9df8774..cb0068b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,7 +16,7 @@ override_dh_auto_configure:
qmake QT_BUILD_PARTS+=tests
override_dh_auto_build-indep:
- dh_auto_build -Smakefile -- docs
+ dh_auto_build -Smakefile -- html_docs
override_dh_auto_install-arch:
dh_auto_install
@@ -25,13 +25,15 @@ override_dh_auto_install-arch:
rm -f debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/*.la
override_dh_auto_install-indep:
- make INSTALL_ROOT=$(CURDIR)/debian/tmp install_docs
+ make INSTALL_ROOT=$(CURDIR)/debian/tmp install_html_docs
override_dh_install:
dh_install --fail-missing -X.la
-override_dh_builddeb:
- dh_builddeb -- -Zxz
+override_dh_makeshlibs:
+ dh_makeshlibs
+ # Check for private symbols not marked as such. Be verbose.
+ DEBUG=1 debian/mark_private_symbols.sh
prune-nonfree:
rm -rfv tests/benchmarks/script/sunspider/*