summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Habouzit <madcoder@debian.org>2007-08-18 08:29:00 +0000
committerPierre Habouzit <madcoder@debian.org>2007-08-18 08:29:00 +0000
commit71ad7b8f6184e62dd62534340452e315a8919fa3 (patch)
tree72f7afa0c8703963c85adfc7ae1720571296489b
parentc646245d49ddf916896fe7087e308f551355dd04 (diff)
downloadlighttpd-debian/1.4.16-4.tar.gz
* debian/control: Drop conflict with gamin as it appears it was not thedebian/1.4.16-4
issue. (Closes: #438058). * src/mod_mysql_vhost.c: Enable mysql auto-connect mode, as it's not default in mysql 5.x anymore. (Closes: #428677).
-rw-r--r--debian/changelog9
-rw-r--r--debian/patches/00list1
-rwxr-xr-xdebian/patches/05_mysql_autoreconnect.dpatch20
3 files changed, 30 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index ed78fb7..6e92513 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+lighttpd (1.4.16-4) unstable; urgency=low
+
+ * debian/control: Drop conflict with gamin as it appears it was not the
+ issue. (Closes: #438058).
+ * src/mod_mysql_vhost.c: Enable mysql auto-connect mode, as it's not default
+ in mysql 5.x anymore. (Closes: #428677).
+
+ -- Pierre Habouzit <madcoder@debian.org> Sat, 18 Aug 2007 10:27:22 +0200
+
lighttpd (1.4.16-3) unstable; urgency=high
* Urgency set to high due to RC bug fix.
diff --git a/debian/patches/00list b/debian/patches/00list
index c61f84e..7e79265 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -1,3 +1,4 @@
02_fastcgi_detach.dpatch
03_ldap_leak_bugfix.dpatch
04_ldap_build_filter_fix.dpatch
+05_mysql_autoreconnect.dpatch
diff --git a/debian/patches/05_mysql_autoreconnect.dpatch b/debian/patches/05_mysql_autoreconnect.dpatch
new file mode 100755
index 0000000..64c92ce
--- /dev/null
+++ b/debian/patches/05_mysql_autoreconnect.dpatch
@@ -0,0 +1,20 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 04_mysql_autoreconnect.dpatch by Pierre Habouzit <madcoder@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: No description.
+
+@DPATCH@
+diff -urNad pkg~/src/mod_mysql_vhost.c pkg/src/mod_mysql_vhost.c
+--- pkg~/src/mod_mysql_vhost.c 2007-07-20 11:43:29.000000000 +0200
++++ pkg/src/mod_mysql_vhost.c 2007-08-18 10:26:36.000000000 +0200
+@@ -253,6 +253,9 @@
+ return HANDLER_ERROR;
+ }
+ #define FOO(x) (s->x->used ? s->x->ptr : NULL)
++ /* http://trac.lighttpd.net/trac/ticket/518 */
++ my_bool reconnect = 1;
++ mysql_options(s->mysql, MYSQL_OPT_RECONNECT, &reconnect);
+
+ if (!mysql_real_connect(s->mysql, FOO(hostname), FOO(myuser), FOO(mypass),
+ FOO(mydb), s->port, FOO(mysock), 0)) {