summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Habouzit <madcoder@debian.org>2008-04-13 11:11:17 +0000
committerPierre Habouzit <madcoder@debian.org>2008-04-13 11:11:17 +0000
commit346c7b00ba20b6928ea4e256d95ec0b96f130b8c (patch)
treec4f2923d875a09c9759d6a343cc10726c6bc09cc
parent01e100d7ed4619e49d11fd31746b8b3c2e97732d (diff)
downloadlighttpd-346c7b00ba20b6928ea4e256d95ec0b96f130b8c.tar.gz
closes 473510
-rw-r--r--debian/changelog3
-rw-r--r--debian/conf-available/10-cgi.conf2
-rw-r--r--debian/lighttpd.conf3
3 files changed, 6 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 1f9ae42..ff0c0fd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -17,6 +17,9 @@ lighttpd (1.4.19-2) UNRELEASED; urgency=low
* init.d: stopping an already stopped lighttpd, or starting an already
running one should not fail (Closes: 472122).
+ * Use $HTTP["remoteip"] =~ "127.0.0.1" in configuration snipplets so that it
+ works when ipv6 is enabled by default too (Closes: 473510).
+
-- Pierre Habouzit <madcoder@debian.org> Thu, 20 Mar 2008 00:53:45 +0100
lighttpd (1.4.19-1~bpo40+1) etch-backports; urgency=low
diff --git a/debian/conf-available/10-cgi.conf b/debian/conf-available/10-cgi.conf
index 507a034..aba48fa 100644
--- a/debian/conf-available/10-cgi.conf
+++ b/debian/conf-available/10-cgi.conf
@@ -8,7 +8,7 @@ server.modules += ( "mod_cgi" )
alias.url += ( "/cgi-bin/" => "/usr/lib/cgi-bin/" )
-$HTTP["remoteip"] == "127.0.0.1" {
+$HTTP["remoteip"] =~ "127.0.0.1" {
alias.url += ( "/cgi-bin/" => "/usr/lib/cgi-bin/" )
$HTTP["url"] =~ "^/cgi-bin/" {
cgi.assign = ( "" => "" )
diff --git a/debian/lighttpd.conf b/debian/lighttpd.conf
index f33882f..146302e 100644
--- a/debian/lighttpd.conf
+++ b/debian/lighttpd.conf
@@ -154,7 +154,8 @@ include_shell "/usr/share/lighttpd/include-conf-enabled.pl"
#### handle Debian Policy Manual, Section 11.5. urls
## by default allow them only from localhost
## (This must come last due to #445459)
-$HTTP["remoteip"] == "127.0.0.1" {
+## Note: =~ "127.0.0.1" works with ipv6 enabled, whereas == "127.0.0.1" doesn't
+$HTTP["remoteip"] =~ "127.0.0.1" {
alias.url += (
"/doc/" => "/usr/share/doc/",
"/images/" => "/usr/share/images/"