summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authorArno Töll <arno@debian.org>2012-11-21 23:03:42 +0100
committerArno Töll <arno@debian.org>2012-11-21 23:03:42 +0100
commit1b24d86e6b2179692e60091dec59f797cd308b9e (patch)
treec5502d40d82fdef69ab9c1e4ed69904fefea9ac1 /openwrt
parent6a6df8dc258631c6eaccb03bf08845241f6dfa4a (diff)
downloadlighttpd-1b24d86e6b2179692e60091dec59f797cd308b9e.tar.gz
Imported Upstream version 1.4.13upstream/1.4.13
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/Makefile.in2
-rw-r--r--openwrt/control4
-rw-r--r--openwrt/lighttpd.conf36
-rw-r--r--openwrt/lighttpd.mk12
-rw-r--r--openwrt/lighttpd.mk.in10
5 files changed, 32 insertions, 32 deletions
diff --git a/openwrt/Makefile.in b/openwrt/Makefile.in
index 8cd22be..2fba912 100644
--- a/openwrt/Makefile.in
+++ b/openwrt/Makefile.in
@@ -101,7 +101,6 @@ LIBS = @LIBS@
LIBTOOL = @LIBTOOL@
LN_S = @LN_S@
LTLIBOBJS = @LTLIBOBJS@
-LUACONFIG = @LUACONFIG@
LUA_CFLAGS = @LUA_CFLAGS@
LUA_LIBS = @LUA_LIBS@
MAINT = @MAINT@
@@ -134,6 +133,7 @@ SQLITE_LIBS = @SQLITE_LIBS@
SSL_LIB = @SSL_LIB@
STRIP = @STRIP@
U = @U@
+UUID_LIBS = @UUID_LIBS@
VERSION = @VERSION@
XML_CFLAGS = @XML_CFLAGS@
XML_LIBS = @XML_LIBS@
diff --git a/openwrt/control b/openwrt/control
index ec80f98..d83440a 100644
--- a/openwrt/control
+++ b/openwrt/control
@@ -1,8 +1,8 @@
Package: lighttpd
-Version: 1.4.12
+Version: 1.4.13
Architecture: mipsel
Maintainer: Jan Kneschke <jan@kneschke.de>
-Source: http://jan.kneschke.de/projects/lighttpd/download/lighttpd-1.4.12.tar.gz
+Source: http://jan.kneschke.de/projects/lighttpd/download/lighttpd-1.4.13.tar.gz
Section: net
Priority: optional
Depends:
diff --git a/openwrt/lighttpd.conf b/openwrt/lighttpd.conf
index 42d2f76..b17519d 100644
--- a/openwrt/lighttpd.conf
+++ b/openwrt/lighttpd.conf
@@ -1,5 +1,5 @@
# lighttpd configuration file
-#
+#
# use a it as base for lighttpd 1.0.0 and above
#
# $Id: lighttpd.conf,v 1.6 2004/08/29 09:44:53 weigon Exp $
@@ -11,12 +11,12 @@
# all other module should only be loaded if really neccesary
# - saves some time
# - saves memory
-server.modules = (
-# "mod_rewrite",
-# "mod_redirect",
- "mod_access",
-# "mod_auth",
-# "mod_status",
+server.modules = (
+# "mod_rewrite",
+# "mod_redirect",
+ "mod_access",
+# "mod_auth",
+# "mod_status",
# "mod_fastcgi",
# "mod_simple_vhost",
# "mod_evhost",
@@ -25,10 +25,10 @@ server.modules = (
# "mod_ssi",
# "mod_usertrack",
# "mod_rrdtool",
-# "mod_accesslog"
+# "mod_accesslog"
)
-## a static document-root, for virtual-hosting take look at the
+## a static document-root, for virtual-hosting take look at the
## server.virtual-* options
server.document-root = "/www/"
@@ -36,11 +36,11 @@ server.document-root = "/www/"
# server.errorlog = ""
# files to check for if .../ is requested
-server.indexfiles = ( "index.php", "index.html",
+server.indexfiles = ( "index.php", "index.html",
"index.htm", "default.htm" )
# mimetype mapping
-mimetype.assign = (
+mimetype.assign = (
".pdf" => "application/pdf",
".sig" => "application/pgp-signature",
".spl" => "application/futuresplash",
@@ -131,7 +131,7 @@ url.access-deny = ( "~", ".inc" )
#simple-vhost.document-root = "/pages/"
-##
+##
## Format: <errorfile-prefix><status>.html
## -> ..../status-404.html for 'File not found'
#server.errorfile-prefix = "/home/weigon/projects/lighttpd/doc/status-"
@@ -160,8 +160,8 @@ url.access-deny = ( "~", ".inc" )
#### fastcgi module
## read fastcgi.txt for more info
#fastcgi.server = ( ".php" =>
-# ( "grisu" =>
-# (
+# ( "grisu" =>
+# (
# "host" => "192.168.2.10",
# "port" => 1026
# )
@@ -191,14 +191,14 @@ url.access-deny = ( "~", ".inc" )
# auth.backend.ldap.base-dn = "dc=my-domain,dc=com"
# auth.backend.ldap.filter = "(uid=$)"
-# auth.require = ( "/server-status" =>
-# (
+# auth.require = ( "/server-status" =>
+# (
# "method" => "digest",
# "realm" => "download archiv",
# "require" => "group=www|user=jan|host=192.168.2.10"
# ),
-# "/server-info" =>
-# (
+# "/server-info" =>
+# (
# "method" => "digest",
# "realm" => "download archiv",
# "require" => "group=www|user=jan|host=192.168.2.10"
diff --git a/openwrt/lighttpd.mk b/openwrt/lighttpd.mk
index e198e3f..c4bf1de 100644
--- a/openwrt/lighttpd.mk
+++ b/openwrt/lighttpd.mk
@@ -10,7 +10,7 @@
# For this example we'll use a fairly simple package that compiles easily
# and has sources available for download at sourceforge
-LIGHTTPD=lighttpd-1.4.12
+LIGHTTPD=lighttpd-1.4.13
LIGHTTPD_TARGET=.built
LIGHTTPD_DIR=$(BUILD_DIR)/$(LIGHTTPD)
LIGHTTPD_IPK=$(BUILD_DIR)/$(LIGHTTPD)_mipsel.ipk
@@ -28,7 +28,7 @@ $(DL_DIR)/$(LIGHTTPD_SOURCE) :
$(LIGHTTPD_DIR)/.unpacked: $(DL_DIR)/$(LIGHTTPD_SOURCE)
gzip -cd $(DL_DIR)/$(LIGHTTPD_SOURCE) | tar -C $(BUILD_DIR) -xvf -
touch $(LIGHTTPD_DIR)/.unpacked
-
+
# if we have the sources unpacked, we need to configure them
$(LIGHTTPD_DIR)/.configured: $(LIGHTTPD_DIR)/.unpacked
(cd $(LIGHTTPD_DIR); rm -rf config.cache; \
@@ -48,14 +48,14 @@ $(LIGHTTPD_DIR)/.configured: $(LIGHTTPD_DIR)/.unpacked
--program-transform-name="s,y,y," \
);
touch $(LIGHTTPD_DIR)/.configured
-
-
+
+
# now that we have it all in place, just build it
$(LIGHTTPD_DIR)/$(LIGHTTPD_TARGET): $(LIGHTTPD_DIR)/.configured
- cd $(LIGHTTPD_DIR) && $(MAKE) CC=$(TARGET_CC) DESTDIR="$(LIGHTTPD_IPK_DIR)" install
+ cd $(LIGHTTPD_DIR) && $(MAKE) CC=$(TARGET_CC) DESTDIR="$(LIGHTTPD_IPK_DIR)" install
$(STAGING_DIR)/bin/sstrip $(LIGHTTPD_IPK_DIR)/usr/sbin/lighttpd
touch $(LIGHTTPD_DIR)/$(LIGHTTPD_TARGET)
-
+
$(LIGHTTPD_IPK): uclibc $(LIGHTTPD_DIR)/$(LIGHTTPD_TARGET)
mkdir -p $(LIGHTTPD_IPK_DIR)/CONTROL
mkdir -p $(LIGHTTPD_IPK_DIR)/etc/init.d
diff --git a/openwrt/lighttpd.mk.in b/openwrt/lighttpd.mk.in
index 9ee6170..85cd2f2 100644
--- a/openwrt/lighttpd.mk.in
+++ b/openwrt/lighttpd.mk.in
@@ -28,7 +28,7 @@ $(DL_DIR)/$(LIGHTTPD_SOURCE) :
$(LIGHTTPD_DIR)/.unpacked: $(DL_DIR)/$(LIGHTTPD_SOURCE)
gzip -cd $(DL_DIR)/$(LIGHTTPD_SOURCE) | tar -C $(BUILD_DIR) -xvf -
touch $(LIGHTTPD_DIR)/.unpacked
-
+
# if we have the sources unpacked, we need to configure them
$(LIGHTTPD_DIR)/.configured: $(LIGHTTPD_DIR)/.unpacked
(cd $(LIGHTTPD_DIR); rm -rf config.cache; \
@@ -48,14 +48,14 @@ $(LIGHTTPD_DIR)/.configured: $(LIGHTTPD_DIR)/.unpacked
--program-transform-name="s,y,y," \
);
touch $(LIGHTTPD_DIR)/.configured
-
-
+
+
# now that we have it all in place, just build it
$(LIGHTTPD_DIR)/$(LIGHTTPD_TARGET): $(LIGHTTPD_DIR)/.configured
- cd $(LIGHTTPD_DIR) && $(MAKE) CC=$(TARGET_CC) DESTDIR="$(LIGHTTPD_IPK_DIR)" install
+ cd $(LIGHTTPD_DIR) && $(MAKE) CC=$(TARGET_CC) DESTDIR="$(LIGHTTPD_IPK_DIR)" install
$(STAGING_DIR)/bin/sstrip $(LIGHTTPD_IPK_DIR)/usr/sbin/lighttpd
touch $(LIGHTTPD_DIR)/$(LIGHTTPD_TARGET)
-
+
$(LIGHTTPD_IPK): uclibc $(LIGHTTPD_DIR)/$(LIGHTTPD_TARGET)
mkdir -p $(LIGHTTPD_IPK_DIR)/CONTROL
mkdir -p $(LIGHTTPD_IPK_DIR)/etc/init.d