summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in90
1 files changed, 49 insertions, 41 deletions
diff --git a/configure.in b/configure.in
index 74bca03..f0c789f 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.57)
-AC_INIT(lighttpd, 1.4.12, jan@kneschke.de)
+AC_INIT(lighttpd, 1.4.13, jan@kneschke.de)
AC_CONFIG_SRCDIR([src/server.c])
AC_CANONICAL_TARGET
@@ -40,13 +40,13 @@ dnl more automake stuff
AM_C_PROTOTYPES
dnl libtool
-AC_DISABLE_STATIC
+AC_DISABLE_STATIC
AC_ENABLE_SHARED
AC_LIBTOOL_DLOPEN
AC_PROG_LIBTOOL
-dnl for solaris
+dnl for solaris
CPPFLAGS="${CPPFLAGS} -D_REENTRANT -D__EXTENSIONS__"
# Checks for header files.
@@ -56,7 +56,7 @@ AC_CHECK_HEADERS([arpa/inet.h fcntl.h netinet/in.h stdlib.h string.h \
sys/socket.h sys/time.h unistd.h sys/sendfile.h sys/uio.h \
getopt.h sys/epoll.h sys/select.h poll.h sys/poll.h sys/devpoll.h sys/filio.h \
sys/mman.h sys/event.h sys/port.h pwd.h sys/syslimits.h \
-sys/resource.h sys/un.h syslog.h sys/prctl.h])
+sys/resource.h sys/un.h syslog.h sys/prctl.h uuid/uuid.h])
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
@@ -90,7 +90,7 @@ AC_ARG_WITH(mysql,
[WITH_MYSQL=$withval],[WITH_MYSQL=no])
if test "$WITH_MYSQL" != "no"; then
- AC_MSG_RESULT(yes)
+ AC_MSG_RESULT(yes)
if test "$WITH_MYSQL" = "yes"; then
AC_PATH_PROG(MYSQL_CONFIG, mysql_config)
else
@@ -237,8 +237,8 @@ if test "x$use_openssl" = "xyes"; then
AC_CHECK_HEADERS([openssl/ssl.h])
OLDLIBS="$LIBS"
- AC_CHECK_LIB(crypto, BIO_f_base64, [
- AC_CHECK_LIB(ssl, SSL_new, [ SSL_LIB="-lssl -lcrypto"
+ AC_CHECK_LIB(crypto, BIO_f_base64, [
+ AC_CHECK_LIB(ssl, SSL_new, [ SSL_LIB="-lssl -lcrypto"
AC_DEFINE(HAVE_LIBSSL, [], [Have libssl]) ], [], [ -lcrypto "$DL_LIB" ])
], [], [])
LIBS="$OLDLIBS"
@@ -253,7 +253,7 @@ AC_MSG_RESULT([$WITH_PCRE])
if test "x$cross_compiling" = xno -a "$WITH_PCRE" != "no"; then
AC_PATH_PROG(PCRECONFIG, pcre-config)
- if test x"$PCRECONFIG" != x; then
+ if test x"$PCRECONFIG" != x; then
PCRE_LIB=`$PCRECONFIG --libs`
CPPFLAGS="$CPPFLAGS `$PCRECONFIG --cflags`"
OLDLIBS="$LIBS"
@@ -339,7 +339,24 @@ if test "$WITH_WEBDAV_PROPS" != "no"; then
AC_DEFINE([HAVE_SQLITE3], [1], [libsqlite3])
AC_DEFINE([HAVE_SQLITE3_H], [1], [sqlite3.h])
])
+
+ AC_MSG_CHECKING(for locks in mod_webdav)
+ AC_ARG_WITH(webdav-locks, AC_HELP_STRING([--with-webdav-locks],[locks in mod_webdav]),
+ [WITH_WEBDAV_LOCKS=$withval],[WITH_WEBDAV_LOCKS=no])
+ AC_MSG_RESULT([$WITH_WEBDAV_LOCKS])
+
+ if test "$WITH_WEBDAV_LOCKS" != "no"; then
+ AC_CHECK_LIB(uuid, uuid_unparse, [
+ AC_CHECK_HEADERS([uuid/uuid.h],[
+ UUID_LIBS=-luuid
+ AC_DEFINE([HAVE_UUID], [1], [libuuid])
+ AC_DEFINE([HAVE_UUID_H], [1], [uuid/uuid.h is available])
+ ])
+ ])
+
+ fi
fi
+AC_SUBST(UUID_LIBS)
dnl Check for gdbm
AC_MSG_CHECKING(for gdbm)
@@ -373,7 +390,7 @@ if test "$WITH_MEMCACHE" != "no"; then
])
AC_SUBST(MEMCACHE_LIB)
fi
-
+
dnl Check for lua
AC_MSG_CHECKING(if lua-support is requested)
AC_ARG_WITH(lua, AC_HELP_STRING([--with-lua],[lua engine for mod_cml]),
@@ -381,30 +398,13 @@ AC_ARG_WITH(lua, AC_HELP_STRING([--with-lua],[lua engine for mod_cml]),
AC_MSG_RESULT($WITH_LUA)
if test "$WITH_LUA" != "no"; then
- AC_PATH_PROG(LUACONFIG, lua-config)
-
- if test x"$LUACONFIG" != x; then
- LUA_CFLAGS=`$LUACONFIG --include`
- LUA_LIBS=`$LUACONFIG --libs --extralibs`
+ if test "$WITH_LUA" == "yes"; then
+ WITH_LUA=lua
+ fi
+ PKG_CHECK_MODULES(LUA, $WITH_LUA >= 5.1, [
AC_DEFINE([HAVE_LUA], [1], [liblua])
AC_DEFINE([HAVE_LUA_H], [1], [lua.h])
- else
- AC_CHECK_LIB(lua, lua_open, [
- AC_CHECK_HEADERS([lua.h],[
- LUA_LIBS="-llua -llualib"
- AC_DEFINE([HAVE_LUA], [1], [liblua])
- AC_DEFINE([HAVE_LUA_H], [1], [lua.h])
- ])
- ])
- fi
-
- if test x"$LUA_LIBS" = x; then
- # try pkgconfig
- PKG_CHECK_MODULES(LUA, lua >= 5.0, [
- AC_DEFINE([HAVE_LUA], [1], [liblua])
- AC_DEFINE([HAVE_LUA_H], [1], [lua.h])
- ])
- fi
+ ])
AC_SUBST(LUA_CFLAGS)
AC_SUBST(LUA_LIBS)
@@ -472,13 +472,13 @@ if test "x$ac_cv_func_sendfile" = xyes; then
int o = 0;
if (-1 == sendfile(-1, 0, &o, 0) && errno == ENOSYS) return -1;
return 0;
- } ],
- AC_MSG_RESULT(yes),
- [ AC_MSG_RESULT(no)
+ } ],
+ AC_MSG_RESULT(yes),
+ [ AC_MSG_RESULT(no)
AC_DEFINE([HAVE_SENDFILE_BROKEN], [1], [broken sendfile]) ] )
else
- AC_MSG_RESULT(no, cross-compiling)
- AC_DEFINE([HAVE_SENDFILE_BROKEN], [1], [broken sendfile])
+ AC_MSG_RESULT(no, cross-compiling)
+ AC_DEFINE([HAVE_SENDFILE_BROKEN], [1], [broken sendfile])
fi
fi
@@ -498,7 +498,7 @@ if test x$ipv6 = xtrue; then
#include <sys/socket.h>
#include <netinet/in.h>], [struct sockaddr_in6 s; struct in6_addr t=in6addr_any; int i=AF_INET6; s; t.s6_addr[0] = 0; ],
[ac_cv_ipv6_support=yes], [ac_cv_ipv6_support=no])])
-
+
if test "$ac_cv_ipv6_support" = yes; then
AC_DEFINE(HAVE_IPV6,1,[Whether to enable IPv6 support])
fi
@@ -510,7 +510,7 @@ AM_CONDITIONAL(CROSS_COMPILING, test "x$cross_compiling" = xyes)
dnl check for fastcgi lib, for the tests only
fastcgi_found=no
AC_CHECK_LIB(fcgi, FCGI_Accept, [
- AC_CHECK_HEADERS([fastcgi.h],[
+ AC_CHECK_HEADERS([fastcgi.h fastcgi/fastcgi.h],[
fastcgi_found=yes
])
])
@@ -519,12 +519,12 @@ AM_CONDITIONAL(CHECK_WITH_FASTCGI, test "x$fastcgi_found" = xyes)
if test "${GCC}" = "yes"; then
- CFLAGS="${CFLAGS} -Wall -W -Wshadow -pedantic"
+ CFLAGS="${CFLAGS} -Wall -W -Wshadow -pedantic -std=gnu99"
fi
dnl build version-id
LIGHTTPD_VERSION_ID=`echo $PACKAGE_VERSION | $AWK -F '.' '{print "(" $1 " << 16 | " $2 " << 8 | " $3 ")"}'`
-AC_DEFINE_UNQUOTED([LIGHTTPD_VERSION_ID], [$LIGHTTPD_VERSION_ID], [lighttpd-version-id])
+AC_DEFINE_UNQUOTED([LIGHTTPD_VERSION_ID], [$LIGHTTPD_VERSION_ID], [lighttpd-version-id])
AC_CONFIG_FILES([Makefile src/Makefile doc/Makefile tests/Makefile \
tests/docroot/Makefile \
@@ -538,7 +538,7 @@ AC_CONFIG_FILES([Makefile src/Makefile doc/Makefile tests/Makefile \
AC_OUTPUT
-do_build="mod_cgi mod_fastcgi mod_proxy mod_evhost mod_simple_vhost mod_access mod_alias mod_setenv mod_usertrack mod_auth mod_status mod_accesslog mod_rrdtool mod_secdownload mod_expire mod_compress mod_dirlisting mod_indexfiles mod_userdir mod_webdav mod_staticfile mod_scgi mod_flv_streaming"
+do_build="mod_cgi mod_fastcgi mod_proxy mod_evhost mod_simple_vhost mod_access mod_alias mod_setenv mod_usertrack mod_auth mod_status mod_accesslog mod_rrdtool mod_secdownload mod_expire mod_compress mod_dirlisting mod_indexfiles mod_userdir mod_webdav mod_staticfile mod_scgi mod_flv_streaming"
plugins="mod_rewrite mod_redirect mod_ssi mod_trigger_b4_dl"
features="regex-conditionals"
@@ -642,6 +642,14 @@ else
disable_feature="$disable_feature $features"
fi
+features="webdav-locks"
+if test "x$UUID_LIBS" \!= x; then
+ enable_feature="$enable_feature $features"
+else
+ disable_feature="$disable_feature $features"
+fi
+
+
## output
$ECHO