summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJo Shields <jo.shields@xamarin.com>2015-12-10 12:09:58 +0000
committerJo Shields <jo.shields@xamarin.com>2015-12-10 12:38:48 +0000
commit546ee96c637d4db539f5539555ee2c5b6d5dd009 (patch)
tree362d9f720ecc99282118ec86e517a67d55c5bd53
parent8c4db6f0b622634a7ea634e6b33d19df45e9f23b (diff)
downloadmono-546ee96c637d4db539f5539555ee2c5b6d5dd009.tar.gz
I... have no idea how these deltas ended up existing, vs. the tarball. Thanks, git, you weird little monkey.
-rw-r--r--mcs/class/System.Data.Services.Client/Makefile1
-rw-r--r--mcs/class/System.Data/ReferenceSources/ResCategoryAttribute.cs12
-rw-r--r--mcs/class/System.ServiceModel.Web/Makefile1
3 files changed, 12 insertions, 2 deletions
diff --git a/mcs/class/System.Data.Services.Client/Makefile b/mcs/class/System.Data.Services.Client/Makefile
index cb91d61296..108d98cf14 100644
--- a/mcs/class/System.Data.Services.Client/Makefile
+++ b/mcs/class/System.Data.Services.Client/Makefile
@@ -18,7 +18,6 @@ ifneq (2.1, $(FRAMEWORK_VERSION))
LIB_REFS += WindowsBase
endif
endif
-endif
include ../../build/library.make
diff --git a/mcs/class/System.Data/ReferenceSources/ResCategoryAttribute.cs b/mcs/class/System.Data/ReferenceSources/ResCategoryAttribute.cs
new file mode 100644
index 0000000000..d8086404a8
--- /dev/null
+++ b/mcs/class/System.Data/ReferenceSources/ResCategoryAttribute.cs
@@ -0,0 +1,12 @@
+using System.ComponentModel;
+
+namespace System.Data
+{
+ sealed class ResCategoryAttribute : CategoryAttribute
+ {
+ public ResCategoryAttribute (string category)
+ : base (category)
+ {
+ }
+ }
+} \ No newline at end of file
diff --git a/mcs/class/System.ServiceModel.Web/Makefile b/mcs/class/System.ServiceModel.Web/Makefile
index e84e89f426..a278ec14ae 100644
--- a/mcs/class/System.ServiceModel.Web/Makefile
+++ b/mcs/class/System.ServiceModel.Web/Makefile
@@ -21,7 +21,6 @@ ifeq (4, $(FRAMEWORK_VERSION_MAJOR))
LIB_REFS += System.ServiceModel.Activation
endif
endif
-endif
TEST_MCS_FLAGS = $(LIB_MCS_FLAGS)