summaryrefslogtreecommitdiff
path: root/man
diff options
context:
space:
mode:
authorMirco Bauer <meebey@meebey.net>2009-12-12 19:51:58 +0100
committerMirco Bauer <meebey@meebey.net>2009-12-12 19:51:58 +0100
commitf61d205923b75b9159ca84e5aaa15053328f8519 (patch)
treeb10a632549fd63ec21696cf5a54ce6287d73f7a7 /man
parentb9af3bcea75b9518b9147583ca7760d673e95e0f (diff)
downloadmono-f61d205923b75b9159ca84e5aaa15053328f8519.tar.gz
Imported Upstream version 2.4.3+dfsgupstream/2.4.3+dfsg
Diffstat (limited to 'man')
-rw-r--r--man/ChangeLog13
-rw-r--r--man/Makefile.am2
-rw-r--r--man/Makefile.in26
-rw-r--r--man/lc.187
-rw-r--r--man/mono.116
-rw-r--r--man/xbuild.188
6 files changed, 215 insertions, 17 deletions
diff --git a/man/ChangeLog b/man/ChangeLog
index e7e4722c00..a347d08e8a 100644
--- a/man/ChangeLog
+++ b/man/ChangeLog
@@ -1,3 +1,16 @@
+2009-10-11 Ankit Jain <jankit@novell.com>
+
+ * xbuild.1: Add info about env var XBUILD_COLORS.
+
+2009-09-24 Ankit Jain <jankit@novell.com>
+
+ * xbuild.1: Add info about env var XBUILD_EMIT_SOLUTION.
+
+2009-08-21 Ankit Jain <jankit@novell.com>
+
+ * Makefile.am (man_MANS): Add xbuild.1
+ * xbuild.1: New.
+
2009-04-09 Jonathan Pryor <jpryor@novell.com>
* mdoc-update.1: Document -L, -r options.
diff --git a/man/Makefile.am b/man/Makefile.am
index 1c3fc4078c..41d9ea02a6 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -11,6 +11,7 @@ man_MANS = \
genxs.1 \
httpcfg.1 \
ilasm.1 \
+ lc.1 \
macpack.1 \
makecert.1 \
mconfig.1 \
@@ -49,6 +50,7 @@ man_MANS = \
soapsuds.1 \
sqlsharp.1 \
wsdl.1 \
+ xbuild.1 \
xsd.1
EXTRA_DIST = $(man_MANS)
diff --git a/man/Makefile.in b/man/Makefile.in
index 97cb4b21c1..ed43c4f5d8 100644
--- a/man/Makefile.in
+++ b/man/Makefile.in
@@ -35,7 +35,10 @@ target_triplet = @target@
subdir = man
DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in ChangeLog
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
-am__aclocal_m4_deps = $(top_srcdir)/nls.m4 $(top_srcdir)/po.m4 \
+am__aclocal_m4_deps = $(top_srcdir)/libtool.m4 \
+ $(top_srcdir)/ltoptions.m4 $(top_srcdir)/ltsugar.m4 \
+ $(top_srcdir)/ltversion.m4 $(top_srcdir)/lt~obsolete.m4 \
+ $(top_srcdir)/nls.m4 $(top_srcdir)/po.m4 \
$(top_srcdir)/progtest.m4 $(top_srcdir)/acinclude.m4 \
$(top_srcdir)/configure.in
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
@@ -74,10 +77,6 @@ CFLAGS = @CFLAGS@
CFLAGS_FOR_BUILD = @CFLAGS_FOR_BUILD@
CPP = @CPP@
CPPFLAGS = @CPPFLAGS@
-CXX = @CXX@
-CXXCPP = @CXXCPP@
-CXXDEPMODE = @CXXDEPMODE@
-CXXFLAGS = @CXXFLAGS@
CYGPATH_W = @CYGPATH_W@
DEFS = @DEFS@
DEPDIR = @DEPDIR@
@@ -87,14 +86,13 @@ DOLT_BASH = @DOLT_BASH@
DSYMUTIL = @DSYMUTIL@
DTRACE = @DTRACE@
DTRACEFLAGS = @DTRACEFLAGS@
-ECHO = @ECHO@
+DUMPBIN = @DUMPBIN@
ECHO_C = @ECHO_C@
ECHO_N = @ECHO_N@
ECHO_T = @ECHO_T@
EGREP = @EGREP@
EXEEXT = @EXEEXT@
-F77 = @F77@
-FFLAGS = @FFLAGS@
+FGREP = @FGREP@
GETTEXT_MACRO_VERSION = @GETTEXT_MACRO_VERSION@
GLIB_CFLAGS = @GLIB_CFLAGS@
GLIB_LIBS = @GLIB_LIBS@
@@ -112,6 +110,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
INTL = @INTL@
+LD = @LD@
LDFLAGS = @LDFLAGS@
LIBC = @LIBC@
LIBGC_CFLAGS = @LIBGC_CFLAGS@
@@ -120,6 +119,7 @@ LIBGC_STATIC_LIBS = @LIBGC_STATIC_LIBS@
LIBOBJS = @LIBOBJS@
LIBS = @LIBS@
LIBTOOL = @LIBTOOL@
+LIPO = @LIPO@
LN_S = @LN_S@
LTCOMPILE = @LTCOMPILE@
LTCXXCOMPILE = @LTCXXCOMPILE@
@@ -131,11 +131,14 @@ MONO_DL_NEED_USCORE = @MONO_DL_NEED_USCORE@
MSGFMT = @MSGFMT@
MSGFMT_015 = @MSGFMT_015@
MSGMERGE = @MSGMERGE@
+NM = @NM@
NMEDIT = @NMEDIT@
OBJDUMP = @OBJDUMP@
OBJEXT = @OBJEXT@
OPROFILE_CFLAGS = @OPROFILE_CFLAGS@
OPROFILE_LIBS = @OPROFILE_LIBS@
+OTOOL = @OTOOL@
+OTOOL64 = @OTOOL64@
PACKAGE = @PACKAGE@
PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
PACKAGE_NAME = @PACKAGE_NAME@
@@ -164,8 +167,7 @@ abs_srcdir = @abs_srcdir@
abs_top_builddir = @abs_top_builddir@
abs_top_srcdir = @abs_top_srcdir@
ac_ct_CC = @ac_ct_CC@
-ac_ct_CXX = @ac_ct_CXX@
-ac_ct_F77 = @ac_ct_F77@
+ac_ct_DUMPBIN = @ac_ct_DUMPBIN@
am__include = @am__include@
am__leading_dot = @am__leading_dot@
am__quote = @am__quote@
@@ -205,6 +207,7 @@ libmono_ldflags = @libmono_ldflags@
libsuffix = @libsuffix@
localedir = @localedir@
localstatedir = @localstatedir@
+lt_ECHO = @lt_ECHO@
mandir = @mandir@
mcs_topdir = @mcs_topdir@
mcs_topdir_from_srcdir = @mcs_topdir_from_srcdir@
@@ -228,6 +231,7 @@ target_alias = @target_alias@
target_cpu = @target_cpu@
target_os = @target_os@
target_vendor = @target_vendor@
+top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
man_MANS = \
@@ -243,6 +247,7 @@ man_MANS = \
genxs.1 \
httpcfg.1 \
ilasm.1 \
+ lc.1 \
macpack.1 \
makecert.1 \
mconfig.1 \
@@ -281,6 +286,7 @@ man_MANS = \
soapsuds.1 \
sqlsharp.1 \
wsdl.1 \
+ xbuild.1 \
xsd.1
EXTRA_DIST = $(man_MANS)
diff --git a/man/lc.1 b/man/lc.1
new file mode 100644
index 0000000000..9e5f307ee5
--- /dev/null
+++ b/man/lc.1
@@ -0,0 +1,87 @@
+.\"
+.\" lc manual page.
+.\" (C) 2009 Carlo Kok
+.\"
+.\" Author:
+.\" Carlo Kok (ck@remobjects.com)
+.\"
+.de Sp \" Vertical space (when we can't use .PP)
+.if t .sp .5v
+.if n .sp
+..
+.TH lc "Mono 2.6"
+.SH NAME
+lc \- Mono License Compiler
+.SH SYNOPSIS
+.PP
+.B lc -c filename -t targetassembly [-i reference...] [-v] [-o outputpath] [-nologo]
+.SH DESCRIPTION
+\fIlc\fP tool is a license compiler for Mono. It's used to convert a
+licenses.licx file to a resource that can be embedded into an executable.
+.PP
+When using commercial components for .NET they often require a license
+resource at runtime to make sure the developer was licensed to use this
+control. The most common way of making sure the component was properly
+licensed is by using license resources. At compile time the developer
+uses the \fIlc\fP tool to convert a licenses.licx file to a
+programname.exe.resources file and embed that as a managed resource
+during compilation.
+.SH RUNTIME OPTIONS
+The following options are available:
+.TP
+\fB--complist=filename\fR, \fB-c filename\fR
+This option is used to specify the input file, the licenses.licx file
+to create a license reesource for. This option is required. The license
+compiler will read each line in this file and try to load the types
+specified on that line.
+.TP
+\fB--target=assemblyname\fR, \fB-t targetassembly\fR
+full assembly name with file extension for the target assembly. The
+license compiler uses this as a key when compiling the licenses. It
+has to match the assembly the resource will be embedded in. This option
+is required.
+.TP
+\fB--load=reference\fR, \fB-i reference\fR
+Assembly reference to load before trying to compile a license. This
+option is needed for assemblies where the references are not in the
+gac. Compilers should pass all references to the license compiler.
+.TP
+\fB--verbose,\fR, \fB-v\fR
+Gives more verbose output about the license compiling process.
+.TP
+\fB--help\fR, \fB-h\fR
+Displays usage instructions.
+.TP
+\fB--output=path\fR, \fB-o path\fR
+Target path file the licenses resource. By default the license
+compiler emits the resource in the current directory. The filename
+will always match the target assembly passed to --target with .licenses
+added.
+.TP
+\fB--nologo\fR
+Do not emit the "Mono License Compiler" logo on stdout while compilng.
+
+.SH LICENSE FILES
+The format for the license files (licenses.licx) is the following:
+.nf
+ # comment
+ namespace.type, assemblyname
+ namespace.type, full-assemblyname
+.fi
+.Sp
+All lines starting with a # are ignored. the first form requires
+that the assembly was loaded through the --load,-i option but
+does not require the full assembly name, only the first part.
+
+The second form requires the full assembly name including locale,
+version and publickeytoken.
+
+.SH MAILING LISTS
+Mailing lists are listed at the
+http://www.mono-project.com/Mailing_Lists
+.SH WEB SITE
+http://www.mono-project.com
+.SH SEE ALSO
+.PP
+mono(1), mcs(1)
+
diff --git a/man/mono.1 b/man/mono.1
index a9e0937029..bc6b261493 100644
--- a/man/mono.1
+++ b/man/mono.1
@@ -5,7 +5,7 @@
.\" Author:
.\" Miguel de Icaza (miguel@gnu.org)
.\"
-.TH Mono "Mono 2.2"
+.TH Mono "Mono 2.4"
.SH NAME
mono \- Mono's ECMA-CLI native code generator (Just-in-Time and Ahead-of-Time)
.SH SYNOPSIS
@@ -1184,13 +1184,14 @@ For example, this would work from the shell:
.fi
If you are using mod_mono to host your web applications, you can use
the
-.B MonoSetEnv
-directive, like this:
+.B MonoIOMAP
+directive instead, like this:
.nf
- MonoSetEnv MONO_IOMAP=all
+ MonoIOMAP <appalias> all
.fi
+See mod_mono(8) for more details.
.TP
\fBMONO_MANAGED_WATCHER\fR
If set to "disabled", System.IO.FileSystemWatcher will use a file watcher
@@ -1218,8 +1219,8 @@ the Global Assembly Cache (see gacutil(1)) or having the dependent
libraries side-by-side with the main executable.
.Sp
For a complete description of recommended practices for application
-deployment, see the
-http://www.mono-project.com/Guidelines:Application_Deployment page.
+deployment, see
+http://www.mono-project.com/Guidelines:Application_Deployment
.TP
\fBMONO_RTC\fR
Experimental RTC support in the statistical profiler: if the user has
@@ -1500,7 +1501,8 @@ http://www.mono-project.com/Mailing_Lists
http://www.mono-project.com
.SH SEE ALSO
.PP
-certmgr(1), csharp(1), mcs(1), mdb(1), monocov(1), monodis(1), mono-config(5), mozroots(1), xsp(1).
+certmgr(1), csharp(1), mcs(1), mdb(1), monocov(1), monodis(1),
+mono-config(5), mozroots(1), pdb2mdb(1), xsp(1), mod_mono(8).
.PP
For more information on AOT:
http://www.mono-project.com/AOT
diff --git a/man/xbuild.1 b/man/xbuild.1
new file mode 100644
index 0000000000..ec9472f633
--- /dev/null
+++ b/man/xbuild.1
@@ -0,0 +1,88 @@
+.TH "xbuild" 1
+.SH NAME
+xbuild \- Mono's tool to build MSBuild project files
+.SH SYNOPSIS
+.B xbuild
+[option] [project-file]
+.SH DESCRIPTION
+xbuild can be used to build MSBuild project files. Integrated Development
+Environments like MonoDevelop and "Microsoft Visual Studio .NET" use msbuild
+project file format.
+
+xbuild takes the path of the project or solution file to build, as the main argument.
+If no file is specified then it tries to build any solution file or project file in
+the current directory, that has a *proj extension.
+.SH OPTIONS
+.TP
+.B \//target:T1[,TN]
+List of targets to build
+.TP
+.B \//property:Name=Value
+Set or override project properties
+.TP
+.B \//logger:<logger>
+Custom logger to log build events
+.TP
+.B \//verbosity:<level>
+Logger verbosity level : quiet, minimal, normal, detailed, diagnostic
+.TP
+.B \//validate
+Validate the project file against the schema
+.TP
+.B \//validate:<schema>
+Validate the project file against the specified schema
+.TP
+.B \//consoleloggerparameters:<params>
+Parameters for the console logger
+.TP
+.B \//nologo
+Don't show the initial xbuild banner
+.TP
+.B \//help
+Show xbuild usage
+.TP
+.B \//version
+Display xbuild version
+.SH ENVIRONMENT VARIABLES
+.TP
+.I "XBUILD_EMIT_SOLUTION"
+If this variable is set, then the project file generated from a solution
+file is emitted.
+.TP
+.I "XBUILD_COLORS"
+If this variable is set, it contains a string of the form
+"type=foreground,type=.." that specifies which color to use to display
+errors/warnings etc on some terminals. Type here can be:
+
+.nf
+ errors, warnings, messages or events
+
+ events: These are project/target/task start and end event
+ messages.
+.fi
+
+.Sp
+The possible colors for foreground are:
+.B black, red, brightred, green, brightgreen, yellow, brightyellow,
+blue, brightblue, magenta, brightmagenta, cyan, brightcyan, grey,
+white and brightwhite.
+
+.Sp
+For example, you could set this variable from your shell:
+.nf
+ export XBUILD_COLORS
+ XBUILD_COLORS=errors=brightred,warnings=blue
+.fi
+.Sp
+
+You can disable the built-in color scheme by setting this variable to
+"disable".
+
+.SH SEE ALSO
+.BR mono(1), mcs(1)
+.SH COPYRIGHT
+Copyright (C) 2009 Novell, Inc (http://www.novell.com)
+.SH MAILING LISTS
+Visit http://lists.ximian.com/mailman/listinfo/mono-devel-list for details.
+.SH WEB SITE
+Visit: http://www.mono-project.com for details