summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c9192998d8..a4a959d1c4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,6 +27,7 @@ update_submodules:
.PHONY: update_submodules
EXTRA_DIST= \
+ README.md \
LICENSE \
autogen.sh \
build-mingw32.sh \
@@ -155,3 +156,9 @@ package-inputs:
done
echo "</root>" >> msvc/scripts/order.xml
+# Update llvm version in configure.in to the output of $LLVM_DIR/bin/llvm-config --version
+update-llvm-version:
+ if test "x$$LLVM_DIR" = "x"; then echo "Set the make variable LLVM_DIR to the directory containing the LLVM installation."; exit 1; fi
+ REV=`$(LLVM_DIR)/bin/llvm-config --version` && sed -e "s,expected_llvm_version=.*,expected_llvm_version=\"$$REV\"," < configure.in > tmp && mv tmp configure.in && echo "Version set to $$REV."
+
+