summaryrefslogtreecommitdiff
path: root/mcs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mcs/Makefile')
-rw-r--r--mcs/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/mcs/Makefile b/mcs/Makefile
index df6b9a117d..eae178de4a 100644
--- a/mcs/Makefile
+++ b/mcs/Makefile
@@ -14,6 +14,7 @@ mobile_SUBDIRS := build class
net_3_5_SUBDIRS := build class tools/xbuild
net_4_0_SUBDIRS := build class
net_4_5_SUBDIRS := build mcs class nunit24 ilasm tools tests errors docs
+xbuild_12_SUBDIRS := build class tools/xbuild
# List of test subdirs that should pass 100%
centum_tests := \
@@ -85,7 +86,7 @@ dir-check:
# fun specialty targets
-PROFILES = net_2_0 net_3_5 net_4_0 net_4_5
+PROFILES = net_2_0 net_3_5 net_4_0 net_4_5 xbuild_12
.PHONY: all-profiles $(STD_TARGETS:=-profiles)
all-profiles $(STD_TARGETS:=-profiles): %-profiles: profiles-do--%
@@ -104,6 +105,7 @@ profiles-do--run-test:
# Orchestrate the bootstrap here.
_boot_ = all clean install
+$(_boot_:%=profile-do--xbuild_12--%): profile-do--xbuild_12--%: profile-do--net_4_5--%
$(_boot_:%=profile-do--net_4_5--%): profile-do--net_4_5--%: profile-do--build--%
$(_boot_:%=profile-do--net_4_0--%): profile-do--net_4_0--%: profile-do--build--%
$(_boot_:%=profile-do--net_3_5--%): profile-do--net_3_5--%: profile-do--net_2_0--%